summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-07-22 11:28:53 +0200
committerRemi Collet <remi@remirepo.net>2019-07-22 11:28:53 +0200
commit43827495f81824d4028271ded6903e1f6f17bdeb (patch)
tree04cb89aee6fccce591f1a6e0f1086fdc4f9a6986
parent3abb79ec386c98c43eaf2681948760ac1774dbe1 (diff)
v8.0.17
-rw-r--r--7.patch44
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION6
-rw-r--r--php-pecl-mysql-xdevapi.spec8
4 files changed, 10 insertions, 50 deletions
diff --git a/7.patch b/7.patch
index dc0b483..44237c5 100644
--- a/7.patch
+++ b/7.patch
@@ -69,50 +69,6 @@ index 31aad8ff..3042cd56 100644
} while (0);
#define DATETIME_FMT_STR "%04u-%02u-%02u %02u:%02u:%02u"
ZVAL_NEW_STR(&zv, strpprintf(0, DATETIME_FMT_STR ,
-diff --git a/mysqlx_class_properties.cc b/mysqlx_class_properties.cc
-index 3f1b13b2..a167561a 100644
---- a/mysqlx_class_properties.cc
-+++ b/mysqlx_class_properties.cc
-@@ -126,7 +126,11 @@ mysqlx_property_get_value(zval * object, zval * member, int type, void ** cache_
-
-
- /* {{{ mysqlx_property_set_value */
-+#if PHP_VERSION_ID >= 70400
-+zval *
-+#else
- void
-+#endif
- mysqlx_property_set_value(zval * object, zval * member, zval * value, void **cache_slot)
- {
- zval tmp_member;
-@@ -158,7 +162,11 @@ mysqlx_property_set_value(zval * object, zval * member, zval * value, void **cac
- if (member == &tmp_member) {
- zval_dtor(member);
- }
-+#if PHP_VERSION_ID >= 70400
-+ DBG_RETURN(value);
-+#else
- DBG_VOID_RETURN;
-+#endif
- }
- /* }}} */
-
-diff --git a/mysqlx_class_properties.h b/mysqlx_class_properties.h
-index 878248fa..1e3758ec 100644
---- a/mysqlx_class_properties.h
-+++ b/mysqlx_class_properties.h
-@@ -45,7 +45,11 @@ struct st_mysqlx_property
- void mysqlx_add_properties(HashTable * ht, const st_mysqlx_property_entry* entries);
-
- zval * mysqlx_property_get_value(zval * object, zval * member, int type, void ** cache_slot, zval * rv);
-+#if PHP_VERSION_ID >= 70400
-+zval *mysqlx_property_set_value(zval * object, zval * member, zval * value, void ** cache_slot);
-+#else
- void mysqlx_property_set_value(zval * object, zval * member, zval * value, void ** cache_slot);
-+#endif
- int mysqlx_object_has_property(zval * object, zval *member, int has_set_exists, void ** cache_slot);
-
- void mysqlx_free_property_cb(zval *el);
diff --git a/xmysqlnd/xmysqlnd_protocol_dumper.cc b/xmysqlnd/xmysqlnd_protocol_dumper.cc
index aeccf049..63ce118e 100644
--- a/xmysqlnd/xmysqlnd_protocol_dumper.cc
diff --git a/PHPINFO b/PHPINFO
index 74a6951..f07faf9 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
mysql_xdevapi
mysql_xdevapi => enabled
-Version => mysql_xdevapi 8.0.16
+Version => mysql_xdevapi 8.0.17
Read timeout => 31536000
Collecting statistics => Yes
Collecting memory statistics => No
diff --git a/REFLECTION b/REFLECTION
index deea155..cc10e0b 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #125 mysql_xdevapi version 8.0.16 ] {
+Extension [ <persistent> extension #123 mysql_xdevapi version 8.0.17 ] {
- Dependencies {
Dependency [ standard (Required) ]
@@ -29,8 +29,8 @@ Extension [ <persistent> extension #125 mysql_xdevapi version 8.0.16 ] {
}
- Constants [40] {
- Constant [ string MYSQLX_VERSION ] { 8.0.16 }
- Constant [ integer MYSQLX_VERSION_ID ] { 80016 }
+ Constant [ string MYSQLX_VERSION ] { 8.0.17 }
+ Constant [ integer MYSQLX_VERSION_ID ] { 80017 }
Constant [ integer MYSQLX_CLIENT_SSL ] { 2048 }
Constant [ integer MYSQLX_TYPE_DECIMAL ] { 0 }
Constant [ integer MYSQLX_TYPE_TINY ] { 1 }
diff --git a/php-pecl-mysql-xdevapi.spec b/php-pecl-mysql-xdevapi.spec
index 8e12477..bf23aa2 100644
--- a/php-pecl-mysql-xdevapi.spec
+++ b/php-pecl-mysql-xdevapi.spec
@@ -24,8 +24,8 @@
Summary: MySQL database access functions
Name: %{?sub_prefix}php-pecl-mysql-xdevapi
-Version: 8.0.16
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 8.0.17
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: http://pecl.php.net/package/%{pecl_name}
@@ -322,6 +322,10 @@ fi
%changelog
+* Mon Jul 22 2019 Remi Collet <remi@remirepo.net> - 8.0.17-1
+- update to 8.0.17
+- adapt patch partially merged upstream
+
* Tue Jul 9 2019 Remi Collet <remi@remirepo.net> - 8.0.16-2
- add patch for PHP 7.4 from
https://github.com/php/pecl-database-mysql_xdevapi/pull/6