summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-11-28 08:02:51 +0100
committerRemi Collet <remi@php.net>2022-11-28 08:02:51 +0100
commit8ecf5dcd822a245b1d138b893ed843f2f38567b2 (patch)
tree9d7d3d38d6a2d47cbd411a3492b95535bc18becb
parentc7537a22ba77e92e6065a027875a64a300a1ba7d (diff)
update to 0.9.3
drop patch merged upstream
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION124
-rw-r--r--mustache-php82.patch42
-rw-r--r--php-pecl-mustache.spec12
4 files changed, 105 insertions, 77 deletions
diff --git a/PHPINFO b/PHPINFO
index 83d4f49..192f2a4 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -1,8 +1,8 @@
mustache
-Version => 0.9.2
-Released => 2020-11-12
+Version => 0.9.3
+Released => 2022-11-26
Revision => master
Authors => John Boehr <jbboehr@gmail.com> (lead)
Spec Version => 1.1.2
diff --git a/REFLECTION b/REFLECTION
index f235443..ee666bc 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,7 +1,7 @@
-Extension [ <persistent> extension #117 mustache version 0.9.2 ] {
+Extension [ <persistent> extension #122 mustache version 0.9.3 ] {
- Classes [7] {
- Class [ <internal:mustache> class MustacheAST ] {
+ Class [ <internal:mustache> class MustacheAST implements Stringable ] {
- Constants [0] {
}
@@ -13,14 +13,14 @@ Extension [ <persistent> extension #117 mustache version 0.9.2 ] {
}
- Properties [1] {
- Property [ <default> protected $binaryString ]
+ Property [ protected $binaryString = NULL ]
}
- Methods [5] {
Method [ <internal:mustache, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> $vars ]
+ Parameter #0 [ <optional> $vars = <default> ]
}
}
@@ -36,10 +36,11 @@ Extension [ <persistent> extension #117 mustache version 0.9.2 ] {
}
}
- Method [ <internal:mustache> public method __toString ] {
+ Method [ <internal:mustache, prototype Stringable> public method __toString ] {
- Parameters [0] {
}
+ - Return [ string ]
}
Method [ <internal:mustache> public method __wakeup ] {
@@ -172,7 +173,7 @@ Extension [ <persistent> extension #117 mustache version 0.9.2 ] {
}
}
- Class [ <internal:mustache> class MustacheTemplate ] {
+ Class [ <internal:mustache> class MustacheTemplate implements Stringable ] {
- Constants [0] {
}
@@ -184,26 +185,27 @@ Extension [ <persistent> extension #117 mustache version 0.9.2 ] {
}
- Properties [1] {
- Property [ <default> protected $template ]
+ Property [ protected $template = NULL ]
}
- Methods [2] {
Method [ <internal:mustache, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> $vars ]
+ Parameter #0 [ <optional> $vars = <default> ]
}
}
- Method [ <internal:mustache> public method __toString ] {
+ Method [ <internal:mustache, prototype Stringable> public method __toString ] {
- Parameters [0] {
}
+ - Return [ string ]
}
}
}
- Class [ <internal:mustache> class MustacheException extends Exception implements Throwable ] {
+ Class [ <internal:mustache> class MustacheException extends Exception implements Throwable, Stringable ] {
- Constants [0] {
}
@@ -215,52 +217,86 @@ Extension [ <persistent> extension #117 mustache version 0.9.2 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected $file = NULL ]
+ Property [ protected $line = NULL ]
}
- Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
- Class [ <internal:mustache> class MustacheParserException extends MustacheException implements Throwable ] {
+ Class [ <internal:mustache> class MustacheParserException extends MustacheException implements Stringable, Throwable ] {
- Constants [0] {
}
@@ -272,47 +308,81 @@ Extension [ <persistent> extension #117 mustache version 0.9.2 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected $file = NULL ]
+ Property [ protected $line = NULL ]
}
- Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
diff --git a/mustache-php82.patch b/mustache-php82.patch
deleted file mode 100644
index 9e40b5c..0000000
--- a/mustache-php82.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 4b998185887213029616163c6fa336d6a985ff06 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Tue, 13 Sep 2022 11:06:35 +0200
-Subject: [PATCH] fix __toString return type for PHP 8.2
-
----
- mustache_ast.cpp | 4 ++++
- mustache_template.cpp | 4 ++++
- 2 files changed, 8 insertions(+)
-
-diff --git a/mustache_ast.cpp b/mustache_ast.cpp
-index eb0ba06..70abc4b 100644
---- a/mustache_ast.cpp
-+++ b/mustache_ast.cpp
-@@ -24,7 +24,11 @@ ZEND_END_ARG_INFO()
- ZEND_BEGIN_ARG_INFO_EX(MustacheAST__toArray_args, ZEND_SEND_BY_VAL, ZEND_RETURN_VALUE, 0)
- ZEND_END_ARG_INFO()
-
-+#if PHP_VERSION_ID >= 80200
-+ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(MustacheAST____toString_args, 0, 0, IS_STRING, 0)
-+#else
- ZEND_BEGIN_ARG_INFO_EX(MustacheAST____toString_args, ZEND_SEND_BY_VAL, ZEND_RETURN_VALUE, 0)
-+#endif
- ZEND_END_ARG_INFO()
-
- ZEND_BEGIN_ARG_INFO_EX(MustacheAST____wakeup_args, ZEND_SEND_BY_VAL, ZEND_RETURN_VALUE, 0)
-diff --git a/mustache_template.cpp b/mustache_template.cpp
-index e25ab24..7cd47a6 100644
---- a/mustache_template.cpp
-+++ b/mustache_template.cpp
-@@ -17,7 +17,11 @@ ZEND_BEGIN_ARG_INFO_EX(MustacheTemplate____construct_args, ZEND_SEND_BY_VAL, ZEN
- ZEND_ARG_INFO(0, vars)
- ZEND_END_ARG_INFO()
-
-+#if PHP_VERSION_ID >= 80200
-+ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(MustacheTemplate____toString_args, 0, 0, IS_STRING, 0)
-+#else
- ZEND_BEGIN_ARG_INFO_EX(MustacheTemplate____toString_args, ZEND_SEND_BY_VAL, ZEND_RETURN_VALUE, 0)
-+#endif
- ZEND_END_ARG_INFO()
- /* }}} */
-
diff --git a/php-pecl-mustache.spec b/php-pecl-mustache.spec
index 6718440..fe55d35 100644
--- a/php-pecl-mustache.spec
+++ b/php-pecl-mustache.spec
@@ -16,19 +16,17 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 0.9.2
+%global upstream_version 0.9.3
#global upstream_prever RC2
Summary: Mustache templating language
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
-Patch0: %{pecl_name}-php82.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.0
@@ -67,8 +65,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1 -b .pr67
-
# Sanity check, really often broken
extver=$(sed -n '/PHP_MUSTACHE_VERSION/{s/.* "//;s/".*$//;p}' php_mustache.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -212,6 +208,10 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon Nov 28 2022 Remi Collet <remi@remirepo.net> - 0.9.3-1
+- update to 0.9.3
+- drop patch merged upstream
+
* Tue Sep 13 2022 Remi Collet <remi@remirepo.net> - 0.9.2-2
- add patch for PHP 8.2 from
https://github.com/jbboehr/php-mustache/pull/67