summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-pecl-msgpack-dev.spec317
1 files changed, 317 insertions, 0 deletions
diff --git a/php-pecl-msgpack-dev.spec b/php-pecl-msgpack-dev.spec
new file mode 100644
index 0000000..494d7bb
--- /dev/null
+++ b/php-pecl-msgpack-dev.spec
@@ -0,0 +1,317 @@
+# spec file for php-pecl-msgpack
+#
+# Copyright (c) 2012-2015 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%{?scl: %scl_package php-pecl-msgpack}
+%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
+%{!?__pecl: %global __pecl %{_bindir}/pecl}
+%{!?__php: %global __php %{_bindir}/php}
+
+%global pecl_name msgpack
+%global with_zts 0%{?__ztsphp:1}
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
+
+%if 0
+%global with_msgpack 1
+%else
+%global with_msgpack 0
+%endif
+
+Summary: API for communicating with MessagePack serialization
+Name: %{?scl_prefix}php-pecl-msgpack
+Version: 0.5.6
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+License: BSD
+Group: Development/Languages
+URL: http://pecl.php.net/package/msgpack
+Source: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+
+# https://github.com/msgpack/msgpack-php/issues/16
+Patch0: %{pecl_name}.patch
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+BuildRequires: %{?scl_prefix}php-devel
+BuildRequires: %{?scl_prefix}php-pear
+%if %{with_msgpack}
+BuildRequires: msgpack-devel
+%endif
+# https://github.com/msgpack/msgpack-php/issues/25
+ExcludeArch: ppc64
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
+# Other third party repo stuff
+Obsoletes: php53-pecl-%{pecl_name} <= %{version}
+Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php54-pecl-%{pecl_name} <= %{version}
+Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "5.5"
+Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "5.6"
+Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.0"
+Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
+%endif
+%endif
+
+%if 0%{?fedora} < 20 && 0%{?rhel} < 7
+# Filter shared private
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+%endif
+
+
+%description
+This extension provide API for communicating with MessagePack serialization.
+
+MessagePack is an efficient binary serialization format. It lets you exchange
+data among multiple languages like JSON but it's faster and smaller.
+For example, small integers (like flags or error code) are encoded into a
+single byte, and typical short strings only require an extra byte in addition
+to the strings themselves.
+
+If you ever wished to use JSON for convenience (storing an image with metadata)
+but could not for technical reasons (encoding, size, speed...), MessagePack is
+a perfect replacement.
+
+This extension is still EXPERIMENTAL.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection}.
+
+
+%package devel
+Summary: MessagePack developer files (header)
+Group: Development/Libraries
+Requires: %{name}%{?_isa} = %{version}-%{release}
+Requires: %{?scl_prefix}php-devel%{?_isa}
+
+%description devel
+These are the files needed to compile programs using MessagePack serializer.
+
+
+%prep
+%setup -q -c
+
+mv %{pecl_name}-%{version} NTS
+cd NTS
+%patch0 -p1 -b .build
+
+%if %{with_msgpack}
+# use system library
+rm -rf msgpack
+%endif
+
+# When this file will be removed, clean the description.
+[ -f EXPERIMENTAL ] || exit 1
+
+# Sanity check, really often broken
+extver=$(sed -n '/#define PHP_MSGPACK_VERSION/{s/.* "//;s/".*$//;p}' php_msgpack.h)
+if test "x${extver}" != "x%{version}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}.
+ exit 1
+fi
+cd ..
+
+%if %{with_zts}
+# duplicate for ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Drop in the bit of configuration
+cat > %{ini_name} << 'EOF'
+; Enable MessagePack extension module
+extension = %{pecl_name}.so
+
+; Configuration options
+
+;msgpack.error_display = On
+;msgpack.illegal_key_insert = Off
+;msgpack.php_only = On
+EOF
+
+
+%build
+cd NTS
+%{_bindir}/phpize
+%configure --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+rm -rf %{buildroot}
+# Install the NTS stuff
+make -C NTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+%if %{with_zts}
+# Install the ZTS stuff
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Install the package XML file
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+# Test & Documentation
+cd NTS
+for i in $(grep 'role="test"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 $i %{buildroot}%{pecl_testdir}/%{pecl_name}/$i
+done
+for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%check
+# Known by upstream as failed test (travis result)
+rm */tests/{018,030,040b,040c,040d}.phpt
+
+cd NTS
+: Minimal load test for NTS extension
+%{__php} --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+: Upstream test suite for NTS extension
+TEST_PHP_EXECUTABLE=%{__php} \
+TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__php} -n run-tests.php --show-diff
+
+%if %{with_zts}
+cd ../ZTS
+: Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+: Upstream test suite for ZTS extension
+TEST_PHP_EXECUTABLE=%{__ztsphp} \
+TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__ztsphp} -n run-tests.php --show-diff
+%endif
+
+
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-, root, root, 0755)
+%doc %{pecl_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%files devel
+%defattr(-, root, root, 0755)
+%doc %{pecl_testdir}/%{pecl_name}
+%{php_incldir}/ext/%{pecl_name}
+
+%if %{with_zts}
+%{php_ztsincldir}/ext/%{pecl_name}
+%endif
+
+
+%changelog
+* Mon Apr 27 2015 Remi Collet <remi@fedoraproject.org> - 0.5.6-1
+- Update to 0.5.6
+- drop runtime dependency on pear, new scriptlets
+
+* Wed Dec 24 2014 Remi Collet <remi@fedoraproject.org> - 0.5.5-8.1
+- Fedora 21 SCL mass rebuild
+
+* Sun Aug 24 2014 Remi Collet <remi@fedoraproject.org> - 0.5.5-8
+- improve SCL stuff
+
+* Wed Apr 9 2014 Remi Collet <remi@fedoraproject.org> - 0.5.5-7
+- add numerical prefix to extension configuration file
+
+* Wed Mar 19 2014 Remi Collet <rcollet@redhat.com> - 0.5.5-6
+- allow SCL build
+
+* Fri Feb 28 2014 Remi Collet <remi@fedoraproject.org> - 0.5.5-5
+- cleanups
+- move doc in pecl_docdir
+- move tests in pecl_testdir (devel)
+
+* Thu Jul 18 2013 Remi Collet <remi@fedoraproject.org> - 0.5.5-4
+- bump release
+
+* Thu Apr 18 2013 Remi Collet <remi@fedoraproject.org> - 0.5.5-4
+- ExcludeArch: ppc64 (as msgpack)
+
+* Tue Apr 2 2013 Remi Collet <remi@fedoraproject.org> - 0.5.5-3
+- use system msgpack library headers
+
+* Tue Mar 26 2013 Remi Collet <remi@fedoraproject.org> - 0.5.5-2
+- cleanups
+
+* Wed Feb 20 2013 Remi Collet <remi@fedoraproject.org> - 0.5.5-1
+- Update to 0.5.5
+
+* Fri Nov 30 2012 Remi Collet <remi@fedoraproject.org> - 0.5.3-1.1
+- also provides php-msgpack
+
+* Thu Oct 18 2012 Remi Collet <remi@fedoraproject.org> - 0.5.3-1
+- update to 0.5.3 (beta)
+
+* Sat Sep 15 2012 Remi Collet <remi@fedoraproject.org> - 0.5.2-1
+- initial package, version 0.5.2 (beta)
+