summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-10-07 12:48:01 +0200
committerRemi Collet <remi@php.net>2022-10-07 12:48:01 +0200
commitbea0f23e6a7a93696b83f18d2790e9871fdba9b8 (patch)
tree48e2a3b3e862668bf029c866c9947830227a5c16
parent2cf9d75dee8051596ac40ff288abda350f1d1bbb (diff)
update to 2.2.0RC2
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION20
-rw-r--r--php-pecl-msgpack.spec19
3 files changed, 17 insertions, 24 deletions
diff --git a/PHPINFO b/PHPINFO
index 2042bf2..c69034f 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,7 +3,7 @@ msgpack
MessagePack Support => enabled
Session Support => enabled
-extension Version => 2.2.0RC1
+extension Version => 2.2.0RC2
header Version => 3.2.0
Directive => Local Value => Master Value
diff --git a/REFLECTION b/REFLECTION
index 699cecd..4451332 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #87 msgpack version 2.2.0RC1 ] {
+Extension [ <persistent> extension #86 msgpack version 2.2.0RC2 ] {
- INI {
Entry [ msgpack.error_display <ALL> ]
@@ -30,7 +30,7 @@ Extension [ <persistent> extension #87 msgpack version 2.2.0RC1 ] {
- Parameters [2] {
Parameter #0 [ <required> $str ]
- Parameter #1 [ <optional> $object ]
+ Parameter #1 [ <optional> $object = <default> ]
}
}
Function [ <internal:msgpack> function msgpack_pack ] {
@@ -43,7 +43,7 @@ Extension [ <persistent> extension #87 msgpack version 2.2.0RC1 ] {
- Parameters [2] {
Parameter #0 [ <required> $str ]
- Parameter #1 [ <optional> $object ]
+ Parameter #1 [ <optional> $object = <default> ]
}
}
}
@@ -68,7 +68,7 @@ Extension [ <persistent> extension #87 msgpack version 2.2.0RC1 ] {
Method [ <internal:msgpack, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> $opt ]
+ Parameter #0 [ <optional> $opt = <default> ]
}
}
@@ -91,7 +91,7 @@ Extension [ <persistent> extension #87 msgpack version 2.2.0RC1 ] {
- Parameters [2] {
Parameter #0 [ <required> $str ]
- Parameter #1 [ <optional> $object ]
+ Parameter #1 [ <optional> $object = <default> ]
}
}
@@ -121,11 +121,11 @@ Extension [ <persistent> extension #87 msgpack version 2.2.0RC1 ] {
Method [ <internal:msgpack, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> $opt ]
+ Parameter #0 [ <optional> $opt = <default> ]
}
}
- Method [ <internal:msgpack, dtor> public method __destruct ] {
+ Method [ <internal:msgpack> public method __destruct ] {
- Parameters [0] {
}
@@ -149,15 +149,15 @@ Extension [ <persistent> extension #87 msgpack version 2.2.0RC1 ] {
Method [ <internal:msgpack> public method execute ] {
- Parameters [2] {
- Parameter #0 [ <optional> $str ]
- Parameter #1 [ <optional> &$offset ]
+ Parameter #0 [ <optional> $str = <default> ]
+ Parameter #1 [ <optional> &$offset = <default> ]
}
}
Method [ <internal:msgpack> public method data ] {
- Parameters [1] {
- Parameter #0 [ <optional> $object ]
+ Parameter #0 [ <optional> $object = <default> ]
}
}
diff --git a/php-pecl-msgpack.spec b/php-pecl-msgpack.spec
index 77c6d34..3fa4910 100644
--- a/php-pecl-msgpack.spec
+++ b/php-pecl-msgpack.spec
@@ -23,8 +23,8 @@
%global ini_name 40-%{pecl_name}.ini
%global upstream_version 2.2.0
-%global upstream_prever RC1
-%global upstream_lower RC1
+%global upstream_prever RC2
+%global upstream_lower RC2
# to use system library
%bcond_with msgpack
@@ -41,7 +41,7 @@ URL: https://pecl.php.net/package/msgpack
Release: 0.7.%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 8%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
%endif
@@ -201,16 +201,6 @@ rm */tests/034.phpt
# too slow
rm */tests/035.phpt
%endif
-%if "%{php_version}" > "8.0"
-rm */tests/007.phpt
-rm */tests/008.phpt
-rm */tests/009a.phpt
-rm */tests/013.phpt
-rm */tests/014.phpt
-rm */tests/024.phpt
-rm */tests/033.phpt
-rm */tests/bug013.phpt
-%endif
cd NTS
: Minimal load test for NTS extension
@@ -287,6 +277,9 @@ fi
%changelog
+* Fri Oct 7 2022 Remi Collet <remi@remirepo.net> - 2.2.0~RC2-1
+- update to 2.2.0RC2
+
* Fri Sep 9 2022 Remi Collet <remi@remirepo.net> - 2.2.0~RC1-8
- ignore 8 failed tests with PHP 8.2