summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-12-07 07:49:41 +0100
committerRemi Collet <fedora@famillecollet.com>2016-12-07 07:49:41 +0100
commit4f8fc201df6f9e7ee4d692cc66e3ee2374207c6a (patch)
tree6dd70a2edd2e9b0f41d868da66a672d4084b634c
parentd1fa0ff80011ccb9d85f7f9645b7dd045c38df90 (diff)
php-pecl-msgpack: 2.0.2
-rw-r--r--REFLECTION-PHP72
-rw-r--r--msgpack-php71.patch21
-rw-r--r--msgpack-pr87.patch38
-rw-r--r--php-pecl-msgpack-php7.spec18
4 files changed, 9 insertions, 70 deletions
diff --git a/REFLECTION-PHP7 b/REFLECTION-PHP7
index b892bec..194891d 100644
--- a/REFLECTION-PHP7
+++ b/REFLECTION-PHP7
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #67 msgpack version 2.0.1 ] {
+Extension [ <persistent> extension #107 msgpack version 2.0.2 ] {
- INI {
Entry [ msgpack.error_display <ALL> ]
diff --git a/msgpack-php71.patch b/msgpack-php71.patch
deleted file mode 100644
index bab1d2a..0000000
--- a/msgpack-php71.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --git a/msgpack_unpack.h b/msgpack_unpack.h
-index 5dc9524..0851625 100644
---- a/msgpack_unpack.h
-+++ b/msgpack_unpack.h
-@@ -16,6 +16,16 @@ typedef enum
- MSGPACK_UNPACK_PARSE_ERROR = -1,
- } msgpack_unpack_return;
-
-+#if PHP_VERSION_ID >= 70100
-+typedef struct php_unserialize_data {
-+ void *first;
-+ void *last;
-+ void *first_dtor;
-+ void *last_dtor;
-+ HashTable *allowed_classes;
-+};
-+#endif
-+
- typedef struct php_unserialize_data msgpack_unserialize_data_t;
-
- typedef struct {
diff --git a/msgpack-pr87.patch b/msgpack-pr87.patch
deleted file mode 100644
index afdac20..0000000
--- a/msgpack-pr87.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From 710f535c7b25ab7d49b649f9411427761525b8d7 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Sat, 11 Jun 2016 06:39:22 +0200
-Subject: [PATCH] fix for PHP 7.1
-
----
- msgpack_convert.c | 8 +++++++-
- 1 file changed, 7 insertions(+), 1 deletion(-)
-
-diff --git a/msgpack_convert.c b/msgpack_convert.c
-index 3b01150..9b6923a 100644
---- a/msgpack_convert.c
-+++ b/msgpack_convert.c
-@@ -289,9 +289,11 @@ int msgpack_convert_object(zval *return_value, zval *tpl, zval *value) /* {{{ */
- zend_fcall_info_cache fcc;
-
- fci.size = sizeof(fci);
-+#if PHP_VERSION_ID < 70100
- fci.function_table = EG(function_table);
-- fci.function_name = function_name;
- fci.symbol_table = NULL;
-+#endif
-+ fci.function_name = function_name;
- fci.object = Z_OBJ_P(return_value);
- fci.retval = &retval;
- fci.param_count = 0;
-@@ -300,7 +302,11 @@ int msgpack_convert_object(zval *return_value, zval *tpl, zval *value) /* {{{ */
-
- fcc.initialized = 1;
- fcc.function_handler = ce->constructor;
-+#if PHP_VERSION_ID < 70100
- fcc.calling_scope = EG(scope);
-+#else
-+ fcc.calling_scope = zend_get_executed_scope();
-+#endif
- fcc.called_scope = Z_OBJCE_P(return_value);
- fcc.object = Z_OBJ_P(return_value);
-
diff --git a/php-pecl-msgpack-php7.spec b/php-pecl-msgpack-php7.spec
index f3caea2..7fcb84b 100644
--- a/php-pecl-msgpack-php7.spec
+++ b/php-pecl-msgpack-php7.spec
@@ -31,22 +31,18 @@
Summary: API for communicating with MessagePack serialization
Name: %{?sub_prefix}php-pecl-msgpack
-Version: 2.0.1
+Version: 2.0.2
%if 0%{?gh_date:1}
Release: 0.2.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
%endif
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/msgpack
-Patch0: %{pecl_name}-pr87.patch
-# Temp for https://github.com/msgpack/msgpack-php/issues/100
-Patch1: %{pecl_name}-php71.patch
-
BuildRequires: %{?scl_prefix}php-devel >= 7
BuildRequires: %{?scl_prefix}php-pear
%if %{with_msgpack}
@@ -67,7 +63,7 @@ Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%endif
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
Obsoletes: php53-pecl-%{pecl_name} <= %{version}
Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
@@ -133,9 +129,6 @@ mv %{pecl_name}-%{version} NTS
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml} \
cd NTS
-%patch0 -p1 -b .pr87
-%patch1 -p1 -b .php71
-
%if %{with_msgpack}
# use system library
rm -rf msgpack
@@ -210,6 +203,8 @@ done
%check
+# Erratic results
+rm */tests/034.phpt
# Known by upstream as failed test (travis result)
rm */tests/041.phpt
rm */tests/040*.phpt
@@ -287,6 +282,9 @@ fi
%changelog
+* Wed Dec 7 2016 Remi Collet <remi@fedoraproject.org> - 2.0.2-1
+- update to 2.0.2
+
* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 2.0.1-5
- rebuild with PHP 7.1.0 GA