summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-03-14 08:28:29 +0100
committerRemi Collet <fedora@famillecollet.com>2017-03-14 08:28:29 +0100
commitf0bc5e5e526e292756c5831d9cef67e3060fe7c7 (patch)
tree479f1ea998d0d9ec40cea65122e26ec5b3418ebc
parente95d666212872b7ffa02e8095ad65beada3df721 (diff)
php-pecl-mosquitto: 0.4.0
-rw-r--r--REFLECTION20
-rw-r--r--php-pecl-mosquitto.spec34
2 files changed, 29 insertions, 25 deletions
diff --git a/REFLECTION b/REFLECTION
index f099fdc..295b568 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #126 mosquitto version 0.3.0 ] {
+Extension [ <persistent> extension #109 mosquitto version 0.4.0 ] {
- Constants [7] {
Constant [ integer MOSQ_LOG_INFO ] { 1 }
@@ -208,7 +208,7 @@ Extension [ <persistent> extension #126 mosquitto version 0.3.0 ] {
}
}
- Class [ <internal:mosquitto> class Mosquitto\Exception extends Exception ] {
+ Class [ <internal:mosquitto> class Mosquitto\Exception extends Exception implements Throwable ] {
- Constants [0] {
}
@@ -239,28 +239,28 @@ Extension [ <persistent> extension #126 mosquitto version 0.3.0 ] {
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
}
- Method [ <internal:Core, inherits Exception> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
}
- Method [ <internal:Core, inherits Exception> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
}
- Method [ <internal:Core, inherits Exception> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
}
- Method [ <internal:Core, inherits Exception> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
}
- Method [ <internal:Core, inherits Exception> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
}
- Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits Exception> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
}
}
}
diff --git a/php-pecl-mosquitto.spec b/php-pecl-mosquitto.spec
index 40b3533..edf123e 100644
--- a/php-pecl-mosquitto.spec
+++ b/php-pecl-mosquitto.spec
@@ -7,14 +7,9 @@
# Please, preserve the changelog entries
#
%if 0%{?scl:1}
-%if "%{scl}" == "rh-php56"
-%global sub_prefix more-php56-
-%else
%global sub_prefix %{scl_prefix}
+%scl_package php-pecl-mosquitto
%endif
-%endif
-
-%{?scl: %scl_package php-pecl-mosquitto}
%global with_zts 0%{?__ztsphp:1}
%global pecl_name mosquitto
@@ -27,14 +22,13 @@
Summary: Extension for libmosquitto
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 0.3.0
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 0.4.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{proj_name}
Source0: http://pecl.php.net/get/%{proj_name}-%{version}.tgz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel > 5.3
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: mosquitto-devel
@@ -47,8 +41,10 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+%if "%{?scl_prefix}" != "%{?sub_prefix}"
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+%endif
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
@@ -64,6 +60,14 @@ Obsoletes: php55w-pecl-%{pecl_name}
Obsoletes: php56u-pecl-%{pecl_name}
Obsoletes: php56w-pecl-%{pecl_name}
%endif
+%if "%{php_version}" > "7.0"
+Obsoletes: php70u-pecl-%{pecl_name}
+Obsoletes: php70w-pecl-%{pecl_name}
+%endif
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-pecl-%{pecl_name}
+Obsoletes: php71w-pecl-%{pecl_name}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -112,6 +116,8 @@ EOF
%build
+%{?dtsenable}
+
cd NTS
%{_bindir}/phpize
%configure \
@@ -130,7 +136,7 @@ make %{?_smp_mflags}
%install
-rm -rf %{buildroot}
+%{?dtsenable}
make -C NTS install INSTALL_ROOT=%{buildroot}
@@ -188,12 +194,7 @@ cd ../ZTS
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{?_licensedir:%license NTS/LICENSE}
%doc %{pecl_docdir}/%{proj_name}
%{pecl_xmldir}/%{name}.xml
@@ -208,6 +209,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Mar 14 2017 Remi Collet <remi@remirepo.net> - 0.4.0-1
+- Update to 0.4.0
+
* Tue Mar 8 2016 Remi Collet <remi@fedoraproject.org> - 0.3.0-2
- adapt for F24