summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-05-13 08:08:58 +0200
committerRemi Collet <fedora@famillecollet.com>2014-05-13 08:08:58 +0200
commit58fdae1b851cae9fbd1afb438d979d5ef69f982c (patch)
tree4fca39d232169ceb485cfb7a4ea0f6ee744022df
parentc744c554ab2c0b1f418544937f99281d67ba12e0 (diff)
php-pecl-mosquitto: 0.2.2 (alpha)
-rw-r--r--REFLECTION282
-rw-r--r--php-pecl-mosquitto.spec12
2 files changed, 291 insertions, 3 deletions
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..8ae220e
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,282 @@
+Extension [ <persistent> extension #107 mosquitto version 0.2.2 ] {
+
+ - Constants [7] {
+ Constant [ integer MOSQ_LOG_INFO ] { 1 }
+ Constant [ integer MOSQ_LOG_NOTICE ] { 2 }
+ Constant [ integer MOSQ_LOG_WARNING ] { 4 }
+ Constant [ integer MOSQ_LOG_ERR ] { 8 }
+ Constant [ integer MOSQ_LOG_DEBUG ] { 16 }
+ Constant [ integer 0 ] { 0 }
+ Constant [ integer 1 ] { 1 }
+ }
+
+ - Classes [3] {
+ Class [ <internal:mosquitto> class Mosquitto\Client ] {
+
+ - Constants [7] {
+ Constant [ integer LOG_INFO ] { 1 }
+ Constant [ integer LOG_NOTICE ] { 2 }
+ Constant [ integer LOG_WARNING ] { 4 }
+ Constant [ integer LOG_ERR ] { 8 }
+ Constant [ integer LOG_DEBUG ] { 16 }
+ Constant [ integer SSL_VERIFY_NONE ] { 0 }
+ Constant [ integer SSL_VERIFY_PEER ] { 1 }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [24] {
+ Method [ <internal:mosquitto, ctor> public method __construct ] {
+ }
+
+ Method [ <internal:mosquitto> public method onConnect ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $onConnect ]
+ }
+ }
+
+ Method [ <internal:mosquitto> public method onDisconnect ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $onConnect ]
+ }
+ }
+
+ Method [ <internal:mosquitto> public method onLog ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $onConnect ]
+ }
+ }
+
+ Method [ <internal:mosquitto> public method onSubscribe ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $onConnect ]
+ }
+ }
+
+ Method [ <internal:mosquitto> public method onUnsubscribe ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $onConnect ]
+ }
+ }
+
+ Method [ <internal:mosquitto> public method onMessage ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $onConnect ]
+ }
+ }
+
+ Method [ <internal:mosquitto> public method getSocket ] {
+ }
+
+ Method [ <internal:mosquitto> public method setTlsCertificates ] {
+ }
+
+ Method [ <internal:mosquitto> public method setTlsInsecure ] {
+ }
+
+ Method [ <internal:mosquitto> public method setTlsOptions ] {
+ }
+
+ Method [ <internal:mosquitto> public method setTlsPSK ] {
+ }
+
+ Method [ <internal:mosquitto> public method setCredentials ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $username ]
+ Parameter #1 [ <required> $password ]
+ }
+ }
+
+ Method [ <internal:mosquitto> public method setWill ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $topic ]
+ Parameter #1 [ <required> $payload ]
+ Parameter #2 [ <required> $qos ]
+ Parameter #3 [ <required> $retain ]
+ }
+ }
+
+ Method [ <internal:mosquitto> public method setReconnectDelay ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $reconnectDelay ]
+ Parameter #1 [ <required> $maxReconnectDelay ]
+ Parameter #2 [ <required> $exponentialBackoff ]
+ }
+ }
+
+ Method [ <internal:mosquitto> public method setMessageRetry ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $messageRetry ]
+ }
+ }
+
+ Method [ <internal:mosquitto> public method connect ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $host ]
+ Parameter #1 [ <required> $port ]
+ Parameter #2 [ <required> $keepalive ]
+ Parameter #3 [ <required> $interface ]
+ }
+ }
+
+ Method [ <internal:mosquitto> public method disconnect ] {
+ }
+
+ Method [ <internal:mosquitto> public method setMaxInFlightMessages ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $max ]
+ }
+ }
+
+ Method [ <internal:mosquitto> public method publish ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $topic ]
+ Parameter #1 [ <required> $payload ]
+ Parameter #2 [ <required> $qos ]
+ Parameter #3 [ <required> $retain ]
+ }
+ }
+
+ Method [ <internal:mosquitto> public method subscribe ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $topic ]
+ Parameter #1 [ <required> $qos ]
+ }
+ }
+
+ Method [ <internal:mosquitto> public method unsubscribe ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $topic ]
+ }
+ }
+
+ Method [ <internal:mosquitto> public method loop ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $timeout ]
+ Parameter #1 [ <required> $maxPackets ]
+ }
+ }
+
+ Method [ <internal:mosquitto> public method loopForever ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $timeout ]
+ Parameter #1 [ <required> $maxPackets ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mosquitto> class Mosquitto\Exception extends Exception ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [9] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:mosquitto> class Mosquitto\Message ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [2] {
+ Method [ <internal:mosquitto> static public method topicMatchesSub ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $topic ]
+ Parameter #1 [ <required> $subscription ]
+ }
+ }
+
+ Method [ <internal:mosquitto> static public method tokeniseTopic ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $topic ]
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [1] {
+ Method [ <internal:mosquitto, ctor> public method __construct ] {
+ }
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-mosquitto.spec b/php-pecl-mosquitto.spec
index 974794d..cf7cb4b 100644
--- a/php-pecl-mosquitto.spec
+++ b/php-pecl-mosquitto.spec
@@ -22,8 +22,8 @@
Summary: Extension for libmosquitto
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 0.2.1
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 0.2.2
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{proj_name}
@@ -44,7 +44,7 @@ Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if 0%{!?scl:1}
+%if "%{?vendor}" == "Remi Collet"
# Other third party repo stuff
%if "%{php_version}" > "5.4"
Obsoletes: php53-pecl-%{pecl_name}
@@ -54,6 +54,9 @@ Obsoletes: php54-pecl-%{pecl_name}
%if "%{php_version}" > "5.5"
Obsoletes: php55u-pecl-%{pecl_name}
%endif
+%if "%{php_version}" > "5.6"
+Obsoletes: php56u-pecl-%{pecl_name}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -182,6 +185,9 @@ rm -rf %{buildroot}
%changelog
+* Tue May 13 2014 Remi Collet <remi@fedoraproject.org> - 0.2.2-1
+- Update to 0.2.2 (alpha)
+
* Wed Apr 16 2014 Remi Collet <remi@fedoraproject.org> - 0.2.1-2
- add numerical prefix to extension configuration file