summaryrefslogtreecommitdiffstats
path: root/php-pecl-mongodb.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-mongodb.spec')
-rw-r--r--php-pecl-mongodb.spec30
1 files changed, 23 insertions, 7 deletions
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index 48307fb..9fa6c58 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -22,20 +22,23 @@
%bcond_with tests
# temp for EL until available in EPEL
-%if 0%{?fedora} >= 37
+%if 0%{?fedora} >= 37 || 0%{?rhel} >= 8
%bcond_without syslib
%else
%bcond_with syslib
%endif
# Bundled versions
-%global bundled_libmongo 1.26.1
-%global bundled_libcrypt 1.9.1
+%global bundled_libmongo 1.27.0
+%global bundled_libcrypt 1.10.0
+# Required versions
+%global minimal_libmongo 1.27.1
+%global minimal_libcrypt 1.9.1
%if %{with syslib}
# Build dependencies
-%global system_libmongo 1.26.1
-%global system_libcrypt 1.9.1
+%global system_libmongo 1.27.0
+%global system_libcrypt 1.10.0
# Runtime dependencies
%global runtime_libmongo %(pkg-config --silence-errors --modversion libmongoc-1.0 2>/dev/null || echo %{system_libmongo})
%global runtime_libcrypt %(pkg-config --silence-errors --modversion libmongocrypt 2>/dev/null || echo %{system_libcrypt})
@@ -43,7 +46,7 @@
Summary: MongoDB driver for PHP
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-%global upstream_version 1.18.0
+%global upstream_version 1.19.0
#global upstream_prever beta1
#global upstream_lower ~beta1
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
@@ -144,8 +147,12 @@ cat src/*_VERSION_CURRENT
grep -q %{bundled_libmongo} src/LIBMONGOC_VERSION_CURRENT
grep -q %{bundled_libcrypt} src/LIBMONGOCRYPT_VERSION_CURRENT
+grep CHECK_MODULES config.m4
+grep -q %{minimal_libmongo} config.m4
+grep -q %{minimal_libcrypt} config.m4
+
# temporary: lower minimal required versions
-sed -e 's/%{bundled_libmongo}/%{system_libmongo}/;s/%{bundled_libcrypt}/%{system_libcrypt}/' -i config.m4
+sed -e 's/%{minimal_libmongo}/%{system_libmongo}/;s/%{minimal_libcrypt}/%{system_libcrypt}/' -i config.m4
%endif
# Sanity check, really often broken
@@ -340,6 +347,15 @@ exit $ret
%changelog
+* Mon May 13 2024 Remi Collet <remi@remirepo.net> - 1.19.0-1
+- update to 1.19.0
+- raise dependency on libbson and libmongc 1.27.0
+- raise dependency on libmongocrypt 1.10.0
+
+* Fri Apr 12 2024 Remi Collet <remi@remirepo.net> - 1.18.1-1
+- update to 1.18.1 (no change)
+- EL use bundled libbson and libmongc 1.26.2
+
* Thu Mar 28 2024 Remi Collet <remi@remirepo.net> - 1.18.0-1
- update to 1.18.0
- EL use bundled libbson and libmongc 1.26.1