summaryrefslogtreecommitdiffstats
path: root/php-pecl-mongodb.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-mongodb.spec')
-rw-r--r--php-pecl-mongodb.spec30
1 files changed, 19 insertions, 11 deletions
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index c54d222..5df17c0 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -29,16 +29,16 @@
%endif
# Bundled versions
-%global bundled_libmongo 1.27.6
-%global bundled_libcrypt 1.10.1
+%global bundled_libmongo 1.28.0
+%global bundled_libcrypt 1.11.0
# Required versions
-%global minimal_libmongo 1.27.6
-%global minimal_libcrypt 1.10.1
+%global minimal_libmongo 1.28.0
+%global minimal_libcrypt 1.11.0
%if %{with syslib}
# Build dependencies
-%global system_libmongo 1.27.5
-%global system_libcrypt 1.10.1
+%global system_libmongo 1.28.0
+%global system_libcrypt 1.11.0
# Runtime dependencies
%global runtime_libmongo %(pkg-config --silence-errors --modversion libmongoc-1.0 2>/dev/null || echo %{system_libmongo})
%global runtime_libcrypt %(pkg-config --silence-errors --modversion libmongocrypt 2>/dev/null || echo %{system_libcrypt})
@@ -46,13 +46,13 @@
Summary: MongoDB driver for PHP
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-%global upstream_version 1.19.4
+%global upstream_version 1.20.0
#global upstream_prever beta1
#global upstream_lower ~beta1
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
Version: %{upstream_version}%{?upstream_lower}
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%if %{with syslib}
License: Apache-2.0
%else
@@ -180,11 +180,13 @@ peclbuild() {
--with-mongodb-client-side-encryption \
--enable-mongodb
- make %{?_smp_mflags}
+ %make_build
}
cd %{sources}
%{__phpize}
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i build/Makefile.global
+
%if %{with syslib}
# Ensure we use system library
# Need to be removed only after phpize because of m4_include
@@ -203,7 +205,7 @@ peclbuild %{__ztsphpconfig}
%install
%{?dtsenable}
-make -C NTS install INSTALL_ROOT=%{buildroot}
+%make_install -C NTS
# install config file
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
@@ -212,7 +214,7 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
-make -C ZTS install INSTALL_ROOT=%{buildroot}
+%make_install -C ZTS
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
@@ -304,6 +306,12 @@ exit $ret
%changelog
+* Mon Sep 30 2024 Remi Collet <remi@remirepo.net> - 1.20.0-2
+- EL: rebuild with system libraries
+
+* Tue Sep 24 2024 Remi Collet <remi@remirepo.net> - 1.20.0-1
+- update to 1.20.0
+
* Mon Sep 9 2024 Remi Collet <remi@remirepo.net> - 1.19.4-1
- update to 1.19.4