summaryrefslogtreecommitdiffstats
path: root/php-pecl-mongodb.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-mongodb.spec')
-rw-r--r--php-pecl-mongodb.spec25
1 files changed, 12 insertions, 13 deletions
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index 894d8a2..bace77e 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -7,11 +7,7 @@
# Please, preserve the changelog entries
#
-%if 0%{?scl:1}
-%scl_package php-pecl-mongodb
-%else
-%global _root_prefix %{_prefix}
-%endif
+%{?scl:%scl_package php-pecl-mongodb}
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pie_vend mongodb
@@ -21,14 +17,10 @@
%global ini_name 50-%{pecl_name}.ini
# test suite requires a MongoDB server
-%bcond_with tests
+%bcond_with tests
-# temp for EL until available in EPEL
-%if 0%{?fedora} >= 37 || 0%{?rhel} >= 8
-%bcond_without syslib
-%else
+# always use bundled libraries
%bcond_with syslib
-%endif
# Bundled versions
%global bundled_libmongo 1.30.1
@@ -46,7 +38,7 @@
%global runtime_libcrypt %(pkg-config --silence-errors --modversion libmongocrypt 2>/dev/null || echo %{system_libcrypt})
%endif
-Summary: MongoDB driver for PHP
+Summary: MongoDB driver for PHP version 1
Name: %{?scl_prefix}php-pecl-%{pecl_name}
%global upstream_version 1.21.0
#global upstream_prever beta1
@@ -54,7 +46,7 @@ Name: %{?scl_prefix}php-pecl-%{pecl_name}
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
Version: %{upstream_version}%{?upstream_lower}
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%if %{with syslib}
License: Apache-2.0
%else
@@ -110,6 +102,9 @@ The purpose of this driver is to provide exceptionally thin glue between
MongoDB and PHP, implementing only fundemental and performance-critical
components necessary to build a fully-functional MongoDB driver.
+This package provides version 1 of the extension,
+php-pecl-mongodb2 provides version 2.
+
Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
@@ -310,6 +305,10 @@ exit $ret
%changelog
+* Thu Apr 10 2025 Remi Collet <remi@remirepo.net> - 1.21.0-2
+- rebuild using bundled libraries
+- add note in description about php-pecl-mongodb2
+
* Fri Feb 28 2025 Remi Collet <remi@remirepo.net> - 1.21.0-1
- update to 1.21.0
- raise dependency on PHP 8.1