summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO10
-rw-r--r--REFLECTION120
-rw-r--r--php-pecl-mongodb.spec27
3 files changed, 118 insertions, 39 deletions
diff --git a/PHPINFO b/PHPINFO
index 879498f..c27b3c9 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,12 +2,12 @@
mongodb
MongoDB support => enabled
-MongoDB extension version => 1.19.4
+MongoDB extension version => 1.20.0
MongoDB extension stability => stable
-libbson headers version => 1.27.6
-libbson library version => 1.27.6
-libmongoc headers version => 1.27.6
-libmongoc library version => 1.27.6
+libbson headers version => 1.28.0
+libbson library version => 1.28.0
+libmongoc headers version => 1.28.0
+libmongoc library version => 1.28.0
libmongoc SSL => enabled
libmongoc SSL library => OpenSSL
libmongoc crypto => enabled
diff --git a/REFLECTION b/REFLECTION
index 8d6cb83..bbe5e8d 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #110 mongodb version 1.19.4 ] {
+Extension [ <persistent> extension #113 mongodb version 1.20.0 ] {
- Dependencies {
Dependency [ date (Required) ]
@@ -14,40 +14,40 @@ Extension [ <persistent> extension #110 mongodb version 1.19.4 ] {
}
- Constants [2] {
- Constant [ string MONGODB_VERSION ] { 1.19.4 }
+ Constant [ string MONGODB_VERSION ] { 1.20.0 }
Constant [ string MONGODB_STABILITY ] { stable }
}
- Functions {
- Function [ <internal:mongodb> function MongoDB\BSON\fromJSON ] {
+ Function [ <internal, deprecated:mongodb> function MongoDB\BSON\fromJSON ] {
- Parameters [1] {
Parameter #0 [ <required> string $json ]
}
- Return [ string ]
}
- Function [ <internal:mongodb> function MongoDB\BSON\fromPHP ] {
+ Function [ <internal, deprecated:mongodb> function MongoDB\BSON\fromPHP ] {
- Parameters [1] {
Parameter #0 [ <required> object|array $value ]
}
- Return [ string ]
}
- Function [ <internal:mongodb> function MongoDB\BSON\toCanonicalExtendedJSON ] {
+ Function [ <internal, deprecated:mongodb> function MongoDB\BSON\toCanonicalExtendedJSON ] {
- Parameters [1] {
Parameter #0 [ <required> string $bson ]
}
- Return [ string ]
}
- Function [ <internal:mongodb> function MongoDB\BSON\toJSON ] {
+ Function [ <internal, deprecated:mongodb> function MongoDB\BSON\toJSON ] {
- Parameters [1] {
Parameter #0 [ <required> string $bson ]
}
- Return [ string ]
}
- Function [ <internal:mongodb> function MongoDB\BSON\toPHP ] {
+ Function [ <internal, deprecated:mongodb> function MongoDB\BSON\toPHP ] {
- Parameters [2] {
Parameter #0 [ <required> string $bson ]
@@ -55,7 +55,7 @@ Extension [ <persistent> extension #110 mongodb version 1.19.4 ] {
}
- Return [ object|array ]
}
- Function [ <internal:mongodb> function MongoDB\BSON\toRelaxedExtendedJSON ] {
+ Function [ <internal, deprecated:mongodb> function MongoDB\BSON\toRelaxedExtendedJSON ] {
- Parameters [1] {
Parameter #0 [ <required> string $bson ]
@@ -495,7 +495,15 @@ Extension [ <persistent> extension #110 mongodb version 1.19.4 ] {
- Static properties [0] {
}
- - Static methods [2] {
+ - Static methods [3] {
+ Method [ <internal:mongodb> final static public method fromJSON ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $json ]
+ }
+ - Return [ MongoDB\BSON\PackedArray ]
+ }
+
Method [ <internal:mongodb> final static public method fromPHP ] {
- Parameters [1] {
@@ -516,7 +524,7 @@ Extension [ <persistent> extension #110 mongodb version 1.19.4 ] {
- Properties [0] {
}
- - Methods [14] {
+ - Methods [16] {
Method [ <internal:mongodb, ctor> private method __construct ] {
- Parameters [0] {
@@ -554,6 +562,20 @@ Extension [ <persistent> extension #110 mongodb version 1.19.4 ] {
- Return [ object|array ]
}
+ Method [ <internal:mongodb> final public method toCanonicalExtendedJSON ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:mongodb> final public method toRelaxedExtendedJSON ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
Method [ <internal:mongodb, prototype ArrayAccess> public method offsetExists ] {
- Parameters [1] {
@@ -1794,11 +1816,11 @@ Extension [ <persistent> extension #110 mongodb version 1.19.4 ] {
- Properties [0] {
}
- - Methods [8] {
+ - Methods [9] {
Method [ <internal:mongodb, ctor> final public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> DateTimeInterface|string|int|float|null $milliseconds = null ]
+ Parameter #0 [ <optional> DateTimeInterface|MongoDB\BSON\Int64|string|int|float|null $milliseconds = null ]
}
}
@@ -1809,6 +1831,13 @@ Extension [ <persistent> extension #110 mongodb version 1.19.4 ] {
- Return [ DateTime ]
}
+ Method [ <internal:mongodb> final public method toDateTimeImmutable ] {
+
+ - Parameters [0] {
+ }
+ - Return [ DateTimeImmutable ]
+ }
+
Method [ <internal:mongodb, prototype MongoDB\BSON\UTCDateTimeInterface> final public method __toString ] {
- Parameters [0] {
@@ -1874,7 +1903,7 @@ Extension [ <persistent> extension #110 mongodb version 1.19.4 ] {
- Parameters [0] {
}
- - Tentative return [ MongoDB\Driver\CursorId ]
+ - Tentative return [ MongoDB\Driver\CursorId|MongoDB\BSON\Int64 ]
}
Method [ <internal:mongodb> abstract public method getServer ] {
@@ -1968,13 +1997,15 @@ Extension [ <persistent> extension #110 mongodb version 1.19.4 ] {
Class [ <internal:mongodb> final class MongoDB\Driver\ClientEncryption ] {
- - Constants [7] {
+ - Constants [9] {
Constant [ public string AEAD_AES_256_CBC_HMAC_SHA_512_DETERMINISTIC ] { AEAD_AES_256_CBC_HMAC_SHA_512-Deterministic }
Constant [ public string AEAD_AES_256_CBC_HMAC_SHA_512_RANDOM ] { AEAD_AES_256_CBC_HMAC_SHA_512-Random }
Constant [ public string ALGORITHM_INDEXED ] { Indexed }
Constant [ public string ALGORITHM_UNINDEXED ] { Unindexed }
+ Constant [ public string ALGORITHM_RANGE ] { Range }
Constant [ public string ALGORITHM_RANGE_PREVIEW ] { RangePreview }
Constant [ public string QUERY_TYPE_EQUALITY ] { equality }
+ Constant [ public string QUERY_TYPE_RANGE ] { range }
Constant [ public string QUERY_TYPE_RANGE_PREVIEW ] { rangePreview }
}
@@ -2145,9 +2176,10 @@ Extension [ <persistent> extension #110 mongodb version 1.19.4 ] {
Method [ <internal:mongodb, prototype MongoDB\Driver\CursorInterface> final public method getId ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> bool $asInt64 = false ]
}
- - Return [ MongoDB\Driver\CursorId ]
+ - Tentative return [ MongoDB\Driver\CursorId|MongoDB\BSON\Int64 ]
}
Method [ <internal:mongodb, prototype MongoDB\Driver\CursorInterface> final public method getServer ] {
@@ -2606,7 +2638,7 @@ Extension [ <persistent> extension #110 mongodb version 1.19.4 ] {
- Return [ int ]
}
- Method [ <internal:mongodb> final public method getMode ] {
+ Method [ <internal, deprecated:mongodb> final public method getMode ] {
- Parameters [0] {
}
@@ -5026,7 +5058,7 @@ Extension [ <persistent> extension #110 mongodb version 1.19.4 ] {
- Properties [0] {
}
- - Methods [11] {
+ - Methods [13] {
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
@@ -5061,6 +5093,13 @@ Extension [ <persistent> extension #110 mongodb version 1.19.4 ] {
- Return [ Exception ]
}
+ Method [ <internal:mongodb> final public method getHost ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
Method [ <internal:mongodb> final public method getOperationId ] {
- Parameters [0] {
@@ -5068,6 +5107,13 @@ Extension [ <persistent> extension #110 mongodb version 1.19.4 ] {
- Return [ string ]
}
+ Method [ <internal:mongodb> final public method getPort ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
Method [ <internal:mongodb> final public method getReply ] {
- Parameters [0] {
@@ -5082,7 +5128,7 @@ Extension [ <persistent> extension #110 mongodb version 1.19.4 ] {
- Return [ string ]
}
- Method [ <internal:mongodb> final public method getServer ] {
+ Method [ <internal, deprecated:mongodb> final public method getServer ] {
- Parameters [0] {
}
@@ -5119,7 +5165,7 @@ Extension [ <persistent> extension #110 mongodb version 1.19.4 ] {
- Properties [0] {
}
- - Methods [9] {
+ - Methods [11] {
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
@@ -5147,6 +5193,13 @@ Extension [ <persistent> extension #110 mongodb version 1.19.4 ] {
- Return [ string ]
}
+ Method [ <internal:mongodb> final public method getHost ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
Method [ <internal:mongodb> final public method getOperationId ] {
- Parameters [0] {
@@ -5154,6 +5207,13 @@ Extension [ <persistent> extension #110 mongodb version 1.19.4 ] {
- Return [ string ]
}
+ Method [ <internal:mongodb> final public method getPort ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
Method [ <internal:mongodb> final public method getRequestId ] {
- Parameters [0] {
@@ -5161,7 +5221,7 @@ Extension [ <persistent> extension #110 mongodb version 1.19.4 ] {
- Return [ string ]
}
- Method [ <internal:mongodb> final public method getServer ] {
+ Method [ <internal, deprecated:mongodb> final public method getServer ] {
- Parameters [0] {
}
@@ -5198,7 +5258,7 @@ Extension [ <persistent> extension #110 mongodb version 1.19.4 ] {
- Properties [0] {
}
- - Methods [10] {
+ - Methods [12] {
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
@@ -5226,6 +5286,13 @@ Extension [ <persistent> extension #110 mongodb version 1.19.4 ] {
- Return [ int ]
}
+ Method [ <internal:mongodb> final public method getHost ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
Method [ <internal:mongodb> final public method getOperationId ] {
- Parameters [0] {
@@ -5233,6 +5300,13 @@ Extension [ <persistent> extension #110 mongodb version 1.19.4 ] {
- Return [ string ]
}
+ Method [ <internal:mongodb> final public method getPort ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
Method [ <internal:mongodb> final public method getReply ] {
- Parameters [0] {
@@ -5247,7 +5321,7 @@ Extension [ <persistent> extension #110 mongodb version 1.19.4 ] {
- Return [ string ]
}
- Method [ <internal:mongodb> final public method getServer ] {
+ Method [ <internal, deprecated:mongodb> final public method getServer ] {
- Parameters [0] {
}
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index c54d222..e4cf84f 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -22,23 +22,23 @@
%bcond_with tests
# temp for EL until available in EPEL
-%if 0%{?fedora} >= 37 || 0%{?rhel} >= 8
+%if 0%{?fedora} >= 37 || 0%{?rhel} >= 99
%bcond_without syslib
%else
%bcond_with syslib
%endif
# Bundled versions
-%global bundled_libmongo 1.27.6
-%global bundled_libcrypt 1.10.1
+%global bundled_libmongo 1.28.0
+%global bundled_libcrypt 1.11.0
# Required versions
-%global minimal_libmongo 1.27.6
-%global minimal_libcrypt 1.10.1
+%global minimal_libmongo 1.28.0
+%global minimal_libcrypt 1.11.0
%if %{with syslib}
# Build dependencies
-%global system_libmongo 1.27.5
-%global system_libcrypt 1.10.1
+%global system_libmongo 1.28.0
+%global system_libcrypt 1.11.0
# Runtime dependencies
%global runtime_libmongo %(pkg-config --silence-errors --modversion libmongoc-1.0 2>/dev/null || echo %{system_libmongo})
%global runtime_libcrypt %(pkg-config --silence-errors --modversion libmongocrypt 2>/dev/null || echo %{system_libcrypt})
@@ -46,7 +46,7 @@
Summary: MongoDB driver for PHP
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-%global upstream_version 1.19.4
+%global upstream_version 1.20.0
#global upstream_prever beta1
#global upstream_lower ~beta1
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
@@ -180,11 +180,13 @@ peclbuild() {
--with-mongodb-client-side-encryption \
--enable-mongodb
- make %{?_smp_mflags}
+ %make_build
}
cd %{sources}
%{__phpize}
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i build/Makefile.global
+
%if %{with syslib}
# Ensure we use system library
# Need to be removed only after phpize because of m4_include
@@ -203,7 +205,7 @@ peclbuild %{__ztsphpconfig}
%install
%{?dtsenable}
-make -C NTS install INSTALL_ROOT=%{buildroot}
+%make_install -C NTS
# install config file
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
@@ -212,7 +214,7 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
-make -C ZTS install INSTALL_ROOT=%{buildroot}
+%make_install -C ZTS
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
@@ -304,6 +306,9 @@ exit $ret
%changelog
+* Tue Sep 24 2024 Remi Collet <remi@remirepo.net> - 1.20.0-1
+- update to 1.20.0
+
* Mon Sep 9 2024 Remi Collet <remi@remirepo.net> - 1.19.4-1
- update to 1.19.4