summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO12
-rw-r--r--REFLECTION6
-rw-r--r--php-pecl-mongodb.spec24
3 files changed, 21 insertions, 21 deletions
diff --git a/PHPINFO b/PHPINFO
index c04f04f..27b4c5b 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,12 +2,12 @@
mongodb
MongoDB support => enabled
-MongoDB extension version => 1.8.0RC1
-MongoDB extension stability => beta
-libbson headers version => 1.17.0-pre
-libbson library version => 1.17.0-pre
-libmongoc headers version => 1.17.0-pre
-libmongoc library version => 1.17.0-pre
+MongoDB extension version => 1.8.0
+MongoDB extension stability => stable
+libbson headers version => 1.17.0
+libbson library version => 1.17.0
+libmongoc headers version => 1.17.0
+libmongoc library version => 1.17.0
libmongoc SSL => enabled
libmongoc SSL library => OpenSSL
libmongoc crypto => enabled
diff --git a/REFLECTION b/REFLECTION
index 7ca90be..4953cc1 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #112 mongodb version 1.8.0RC1 ] {
+Extension [ <persistent> extension #112 mongodb version 1.8.0 ] {
- Dependencies {
Dependency [ date (Required) ]
@@ -14,8 +14,8 @@ Extension [ <persistent> extension #112 mongodb version 1.8.0RC1 ] {
}
- Constants [2] {
- Constant [ string MONGODB_VERSION ] { 1.8.0RC1 }
- Constant [ string MONGODB_STABILITY ] { beta }
+ Constant [ string MONGODB_VERSION ] { 1.8.0 }
+ Constant [ string MONGODB_STABILITY ] { stable }
}
- Functions {
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index bc08c69..f6b9497 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -19,12 +19,8 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name mongodb
-%if "%{php_version}" < "5.6"
-%global ini_name z-%{pecl_name}.ini
-%else
# After 40-smbclient.ini, see https://jira.mongodb.org/browse/PHPC-658
%global ini_name 50-%{pecl_name}.ini
-%endif
# test suite requires a MongoDB server
%global with_tests 0%{?_with_tests:1}
@@ -33,21 +29,21 @@
%if 0%{?fedora} >= 30 || 0%{?rhel} >= 9
%global with_syslib 1
%global libmongo 1.17
-%global libmongover %{libmongo}
-#global libmongover %%(pkg-config --silence-errors --modversion libmongoc-1.0 2>/dev/null || echo %%{libmongo})
+#global libmongover #{libmongo}
+%global libmongover %(pkg-config --silence-errors --modversion libmongoc-1.0 2>/dev/null || echo %{libmongo})
%global libcrypt 1.0.1
%global libcryptver %(pkg-config --silence-errors --modversion libmongocrypt 2>/dev/null || echo %{libcrypt})
%else
%global with_syslib 0
-%global libmongo 1.17.0~rc0
+%global libmongo 1.17.0
%global libcrypt 1.0.3
%endif
Summary: MongoDB driver for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
%global upstream_version 1.8.0
-%global upstream_prever RC1
-%global upstream_lower ~rc1
+#global upstream_prever RC1
+#global upstream_lower ~rc1
Version: %{upstream_version}%{?upstream_lower}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
@@ -342,17 +338,21 @@ exit $ret
%changelog
+* Fri Jul 31 2020 Remi Collet <remi@remirepo.net> - 1.8.0-1
+- update to 1.8.0
+- with libbson and libmongoc 1.17.0
+
* Fri Jul 17 2020 Remi Collet <remi@remirepo.net> - 1.8.0~rc1-1
- update to 1.8.0RC1
-- with libbson and libmongoc 1.18.0-rc0
+- with libbson and libmongoc 1.17.0-rc0
* Thu Jun 11 2020 Remi Collet <remi@remirepo.net> - 1.8.0~beta2-1
- update to 1.8.0beta2
-- with libbson and libmongoc 1.18.0-beta2
+- with libbson and libmongoc 1.17.0-beta2
* Wed Apr 15 2020 Remi Collet <remi@remirepo.net> - 1.8.0~beta1-1
- update to 1.8.0beta1
-- with libbson and libmongoc 1.18.0-beta
+- with libbson and libmongoc 1.17.0-beta
* Wed Mar 11 2020 Remi Collet <remi@remirepo.net> - 1.7.4-1
- update to 1.7.4 (no change)