summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO14
-rw-r--r--REFLECTION4
-rw-r--r--php-pecl-mongodb.spec33
3 files changed, 30 insertions, 21 deletions
diff --git a/PHPINFO b/PHPINFO
index c27b3c9..479f332 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,12 +2,12 @@
mongodb
MongoDB support => enabled
-MongoDB extension version => 1.20.0
+MongoDB extension version => 1.20.1
MongoDB extension stability => stable
-libbson headers version => 1.28.0
-libbson library version => 1.28.0
-libmongoc headers version => 1.28.0
-libmongoc library version => 1.28.0
+libbson headers version => 1.29.0
+libbson library version => 1.29.0
+libmongoc headers version => 1.29.0
+libmongoc library version => 1.29.0
libmongoc SSL => enabled
libmongoc SSL library => OpenSSL
libmongoc crypto => enabled
@@ -19,8 +19,8 @@ libmongoc compression => enabled
libmongoc compression snappy => enabled
libmongoc compression zlib => enabled
libmongoc compression zstd => enabled
-libmongocrypt headers version => 1.11.0
-libmongocrypt library version => 1.11.0
+libmongocrypt headers version => 1.12.0
+libmongocrypt library version => 1.12.0
libmongocrypt crypto => enabled
libmongocrypt crypto library => libcrypto
crypt_shared library version => unknown
diff --git a/REFLECTION b/REFLECTION
index bbe5e8d..0b3fda4 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #113 mongodb version 1.20.0 ] {
+Extension [ <persistent> extension #120 mongodb version 1.20.1 ] {
- Dependencies {
Dependency [ date (Required) ]
@@ -14,7 +14,7 @@ Extension [ <persistent> extension #113 mongodb version 1.20.0 ] {
}
- Constants [2] {
- Constant [ string MONGODB_VERSION ] { 1.20.0 }
+ Constant [ string MONGODB_VERSION ] { 1.20.1 }
Constant [ string MONGODB_STABILITY ] { stable }
}
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index e4cf84f..e86a5cb 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -1,8 +1,8 @@
# remirepo spec file for php-pecl-mongodb
#
-# Copyright (c) 2015-2024 Remi Collet
-# License: CC-BY-SA-4.0
-# http://creativecommons.org/licenses/by-sa/4.0/
+# SPDX-FileCopyrightText: Copyright 2015-2025 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
# Please, preserve the changelog entries
#
@@ -14,6 +14,8 @@
%endif
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global pie_vend pie_vend
+%global pie_proj mongodb-extension
%global pecl_name mongodb
# After 40-smbclient.ini, see https://jira.mongodb.org/browse/PHPC-658
%global ini_name 50-%{pecl_name}.ini
@@ -22,22 +24,22 @@
%bcond_with tests
# temp for EL until available in EPEL
-%if 0%{?fedora} >= 37 || 0%{?rhel} >= 99
+%if 0%{?fedora} >= 37 || 0%{?rhel} >= 8
%bcond_without syslib
%else
%bcond_with syslib
%endif
# Bundled versions
-%global bundled_libmongo 1.28.0
+%global bundled_libmongo 1.28.1
%global bundled_libcrypt 1.11.0
-# Required versions
-%global minimal_libmongo 1.28.0
+# Required versions (in config.m4)
+%global minimal_libmongo 1.28.1
%global minimal_libcrypt 1.11.0
%if %{with syslib}
-# Build dependencies
-%global system_libmongo 1.28.0
+# Build dependencies (in repository)
+%global system_libmongo 1.28.1
%global system_libcrypt 1.11.0
# Runtime dependencies
%global runtime_libmongo %(pkg-config --silence-errors --modversion libmongoc-1.0 2>/dev/null || echo %{system_libmongo})
@@ -46,7 +48,7 @@
Summary: MongoDB driver for PHP
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-%global upstream_version 1.20.0
+%global upstream_version 1.20.1
#global upstream_prever beta1
#global upstream_lower ~beta1
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
@@ -98,8 +100,9 @@ Requires: %{?scl_prefix}php(api) = %{php_core_api}
Requires: %{?scl_prefix}php-json%{?_isa}
# Don't provide php-mongodb which is the pure PHP library
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pie(%{pie_vend}/%{pie_proj}) = %{version}
%description
The purpose of this driver is to provide exceptionally thin glue between
@@ -306,6 +309,12 @@ exit $ret
%changelog
+* Wed Nov 27 2024 Remi Collet <remi@remirepo.net> - 1.20.1-1
+- update to 1.20.1
+
+* Mon Sep 30 2024 Remi Collet <remi@remirepo.net> - 1.20.0-2
+- EL: rebuild with system libraries
+
* Tue Sep 24 2024 Remi Collet <remi@remirepo.net> - 1.20.0-1
- update to 1.20.0