summaryrefslogtreecommitdiffstats
path: root/php-pecl-mongodb.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-11-15 10:09:28 +0100
committerRemi Collet <remi@php.net>2023-11-15 10:09:28 +0100
commita4d6d80f5567ae6aefb720977c00bcf5410af504 (patch)
tree25beb26d8322c90128ee89250b202966f365b96a /php-pecl-mongodb.spec
parent38414bdc96f229c7b0486e51ace6673538a580fa (diff)
update to 1.17.0
raise dependency on PHP 7.4 EL use bundled libbson and libmongc 1.25.1 EL use bundled libmongocrypt 1.8.2 open https://github.com/mongodb/mongo-php-driver/pull/1490 drop ICU information
Diffstat (limited to 'php-pecl-mongodb.spec')
-rw-r--r--php-pecl-mongodb.spec49
1 files changed, 35 insertions, 14 deletions
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index b2b888b..102ef8e 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -25,20 +25,20 @@
%bcond_with tests
# temp for EL until available in EPEL
-%if 0%{?fedora} >= 36 || 0%{?rhel} >= 8
+%if 0%{?fedora} >= 37
%bcond_without syslib
%else
%bcond_with syslib
%endif
# Bundled versions
-%global bundled_libmongo 1.24.3
-%global bundled_libcrypt 1.8.1
+%global bundled_libmongo 1.25.1
+%global bundled_libcrypt 1.8.2
%if %{with syslib}
# Build dependencies
-%global system_libmongo 1.24.1
-%global system_libcrypt 1.8.1
+%global system_libmongo 1.25.1
+%global system_libcrypt 1.8.2
# Runtime dependencies
%global runtime_libmongo %(pkg-config --silence-errors --modversion libmongoc-1.0 2>/dev/null || echo %{system_libmongo})
%global runtime_libcrypt %(pkg-config --silence-errors --modversion libmongocrypt 2>/dev/null || echo %{system_libcrypt})
@@ -46,13 +46,13 @@
Summary: MongoDB driver for PHP
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-%global upstream_version 1.16.2
+%global upstream_version 1.17.0
#global upstream_prever beta1
#global upstream_lower ~beta1
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
Version: %{upstream_version}%{?upstream_lower}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%if %{with syslib}
License: Apache-2.0
%else
@@ -63,7 +63,7 @@ Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upst
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel >= 7.2
+BuildRequires: %{?scl_prefix}php-devel >= 7.4
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
%if %{with syslib}
@@ -74,13 +74,20 @@ Requires: libbson%{?_isa} >= %{runtime_libmongo}
Requires: mongo-c-driver-libs%{?_isa} >= %{runtime_libmongo}
Requires: libmongocrypt%{?_isa} >= %{runtime_libcrypt}
%else
-BuildRequires: cyrus-sasl-devel
BuildRequires: openssl-devel
-BuildRequires: libzstd-devel
+BuildRequires: pkgconfig(libsasl2)
+BuildRequires: pkgconfig(libzstd)
+BuildRequires: pkgconfig(zlib)
+%if 0%{?rhel} == 7
BuildRequires: snappy-devel
-BuildRequires: zlib-devel
-# We require 72 to ensure we use the same version than PHP
-BuildRequires: pkgconfig(icu-uc) >= 72
+BuildRequires: utf8proc-devel
+%else
+BuildRequires: pkgconfig(snappy)
+%if 0%{?rhel} == 9 || 0%{?fedora}
+# EL-8 will use bundled as only in subversion module
+BuildRequires: pkgconfig(libutf8proc)
+%endif
+%endif
Provides: bundled(libbson) = %{bundled_libmongo}
Provides: bundled(mongo-c-driver) = %{bundled_libmongo}
Provides: bundled(libmongocrypt) = %{bundled_libcrypt}
@@ -177,9 +184,16 @@ peclbuild() {
--with-mongodb-system-libs \
%else
--enable-mongodb-crypto-system-profile \
+ --with-mongodb-snappy \
+ --with-mongodb-zlib \
+ --with-mongodb-zstd \
--with-mongodb-sasl=cyrus \
- --with-mongodb-icu=yes \
--with-mongodb-ssl=openssl \
+%if 0%{?rhel} == 8
+ --with-mongodb-utf8proc=bundled \
+%else
+ --with-mongodb-utf8proc=system \
+%endif
%endif
--with-php-config=${1} \
--with-mongodb-client-side-encryption \
@@ -329,6 +343,13 @@ exit $ret
%changelog
+* Wed Nov 15 2023 Remi Collet <remi@remirepo.net> - 1.17.0-1
+- update to 1.17.0
+- raise dependency on PHP 7.4
+- EL use bundled libbson and libmongc 1.25.1
+- EL use bundled libmongocrypt 1.8.2
+- open https://github.com/mongodb/mongo-php-driver/pull/1490 drop ICU information
+
* Wed Aug 30 2023 Remi Collet <remi@remirepo.net> - 1.16.2-2
- rebuild for PHP 8.3.0RC1