summaryrefslogtreecommitdiffstats
path: root/php-pecl-mongodb.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-12-15 09:01:07 +0100
committerRemi Collet <remi@php.net>2021-12-15 09:01:07 +0100
commita3d64be341c27e0dcf16eb8eba4afd963186d9d3 (patch)
treee569d482c85969950980cccd05c7f0056316622d /php-pecl-mongodb.spec
parente6d3e956cb904c9e621283bcd67d72b81df77c41 (diff)
update to 1.12.0
with libbson and libmongoc 1.20.0 with libmongocrypt 1.3.0 raise dependency on PHP 7.2
Diffstat (limited to 'php-pecl-mongodb.spec')
-rw-r--r--php-pecl-mongodb.spec28
1 files changed, 13 insertions, 15 deletions
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index 7f41963..8a0c4a9 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -26,7 +26,7 @@
%bcond_with tests
# temp for EL-8 until available in EPEL
-%if 0%{?fedora} >= 32 || 0%{?rhel} >= 8
+%if 0%{?fedora} >= 33 || 0%{?rhel} >= 8
%bcond_without syslib
%else
%bcond_with syslib
@@ -34,20 +34,20 @@
%if %{with syslib}
# Build dependency
-%global libmongo 1.19.1
-%global libcrypt 1.2.1
+%global libmongo 1.20.0
+%global libcrypt 1.3.0
# Runtime dependency
%global libmongover %(pkg-config --silence-errors --modversion libmongoc-1.0 2>/dev/null || echo %{libmongo})
%global libcryptver %(pkg-config --silence-errors --modversion libmongocrypt 2>/dev/null || echo %{libcrypt})
%else
# Bundled versions
-%global libmongo 1.19.1
-%global libcrypt 1.2.1
+%global libmongo 1.20.1
+%global libcrypt 1.3.0
%endif
Summary: MongoDB driver for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-%global upstream_version 1.11.1
+%global upstream_version 1.12.0
#global upstream_prever alpha1
#global upstream_lower ~alpha1
Version: %{upstream_version}%{?upstream_lower}
@@ -58,7 +58,7 @@ Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upst
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel >= 7.1
+BuildRequires: %{?scl_prefix}php-devel >= 7.2
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
%if %{with syslib}
@@ -98,22 +98,14 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{rele
%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-%if "%{php_version}" > "5.6"
Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.0"
Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.1"
Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.3"
Obsoletes: php73-pecl-%{pecl_name} <= %{version}
Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
@@ -337,6 +329,12 @@ exit $ret
%changelog
+* Wed Dec 15 2021 Remi Collet <remi@remirepo.net> - 1.12.0-1
+- update to 1.12.0
+- with libbson and libmongoc 1.20.0
+- with libmongocrypt 1.3.0
+- raise dependency on PHP 7.2
+
* Wed Nov 3 2021 Remi Collet <remi@remirepo.net> - 1.11.1-1
- update to 1.11.1 (no change)