summaryrefslogtreecommitdiffstats
path: root/php-pecl-mongodb.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-09-02 18:23:28 +0200
committerRemi Collet <remi@remirepo.net>2019-09-02 18:23:28 +0200
commit62ab7c51c3956c032dd28b106c59faf813fa8d98 (patch)
tree44544c8c0d1b5def06f56f21a3a2a1cc8614747c /php-pecl-mongodb.spec
parent383f46afe55fc034a2073181c84395a1a2b1ef0f (diff)
1.6.0alpha3
Diffstat (limited to 'php-pecl-mongodb.spec')
-rw-r--r--php-pecl-mongodb.spec29
1 files changed, 20 insertions, 9 deletions
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index 107d84c..feec9c6 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -29,20 +29,21 @@
# test suite requires a MongoDB server
%global with_tests 0%{?_with_tests:1}
-# F30 for fedora repo, F27 for remi
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 9
+# F30 for fedora repo, F28 for remi
+%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
%global with_syslib 1
-%global libver 1.14
+%global libver 1.15
+%global libbuildver %(pkg-config --silence-errors --modversion libmongoc-1.0 2>/dev/null || echo %{libver})
%else
%global with_syslib 0
-%global libver 1.14.0
+%global libver 1.15.0
%endif
Summary: MongoDB driver for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
%global upstream_version 1.6.0
-%global upstream_prever alpha2
-%global upstream_lower ~alpha2
+%global upstream_prever alpha3
+%global upstream_lower ~alpha3
Version: %{upstream_version}%{?upstream_lower}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
@@ -50,12 +51,13 @@ URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel > 5.5
+BuildRequires: %{?scl_prefix}php-devel > 5.6
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
%if %{with_syslib}
-BuildRequires: pkgconfig(libbson-1.0) >= %{libver}
-BuildRequires: pkgconfig(libmongoc-1.0) >= %{libver}
+BuildRequires: pkgconfig(libbson-1.0) >= %{libver}
+BuildRequires: pkgconfig(libmongoc-1.0) >= %{libver}
+Requires: mongo-c-driver-libs%{?_isa} >= %{libbuildver}
%else
BuildRequires: cyrus-sasl-devel
BuildRequires: openssl-devel
@@ -326,6 +328,15 @@ exit $ret
%changelog
+* Thu Aug 22 2019 Remi Collet <remi@remirepo.net> - 1.6.0~alpha3-1
+- update to 1.6.0alpha3
+- with libbson and libmongoc 1.15.0
+- ensure proper library version is required
+- raise minimal PHP version to 5.6
+
+* Tue Jul 23 2019 Remi Collet <remi@remirepo.net> - 1.6.0~alpha2-2
+- rebuild for 7.4.0beta1
+
* Tue Jun 4 2019 Remi Collet <remi@remirepo.net> - 1.6.0~alpha2-1
- update to 1.6.0alpha2
- with libbson and libmongoc 1.14.0