summaryrefslogtreecommitdiffstats
path: root/php-pecl-mongodb.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-06-26 17:43:25 +0200
committerRemi Collet <remi@remirepo.net>2018-06-26 17:43:25 +0200
commit33fde6a2ab89dfc619179d6d746670fb850f946d (patch)
tree35af0a4a5f927f79b008fd6d7cabaf3c4dbdd99c /php-pecl-mongodb.spec
parent8db2180f76827584af4275dffa01fa2682fa3868 (diff)
update to 1.5.0
with libbson and libmongoc 1.11.0 add dependency on icu
Diffstat (limited to 'php-pecl-mongodb.spec')
-rw-r--r--php-pecl-mongodb.spec24
1 files changed, 17 insertions, 7 deletions
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index cccb077..5c6d314 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -38,15 +38,15 @@
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
%global with_syslib 1
-%global libver 1.9
+%global libver 1.11
%else
%global with_syslib 0
-%global libver 1.9.4
+%global libver 1.11.0
%endif
Summary: MongoDB driver for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-%global upstream_version 1.4.4
+%global upstream_version 1.5.0
#global upstream_prever RC2
#global upstream_lower ~rc2
Version: %{upstream_version}%{?upstream_lower}
@@ -70,6 +70,8 @@ Provides: bundled(mongo-c-driver) = %{libver}
%endif
BuildRequires: snappy-devel
BuildRequires: zlib-devel
+# We require 50 to ensure use of libicu-last (same version than PHP)
+BuildRequires: libicu-devel >= 50
%if %{with_tests}
BuildRequires: mongodb-server
%endif
@@ -133,7 +135,7 @@ sed -e 's/role="test"/role="src"/' \
cd NTS
# Sanity check, really often broken
-extver=$(sed -n '/#define PHP_MONGODB_VERSION/{s/.* "//;s/".*$//;p}' php_phongo.h)
+extver=$(sed -n '/#define PHP_MONGODB_VERSION /{s/.* "//;s/".*$//;p}' phongo_version.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
: Error: Upstream extension version is ${extver}, expecting %{upstream_version}%{?upstream_prever}.
exit 1
@@ -164,21 +166,24 @@ peclbuild() {
%if %{with_syslib}
# Ensure we use system library
# Need to be removed only after phpize because of m4_include
- rm -r src/libbson
rm -r src/libmongoc
%configure \
--with-php-config=%{_bindir}/${1}-config \
--with-libbson \
--with-libmongoc \
- --with-mongodb-sasl \
+ --with-mongodb-sasl=cyrus \
+ --with-mongodb-icu=yes \
+ --with-mongodb-ssl=openssl \
--enable-mongodb
%else
%configure \
--with-php-config=%{_bindir}/${1}-config \
--enable-mongodb-crypto-system-profile \
- --with-mongodb-sasl \
+ --with-mongodb-sasl=cyrus \
+ --with-mongodb-icu=yes \
+ --with-mongodb-ssl=openssl \
--enable-mongodb
%endif
@@ -322,6 +327,11 @@ exit $ret
%changelog
+* Tue Jun 26 2018 Remi Collet <remi@remirepo.net> - 1.5.0-1
+- update to 1.5.0
+- with libbson and libmongoc 1.11.0
+- add dependency on icu
+
* Thu Jun 7 2018 Remi Collet <remi@remirepo.net> - 1.4.4-1
- update to 1.4.4