summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-02-09 15:06:37 +0100
committerRemi Collet <remi@php.net>2023-02-09 15:06:37 +0100
commitf2bfc07eb0a5cbffd2e70a49f92877574fb12ca8 (patch)
tree471e9bdc84f2657146db01715b6f51a920360f87
parent773d3d5f908daa53eb3c0e139f3f6efa325f11b3 (diff)
update to 1.15.1
EL-7 use bundled libbson and libmongc 1.23.2 cleanup spec macros use spdx license id
-rw-r--r--PHPINFO14
-rw-r--r--REFLECTION117
-rw-r--r--php-pecl-mongodb.spec69
3 files changed, 130 insertions, 70 deletions
diff --git a/PHPINFO b/PHPINFO
index 308418d..c6bebf0 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,12 +2,12 @@
mongodb
MongoDB support => enabled
-MongoDB extension version => 1.15.0
+MongoDB extension version => 1.15.1
MongoDB extension stability => stable
-libbson headers version => 1.23.1
-libbson library version => 1.23.1
-libmongoc headers version => 1.23.1
-libmongoc library version => 1.23.1
+libbson headers version => 1.23.2
+libbson library version => 1.23.2
+libmongoc headers version => 1.23.2
+libmongoc library version => 1.23.2
libmongoc SSL => enabled
libmongoc SSL library => OpenSSL
libmongoc crypto => enabled
@@ -19,8 +19,8 @@ libmongoc compression => enabled
libmongoc compression snappy => enabled
libmongoc compression zlib => enabled
libmongoc compression zstd => enabled
-libmongocrypt headers version => 1.6.1
-libmongocrypt library version => 1.6.1
+libmongocrypt headers version => 1.7.1
+libmongocrypt library version => 1.7.1
libmongocrypt crypto => enabled
libmongocrypt crypto library => libcrypto
crypt_shared library version => unknown
diff --git a/REFLECTION b/REFLECTION
index d86e9d0..d2c8dd7 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
+Extension [ <persistent> extension #115 mongodb version 1.15.1 ] {
- Dependencies {
Dependency [ date (Required) ]
@@ -14,7 +14,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
}
- Constants [2] {
- Constant [ string MONGODB_VERSION ] { 1.15.0 }
+ Constant [ string MONGODB_VERSION ] { 1.15.1 }
Constant [ string MONGODB_STABILITY ] { stable }
}
@@ -116,6 +116,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [0] {
}
+ - Tentative return [ object|array ]
}
}
}
@@ -140,6 +141,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [1] {
Parameter #0 [ <required> array $data ]
}
+ - Tentative return [ void ]
}
}
}
@@ -163,12 +165,14 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [0] {
}
+ - Tentative return [ string ]
}
Method [ <internal:mongodb> abstract public method getType ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:mongodb, prototype Stringable> abstract public method __toString ] {
@@ -199,7 +203,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [0] {
}
- - Return [ string ]
+ - Tentative return [ string ]
}
}
}
@@ -223,19 +227,21 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [0] {
}
+ - Tentative return [ string ]
}
Method [ <internal:mongodb> abstract public method getScope ] {
- Parameters [0] {
}
+ - Tentative return [ ?object ]
}
Method [ <internal:mongodb, prototype Stringable> abstract public method __toString ] {
- Parameters [0] {
}
- - Return [ string ]
+ - Tentative return [ string ]
}
}
}
@@ -295,13 +301,14 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:mongodb, prototype Stringable> abstract public method __toString ] {
- Parameters [0] {
}
- - Return [ string ]
+ - Tentative return [ string ]
}
}
}
@@ -325,19 +332,21 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [0] {
}
+ - Tentative return [ string ]
}
Method [ <internal:mongodb> abstract public method getFlags ] {
- Parameters [0] {
}
+ - Tentative return [ string ]
}
Method [ <internal:mongodb, prototype Stringable> abstract public method __toString ] {
- Parameters [0] {
}
- - Return [ string ]
+ - Tentative return [ string ]
}
}
}
@@ -361,19 +370,21 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:mongodb> abstract public method getIncrement ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:mongodb, prototype Stringable> abstract public method __toString ] {
- Parameters [0] {
}
- - Return [ string ]
+ - Tentative return [ string ]
}
}
}
@@ -397,13 +408,14 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [0] {
}
+ - Tentative return [ DateTime ]
}
Method [ <internal:mongodb, prototype Stringable> abstract public method __toString ] {
- Parameters [0] {
}
- - Return [ string ]
+ - Tentative return [ string ]
}
}
}
@@ -1029,6 +1041,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [0] {
}
+ - Tentative return [ object|array ]
}
Method [ <internal:mongodb, inherits MongoDB\BSON\Unserializable> abstract public method bsonUnserialize ] {
@@ -1036,6 +1049,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [1] {
Parameter #0 [ <required> array $data ]
}
+ - Tentative return [ void ]
}
}
}
@@ -1455,18 +1469,21 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [0] {
}
+ - Tentative return [ MongoDB\Driver\CursorId ]
}
Method [ <internal:mongodb> abstract public method getServer ] {
- Parameters [0] {
}
+ - Tentative return [ MongoDB\Driver\Server ]
}
Method [ <internal:mongodb> abstract public method isDead ] {
- Parameters [0] {
}
+ - Tentative return [ bool ]
}
Method [ <internal:mongodb> abstract public method setTypeMap ] {
@@ -1474,12 +1491,14 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [1] {
Parameter #0 [ <required> array $typemap ]
}
+ - Tentative return [ void ]
}
Method [ <internal:mongodb> abstract public method toArray ] {
- Parameters [0] {
}
+ - Tentative return [ array ]
}
}
}
@@ -3205,8 +3224,8 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Properties [5] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
Property [ protected $errorLabels = NULL ]
}
@@ -3232,6 +3251,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -3305,8 +3325,8 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Properties [5] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
Property [ protected $errorLabels = NULL ]
}
@@ -3332,6 +3352,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -3405,8 +3426,8 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Properties [5] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
Property [ protected $errorLabels = NULL ]
}
@@ -3432,6 +3453,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -3505,8 +3527,8 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Properties [6] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
Property [ protected $errorLabels = NULL ]
Property [ protected $writeResult = NULL ]
}
@@ -3540,6 +3562,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -3613,8 +3636,8 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Properties [5] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
Property [ protected $errorLabels = NULL ]
}
@@ -3640,6 +3663,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -3713,8 +3737,8 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Properties [6] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
Property [ protected $errorLabels = NULL ]
Property [ protected $writeResult = NULL ]
}
@@ -3748,6 +3772,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -3821,8 +3846,8 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Properties [6] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
Property [ protected $errorLabels = NULL ]
Property [ protected $resultDocument = NULL ]
}
@@ -3856,6 +3881,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -3929,8 +3955,8 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Properties [5] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
Property [ protected $errorLabels = NULL ]
}
@@ -3956,6 +3982,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -4029,8 +4056,8 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Properties [5] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
Property [ protected $errorLabels = NULL ]
}
@@ -4056,6 +4083,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -4129,8 +4157,8 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Properties [5] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
Property [ protected $errorLabels = NULL ]
}
@@ -4156,6 +4184,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -4229,8 +4258,8 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
@@ -4247,6 +4276,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -4320,8 +4350,8 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
@@ -4338,6 +4368,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -4411,8 +4442,8 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Properties [5] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
Property [ protected $errorLabels = NULL ]
}
@@ -4438,6 +4469,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -4511,8 +4543,8 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
@@ -4529,6 +4561,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -4626,6 +4659,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [1] {
Parameter #0 [ <required> MongoDB\Driver\Monitoring\CommandStartedEvent $event ]
}
+ - Tentative return [ void ]
}
Method [ <internal:mongodb> abstract public method commandSucceeded ] {
@@ -4633,6 +4667,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [1] {
Parameter #0 [ <required> MongoDB\Driver\Monitoring\CommandSucceededEvent $event ]
}
+ - Tentative return [ void ]
}
Method [ <internal:mongodb> abstract public method commandFailed ] {
@@ -4640,6 +4675,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [1] {
Parameter #0 [ <required> MongoDB\Driver\Monitoring\CommandFailedEvent $event ]
}
+ - Tentative return [ void ]
}
}
}
@@ -4929,6 +4965,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [1] {
Parameter #0 [ <required> MongoDB\Driver\Monitoring\ServerChangedEvent $event ]
}
+ - Tentative return [ void ]
}
Method [ <internal:mongodb> abstract public method serverClosed ] {
@@ -4936,6 +4973,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [1] {
Parameter #0 [ <required> MongoDB\Driver\Monitoring\ServerClosedEvent $event ]
}
+ - Tentative return [ void ]
}
Method [ <internal:mongodb> abstract public method serverOpening ] {
@@ -4943,6 +4981,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [1] {
Parameter #0 [ <required> MongoDB\Driver\Monitoring\ServerOpeningEvent $event ]
}
+ - Tentative return [ void ]
}
Method [ <internal:mongodb> abstract public method serverHeartbeatFailed ] {
@@ -4950,6 +4989,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [1] {
Parameter #0 [ <required> MongoDB\Driver\Monitoring\ServerHeartbeatFailedEvent $event ]
}
+ - Tentative return [ void ]
}
Method [ <internal:mongodb> abstract public method serverHeartbeatStarted ] {
@@ -4957,6 +4997,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [1] {
Parameter #0 [ <required> MongoDB\Driver\Monitoring\ServerHeartbeatStartedEvent $event ]
}
+ - Tentative return [ void ]
}
Method [ <internal:mongodb> abstract public method serverHeartbeatSucceeded ] {
@@ -4964,6 +5005,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [1] {
Parameter #0 [ <required> MongoDB\Driver\Monitoring\ServerHeartbeatSucceededEvent $event ]
}
+ - Tentative return [ void ]
}
Method [ <internal:mongodb> abstract public method topologyChanged ] {
@@ -4971,6 +5013,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [1] {
Parameter #0 [ <required> MongoDB\Driver\Monitoring\TopologyChangedEvent $event ]
}
+ - Tentative return [ void ]
}
Method [ <internal:mongodb> abstract public method topologyClosed ] {
@@ -4978,6 +5021,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [1] {
Parameter #0 [ <required> MongoDB\Driver\Monitoring\TopologyClosedEvent $event ]
}
+ - Tentative return [ void ]
}
Method [ <internal:mongodb> abstract public method topologyOpening ] {
@@ -4985,6 +5029,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.0 ] {
- Parameters [1] {
Parameter #0 [ <required> MongoDB\Driver\Monitoring\TopologyOpeningEvent $event ]
}
+ - Tentative return [ void ]
}
}
}
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index 1c8e055..0dd702a 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -1,7 +1,7 @@
# remirepo spec file for php-pecl-mongodb
#
-# Copyright (c) 2015-2022 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2015-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
@@ -32,27 +32,31 @@
%bcond_with syslib
%endif
-%if %{with syslib}
-# Build dependency
-%global libmongo 1.23.1
-%global libcrypt 1.5.2
-# Runtime dependency
-%global libmongover %(pkg-config --silence-errors --modversion libmongoc-1.0 2>/dev/null || echo %{libmongo})
-%global libcryptver %(pkg-config --silence-errors --modversion libmongocrypt 2>/dev/null || echo %{libcrypt})
-%else
# Bundled versions
-%global libmongo 1.23.1
-%global libcrypt 1.5.2
+%global bundled_libmongo 1.23.2
+%global bundled_libcrypt 1.5.2
+
+%if %{with syslib}
+# Build dependencies
+%global system_libmongo 1.23.1
+%global system_libcrypt 1.5.2
+# Runtime dependencies
+%global runtime_libmongo %(pkg-config --silence-errors --modversion libmongoc-1.0 2>/dev/null || echo %{system_libmongo})
+%global runtime_libcrypt %(pkg-config --silence-errors --modversion libmongocrypt 2>/dev/null || echo %{system_libcrypt})
%endif
Summary: MongoDB driver for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-%global upstream_version 1.15.0
+%global upstream_version 1.15.1
#global upstream_prever beta1
#global upstream_lower ~beta1
Version: %{upstream_version}%{?upstream_lower}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-License: ASL 2.0
+%if %{with syslib}
+License: Apache-2.0
+%else
+License: Apache-2.0 AND ISC AND MIT AND Zlib AND BSD-3-Clause
+%endif
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
@@ -62,12 +66,12 @@ BuildRequires: %{?scl_prefix}php-devel >= 7.2
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
%if %{with syslib}
-BuildRequires: pkgconfig(libbson-1.0) >= %{libmongo}
-BuildRequires: pkgconfig(libmongoc-1.0) >= %{libmongo}
-BuildRequires: pkgconfig(libmongocrypt) >= %{libcrypt}
-Requires: libbson%{?_isa} >= %{libmongover}
-Requires: mongo-c-driver-libs%{?_isa} >= %{libmongover}
-Requires: libmongocrypt%{?_isa} >= %{libcryptver}
+BuildRequires: pkgconfig(libbson-1.0) >= %{system_libmongo}
+BuildRequires: pkgconfig(libmongoc-1.0) >= %{system_libmongo}
+BuildRequires: pkgconfig(libmongocrypt) >= %{system_libcrypt}
+Requires: libbson%{?_isa} >= %{runtime_libmongo}
+Requires: mongo-c-driver-libs%{?_isa} >= %{runtime_libmongo}
+Requires: libmongocrypt%{?_isa} >= %{runtime_libcrypt}
%else
BuildRequires: cyrus-sasl-devel
BuildRequires: openssl-devel
@@ -76,9 +80,9 @@ BuildRequires: snappy-devel
BuildRequires: zlib-devel
# We require 69 to ensure we use the same version than PHP
BuildRequires: pkgconfig(icu-uc) >= 69
-Provides: bundled(libbson) = %{libmongo}
-Provides: bundled(mongo-c-driver) = %{libmongo}
-Provides: bundled(libmongocrypt) = %{libcrypt}
+Provides: bundled(libbson) = %{bundled_libmongo}
+Provides: bundled(mongo-c-driver) = %{bundled_libmongo}
+Provides: bundled(libmongocrypt) = %{bundled_libcrypt}
%endif
%if %{with tests}
BuildRequires: mongodb-server
@@ -134,10 +138,10 @@ sed -e 's/role="test"/role="src"/' \
%{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
-i package.xml
-cd NTS
+pushd NTS
%if %{with syslib}
-# temporary: lower minimal required version
-sed -e 's/1.21.1/%{libmongo}/;s/1.3.2/%{libcrypt}/' -i config.m4
+# temporary: lower minimal required versions
+sed -e 's/%{bundled_libmongo}/%{system_libmongo}/;s/%{bundled_libcrypt}/%{system_libcrypt}/' -i config.m4
%endif
# Sanity check, really often broken
@@ -146,8 +150,13 @@ if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
: Error: Upstream extension version is ${extver}, expecting %{upstream_version}%{?upstream_prever}.
exit 1
fi
-cd ..
+# Check our macro values
+cat src/*_VERSION_CURRENT
+grep %{bundled_libmongo} src/LIBMONGOC_VERSION_CURRENT
+grep %{bundled_libcrypt} src/LIBMONGOCRYPT_VERSION_CURRENT
+
+popd
%if %{with_zts}
# Duplicate source tree for NTS / ZTS build
cp -pr NTS ZTS
@@ -323,6 +332,12 @@ exit $ret
%changelog
+* Thu Feb 9 2023 Remi Collet <remi@remirepo.net> - 1.15.1-1
+- update to 1.15.1
+- EL-7 use bundled libbson and libmongc 1.23.2
+- cleanup spec macros
+- use spdx license id
+
* Wed Nov 23 2022 Remi Collet <remi@remirepo.net> - 1.15.0-1
- update to 1.15.0
- EL-7 use bundled libbson and libmongc 1.23.1