summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-03-28 07:20:12 +0100
committerRemi Collet <remi@php.net>2024-03-28 07:20:12 +0100
commitde702a9695bc5be628e1f2a3041a1d18224494eb (patch)
tree3da8680286e3bd9debb1283d4ce83c910ffcaa6a
parent5bc3a528a9df8661707738e8bf9a539410b1a263 (diff)
update to 1.18.0
EL use bundled libbson and libmongc 1.26.1 EL use bundled libmongocrypt 1.9.1
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION238
-rw-r--r--php-pecl-mongodb.spec17
3 files changed, 40 insertions, 217 deletions
diff --git a/PHPINFO b/PHPINFO
index 45a9aa9..fe11834 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
mongodb
MongoDB support => enabled
-MongoDB extension version => 1.17.3
+MongoDB extension version => 1.18.0
MongoDB extension stability => stable
libbson headers version => 1.26.1
libbson library version => 1.26.1
diff --git a/REFLECTION b/REFLECTION
index 18113e9..a022c34 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
+Extension [ <persistent> extension #94 mongodb version 1.18.0 ] {
- Dependencies {
Dependency [ date (Required) ]
@@ -14,7 +14,7 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
}
- Constants [2] {
- Constant [ string MONGODB_VERSION ] { 1.17.3 }
+ Constant [ string MONGODB_VERSION ] { 1.18.0 }
Constant [ string MONGODB_STABILITY ] { stable }
}
@@ -443,7 +443,7 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
- Properties [0] {
}
- - Methods [7] {
+ - Methods [6] {
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
@@ -484,13 +484,6 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
}
- Return [ bool ]
}
-
- Method [ <internal:mongodb> final public method __wakeup ] {
-
- - Parameters [0] {
- }
- - Return [ void ]
- }
}
}
@@ -1929,7 +1922,7 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
- Properties [0] {
}
- - Methods [6] {
+ - Methods [5] {
Method [ <internal:mongodb, ctor> final public method __construct ] {
- Parameters [1] {
@@ -1970,13 +1963,6 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
}
- Return [ void ]
}
-
- Method [ <internal:mongodb> final public method __wakeup ] {
-
- - Parameters [0] {
- }
- - Return [ void ]
- }
}
}
@@ -2001,7 +1987,7 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
- Properties [0] {
}
- - Methods [13] {
+ - Methods [12] {
Method [ <internal:mongodb, ctor> final public method __construct ] {
- Parameters [1] {
@@ -2101,13 +2087,6 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
}
- Return [ object ]
}
-
- Method [ <internal:mongodb> final public method __wakeup ] {
-
- - Parameters [0] {
- }
- - Return [ void ]
- }
}
}
@@ -2125,7 +2104,7 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
- Properties [0] {
}
- - Methods [2] {
+ - Methods [1] {
Method [ <internal:mongodb, ctor> final public method __construct ] {
- Parameters [2] {
@@ -2133,13 +2112,6 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
Parameter #1 [ <optional> ?array $commandOptions = null ]
}
}
-
- Method [ <internal:mongodb> final public method __wakeup ] {
-
- - Parameters [0] {
- }
- - Return [ void ]
- }
}
}
@@ -2157,7 +2129,7 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
- Properties [0] {
}
- - Methods [12] {
+ - Methods [11] {
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
@@ -2234,13 +2206,6 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
}
- Return [ bool ]
}
-
- Method [ <internal:mongodb> final public method __wakeup ] {
-
- - Parameters [0] {
- }
- - Return [ void ]
- }
}
}
@@ -2325,7 +2290,7 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
- Properties [0] {
}
- - Methods [18] {
+ - Methods [17] {
Method [ <internal:mongodb, ctor> final public method __construct ] {
- Parameters [3] {
@@ -2469,13 +2434,6 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
}
- Return [ MongoDB\Driver\Session ]
}
-
- Method [ <internal:mongodb> final public method __wakeup ] {
-
- - Parameters [0] {
- }
- - Return [ void ]
- }
}
}
@@ -2493,7 +2451,7 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
- Properties [0] {
}
- - Methods [2] {
+ - Methods [1] {
Method [ <internal:mongodb, ctor> final public method __construct ] {
- Parameters [2] {
@@ -2501,13 +2459,6 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
Parameter #1 [ <optional> ?array $queryOptions = null ]
}
}
-
- Method [ <internal:mongodb> final public method __wakeup ] {
-
- - Parameters [0] {
- }
- - Return [ void ]
- }
}
}
@@ -2739,7 +2690,7 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
- Properties [0] {
}
- - Methods [20] {
+ - Methods [19] {
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
@@ -2889,13 +2840,6 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
}
- Return [ bool ]
}
-
- Method [ <internal:mongodb> final public method __wakeup ] {
-
- - Parameters [0] {
- }
- - Return [ void ]
- }
}
}
@@ -2994,7 +2938,7 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
- Properties [0] {
}
- - Methods [8] {
+ - Methods [7] {
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
@@ -3042,13 +2986,6 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
}
- Return [ string ]
}
-
- Method [ <internal:mongodb> final public method __wakeup ] {
-
- - Parameters [0] {
- }
- - Return [ void ]
- }
}
}
@@ -3072,7 +3009,7 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
- Properties [0] {
}
- - Methods [6] {
+ - Methods [5] {
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
@@ -3107,13 +3044,6 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
}
- Return [ bool ]
}
-
- Method [ <internal:mongodb> final public method __wakeup ] {
-
- - Parameters [0] {
- }
- - Return [ void ]
- }
}
}
@@ -3136,7 +3066,7 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
- Properties [0] {
}
- - Methods [16] {
+ - Methods [15] {
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
@@ -3243,13 +3173,6 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
}
- Return [ void ]
}
-
- Method [ <internal:mongodb> final public method __wakeup ] {
-
- - Parameters [0] {
- }
- - Return [ void ]
- }
}
}
@@ -3366,7 +3289,7 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
- Properties [0] {
}
- - Methods [5] {
+ - Methods [4] {
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
@@ -3393,13 +3316,6 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
}
- Return [ string ]
}
-
- Method [ <internal:mongodb> final public method __wakeup ] {
-
- - Parameters [0] {
- }
- - Return [ void ]
- }
}
}
@@ -3417,7 +3333,7 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
- Properties [0] {
}
- - Methods [6] {
+ - Methods [5] {
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
@@ -3451,13 +3367,6 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
}
- Return [ string ]
}
-
- Method [ <internal:mongodb> final public method __wakeup ] {
-
- - Parameters [0] {
- }
- - Return [ void ]
- }
}
}
@@ -3475,7 +3384,7 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
- Properties [0] {
}
- - Methods [13] {
+ - Methods [12] {
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
@@ -3558,13 +3467,6 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
}
- Return [ bool ]
}
-
- Method [ <internal:mongodb> final public method __wakeup ] {
-
- - Parameters [0] {
- }
- - Return [ void ]
- }
}
}
@@ -5124,7 +5026,7 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
- Properties [0] {
}
- - Methods [11] {
+ - Methods [10] {
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
@@ -5193,13 +5095,6 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
}
- Return [ ?int ]
}
-
- Method [ <internal:mongodb> final public method __wakeup ] {
-
- - Parameters [0] {
- }
- - Return [ void ]
- }
}
}
@@ -5217,7 +5112,7 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
- Properties [0] {
}
- - Methods [10] {
+ - Methods [9] {
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
@@ -5279,13 +5174,6 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
}
- Return [ ?int ]
}
-
- Method [ <internal:mongodb> final public method __wakeup ] {
-
- - Parameters [0] {
- }
- - Return [ void ]
- }
}
}
@@ -5303,7 +5191,7 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
- Properties [0] {
}
- - Methods [10] {
+ - Methods [9] {
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
@@ -5365,13 +5253,6 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
}
- Return [ ?int ]
}
-
- Method [ <internal:mongodb> final public method __wakeup ] {
-
- - Parameters [0] {
- }
- - Return [ void ]
- }
}
}
@@ -5511,7 +5392,7 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
- Properties [0] {
}
- - Methods [7] {
+ - Methods [6] {
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
@@ -5552,13 +5433,6 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
}
- Return [ MongoDB\BSON\ObjectId ]
}
-
- Method [ <internal:mongodb> final public method __wakeup ] {
-
- - Parameters [0] {
- }
- - Return [ void ]
- }
}
}
@@ -5576,7 +5450,7 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
- Properties [0] {
}
- - Methods [5] {
+ - Methods [4] {
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
@@ -5603,13 +5477,6 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
}
- Return [ MongoDB\BSON\ObjectId ]
}
-
- Method [ <internal:mongodb> final public method __wakeup ] {
-
- - Parameters [0] {
- }
- - Return [ void ]
- }
}
}
@@ -5627,7 +5494,7 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
- Properties [0] {
}
- - Methods [7] {
+ - Methods [6] {
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
@@ -5668,13 +5535,6 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
}
- Return [ bool ]
}
-
- Method [ <internal:mongodb> final public method __wakeup ] {
-
- - Parameters [0] {
- }
- - Return [ void ]
- }
}
}
@@ -5692,7 +5552,7 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
- Properties [0] {
}
- - Methods [5] {
+ - Methods [4] {
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
@@ -5719,13 +5579,6 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
}
- Return [ bool ]
}
-
- Method [ <internal:mongodb> final public method __wakeup ] {
-
- - Parameters [0] {
- }
- - Return [ void ]
- }
}
}
@@ -5743,7 +5596,7 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
- Properties [0] {
}
- - Methods [7] {
+ - Methods [6] {
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
@@ -5784,13 +5637,6 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
}
- Return [ bool ]
}
-
- Method [ <internal:mongodb> final public method __wakeup ] {
-
- - Parameters [0] {
- }
- - Return [ void ]
- }
}
}
@@ -5808,7 +5654,7 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
- Properties [0] {
}
- - Methods [5] {
+ - Methods [4] {
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
@@ -5835,13 +5681,6 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
}
- Return [ MongoDB\BSON\ObjectId ]
}
-
- Method [ <internal:mongodb> final public method __wakeup ] {
-
- - Parameters [0] {
- }
- - Return [ void ]
- }
}
}
@@ -5859,7 +5698,7 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
- Properties [0] {
}
- - Methods [5] {
+ - Methods [4] {
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
@@ -5886,13 +5725,6 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
}
- Return [ MongoDB\BSON\ObjectId ]
}
-
- Method [ <internal:mongodb> final public method __wakeup ] {
-
- - Parameters [0] {
- }
- - Return [ void ]
- }
}
}
@@ -5910,7 +5742,7 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
- Properties [0] {
}
- - Methods [3] {
+ - Methods [2] {
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
@@ -5923,13 +5755,6 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
}
- Return [ MongoDB\BSON\ObjectId ]
}
-
- Method [ <internal:mongodb> final public method __wakeup ] {
-
- - Parameters [0] {
- }
- - Return [ void ]
- }
}
}
@@ -5947,7 +5772,7 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
- Properties [0] {
}
- - Methods [3] {
+ - Methods [2] {
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
@@ -5960,13 +5785,6 @@ Extension [ <persistent> extension #92 mongodb version 1.17.3 ] {
}
- Return [ MongoDB\BSON\ObjectId ]
}
-
- Method [ <internal:mongodb> final public method __wakeup ] {
-
- - Parameters [0] {
- }
- - Return [ void ]
- }
}
}
}
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index 8a4bec2..48307fb 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-mongodb
#
-# Copyright (c) 2015-2023 Remi Collet
+# Copyright (c) 2015-2024 Remi Collet
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -29,13 +29,13 @@
%endif
# Bundled versions
-%global bundled_libmongo 1.25.4
-%global bundled_libcrypt 1.8.4
+%global bundled_libmongo 1.26.1
+%global bundled_libcrypt 1.9.1
%if %{with syslib}
# Build dependencies
-%global system_libmongo 1.25.4
-%global system_libcrypt 1.8.4
+%global system_libmongo 1.26.1
+%global system_libcrypt 1.9.1
# Runtime dependencies
%global runtime_libmongo %(pkg-config --silence-errors --modversion libmongoc-1.0 2>/dev/null || echo %{system_libmongo})
%global runtime_libcrypt %(pkg-config --silence-errors --modversion libmongocrypt 2>/dev/null || echo %{system_libcrypt})
@@ -43,7 +43,7 @@
Summary: MongoDB driver for PHP
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-%global upstream_version 1.17.3
+%global upstream_version 1.18.0
#global upstream_prever beta1
#global upstream_lower ~beta1
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
@@ -340,6 +340,11 @@ exit $ret
%changelog
+* Thu Mar 28 2024 Remi Collet <remi@remirepo.net> - 1.18.0-1
+- update to 1.18.0
+- EL use bundled libbson and libmongc 1.26.1
+- EL use bundled libmongocrypt 1.9.1
+
* Tue Mar 19 2024 Remi Collet <remi@remirepo.net> - 1.17.3-1
- update to 1.17.3 (no change)
- EL use bundled libbson and libmongc 1.25.4