summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-09-02 18:43:10 +0200
committerRemi Collet <remi@remirepo.net>2019-09-02 18:43:10 +0200
commitdcb4439c1c98552cf57119f3fc8349dcd89e9b91 (patch)
tree679ebf0e71a2cf320a29a5e52ca9c753315639a1
parent62ab7c51c3956c032dd28b106c59faf813fa8d98 (diff)
1.6.0RC1
-rw-r--r--PHPINFO12
-rw-r--r--REFLECTION16
-rw-r--r--php-pecl-mongodb.spec9
3 files changed, 23 insertions, 14 deletions
diff --git a/PHPINFO b/PHPINFO
index ca5a4d7..b7aa5dc 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,12 +2,12 @@
mongodb
MongoDB support => enabled
-MongoDB extension version => 1.6.0alpha3
-MongoDB extension stability => alpha
-libbson headers version => 1.15.0
-libbson library version => 1.15.0
-libmongoc headers version => 1.15.0
-libmongoc library version => 1.15.0
+MongoDB extension version => 1.6.0RC1
+MongoDB extension stability => beta
+libbson headers version => 1.15.1
+libbson library version => 1.15.1
+libmongoc headers version => 1.15.1
+libmongoc library version => 1.15.1
libmongoc SSL => enabled
libmongoc SSL library => OpenSSL
libmongoc crypto => enabled
diff --git a/REFLECTION b/REFLECTION
index f88d056..3b821cb 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #194 mongodb version 1.6.0alpha3 ] {
+Extension [ <persistent> extension #194 mongodb version 1.6.0RC1 ] {
- Dependencies {
Dependency [ date (Required) ]
@@ -14,8 +14,8 @@ Extension [ <persistent> extension #194 mongodb version 1.6.0alpha3 ] {
}
- Constants [2] {
- Constant [ string MONGODB_VERSION ] { 1.6.0alpha3 }
- Constant [ string MONGODB_STABILITY ] { alpha }
+ Constant [ string MONGODB_VERSION ] { 1.6.0RC1 }
+ Constant [ string MONGODB_STABILITY ] { beta }
}
- Functions {
@@ -1830,7 +1830,7 @@ Extension [ <persistent> extension #194 mongodb version 1.6.0alpha3 ] {
- Properties [0] {
}
- - Methods [12] {
+ - Methods [13] {
Method [ <internal:mongodb> final public method abortTransaction ] {
- Parameters [0] {
@@ -1881,6 +1881,12 @@ Extension [ <persistent> extension #194 mongodb version 1.6.0alpha3 ] {
}
}
+ Method [ <internal:mongodb> final public method getServer ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:mongodb> final public method isInTransaction ] {
- Parameters [0] {
@@ -1890,7 +1896,7 @@ Extension [ <persistent> extension #194 mongodb version 1.6.0alpha3 ] {
Method [ <internal:mongodb> final public method startTransaction ] {
- Parameters [1] {
- Parameter #0 [ <optional> $options ]
+ Parameter #0 [ <optional> array or NULL $options ]
}
}
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index feec9c6..c478927 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -36,14 +36,14 @@
%global libbuildver %(pkg-config --silence-errors --modversion libmongoc-1.0 2>/dev/null || echo %{libver})
%else
%global with_syslib 0
-%global libver 1.15.0
+%global libver 1.15.1
%endif
Summary: MongoDB driver for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
%global upstream_version 1.6.0
-%global upstream_prever alpha3
-%global upstream_lower ~alpha3
+%global upstream_prever RC1
+%global upstream_lower ~rc1
Version: %{upstream_version}%{?upstream_lower}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
@@ -328,6 +328,9 @@ exit $ret
%changelog
+* Mon Sep 2 2019 Remi Collet <remi@remirepo.net> - 1.6.0~rc1-1
+- update to 1.6.0RC1
+
* Thu Aug 22 2019 Remi Collet <remi@remirepo.net> - 1.6.0~alpha3-1
- update to 1.6.0alpha3
- with libbson and libmongoc 1.15.0