summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-12-06 09:16:28 +0100
committerRemi Collet <remi@php.net>2023-12-06 09:16:28 +0100
commitdb0dc111b94923f3e82de7be6851c219c568bfd2 (patch)
tree83c498134aef79a6d96a13d88ca80811237e36bf
parenta4d6d80f5567ae6aefb720977c00bcf5410af504 (diff)
update to 1.17.1
EL use bundled libbson and libmongc 1.25.2
-rw-r--r--PHPINFO12
-rw-r--r--REFLECTION20
-rw-r--r--php-pecl-mongodb.spec13
3 files changed, 23 insertions, 22 deletions
diff --git a/PHPINFO b/PHPINFO
index e2b490d..a5c7ab4 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,19 +2,19 @@
mongodb
MongoDB support => enabled
-MongoDB extension version => 1.17.0
+MongoDB extension version => 1.17.1
MongoDB extension stability => stable
-libbson headers version => 1.25.1
-libbson library version => 1.25.1
-libmongoc headers version => 1.25.1
-libmongoc library version => 1.25.1
+libbson headers version => 1.25.2
+libbson library version => 1.25.2
+libmongoc headers version => 1.25.2
+libmongoc library version => 1.25.2
libmongoc SSL => enabled
libmongoc SSL library => OpenSSL
libmongoc crypto => enabled
libmongoc crypto library => libcrypto
libmongoc crypto system profile => enabled
libmongoc SASL => enabled
-libmongoc ICU => disabled
+libmongoc SRV => enabled
libmongoc compression => enabled
libmongoc compression snappy => enabled
libmongoc compression zlib => enabled
diff --git a/REFLECTION b/REFLECTION
index d7037fd..a0359ba 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #119 mongodb version 1.17.0 ] {
+Extension [ <persistent> extension #72 mongodb version 1.17.1 ] {
- Dependencies {
Dependency [ date (Required) ]
@@ -14,7 +14,7 @@ Extension [ <persistent> extension #119 mongodb version 1.17.0 ] {
}
- Constants [2] {
- Constant [ string MONGODB_VERSION ] { 1.17.0 }
+ Constant [ string MONGODB_VERSION ] { 1.17.1 }
Constant [ string MONGODB_STABILITY ] { stable }
}
@@ -564,7 +564,7 @@ Extension [ <persistent> extension #119 mongodb version 1.17.0 ] {
Method [ <internal:mongodb, prototype ArrayAccess> public method offsetExists ] {
- Parameters [1] {
- Parameter #0 [ <required> mixed $key ]
+ Parameter #0 [ <required> mixed $offset ]
}
- Return [ bool ]
}
@@ -572,7 +572,7 @@ Extension [ <persistent> extension #119 mongodb version 1.17.0 ] {
Method [ <internal:mongodb, prototype ArrayAccess> public method offsetGet ] {
- Parameters [1] {
- Parameter #0 [ <required> mixed $key ]
+ Parameter #0 [ <required> mixed $offset ]
}
- Return [ mixed ]
}
@@ -580,7 +580,7 @@ Extension [ <persistent> extension #119 mongodb version 1.17.0 ] {
Method [ <internal:mongodb, prototype ArrayAccess> public method offsetSet ] {
- Parameters [2] {
- Parameter #0 [ <required> mixed $key ]
+ Parameter #0 [ <required> mixed $offset ]
Parameter #1 [ <required> mixed $value ]
}
- Return [ void ]
@@ -589,7 +589,7 @@ Extension [ <persistent> extension #119 mongodb version 1.17.0 ] {
Method [ <internal:mongodb, prototype ArrayAccess> public method offsetUnset ] {
- Parameters [1] {
- Parameter #0 [ <required> mixed $key ]
+ Parameter #0 [ <required> mixed $offset ]
}
- Return [ void ]
}
@@ -733,7 +733,7 @@ Extension [ <persistent> extension #119 mongodb version 1.17.0 ] {
Method [ <internal:mongodb, prototype ArrayAccess> public method offsetExists ] {
- Parameters [1] {
- Parameter #0 [ <required> mixed $key ]
+ Parameter #0 [ <required> mixed $offset ]
}
- Return [ bool ]
}
@@ -741,7 +741,7 @@ Extension [ <persistent> extension #119 mongodb version 1.17.0 ] {
Method [ <internal:mongodb, prototype ArrayAccess> public method offsetGet ] {
- Parameters [1] {
- Parameter #0 [ <required> mixed $key ]
+ Parameter #0 [ <required> mixed $offset ]
}
- Return [ mixed ]
}
@@ -749,7 +749,7 @@ Extension [ <persistent> extension #119 mongodb version 1.17.0 ] {
Method [ <internal:mongodb, prototype ArrayAccess> public method offsetSet ] {
- Parameters [2] {
- Parameter #0 [ <required> mixed $key ]
+ Parameter #0 [ <required> mixed $offset ]
Parameter #1 [ <required> mixed $value ]
}
- Return [ void ]
@@ -758,7 +758,7 @@ Extension [ <persistent> extension #119 mongodb version 1.17.0 ] {
Method [ <internal:mongodb, prototype ArrayAccess> public method offsetUnset ] {
- Parameters [1] {
- Parameter #0 [ <required> mixed $key ]
+ Parameter #0 [ <required> mixed $offset ]
}
- Return [ void ]
}
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index 102ef8e..95b9cb1 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -7,9 +7,6 @@
# Please, preserve the changelog entries
#
-# we don't want -z defs linker flag
-%undefine _strict_symbol_defs_build
-
%if 0%{?scl:1}
%scl_package php-pecl-mongodb
%else
@@ -32,12 +29,12 @@
%endif
# Bundled versions
-%global bundled_libmongo 1.25.1
+%global bundled_libmongo 1.25.2
%global bundled_libcrypt 1.8.2
%if %{with syslib}
# Build dependencies
-%global system_libmongo 1.25.1
+%global system_libmongo 1.25.2
%global system_libcrypt 1.8.2
# Runtime dependencies
%global runtime_libmongo %(pkg-config --silence-errors --modversion libmongoc-1.0 2>/dev/null || echo %{system_libmongo})
@@ -46,7 +43,7 @@
Summary: MongoDB driver for PHP
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-%global upstream_version 1.17.0
+%global upstream_version 1.17.1
#global upstream_prever beta1
#global upstream_lower ~beta1
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
@@ -343,6 +340,10 @@ exit $ret
%changelog
+* Wed Dec 6 2023 Remi Collet <remi@remirepo.net> - 1.17.1-1
+- update to 1.17.1
+- EL use bundled libbson and libmongc 1.25.2
+
* Wed Nov 15 2023 Remi Collet <remi@remirepo.net> - 1.17.0-1
- update to 1.17.0
- raise dependency on PHP 7.4