summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-07-08 08:54:47 +0200
committerRemi Collet <remi@remirepo.net>2020-07-08 08:54:47 +0200
commitb6fb248334b8c8fbec7761f88c5fe9a7d5d6141f (patch)
tree091ee5fce048a28e99646d78ff7625a0738f3f59
parent77737dc4dcd7c5027356f5e960bc6d3783895ed3 (diff)
update to 1.8.0beta2
with libbson and libmongoc 1.18.0-beta2
-rw-r--r--PHPINFO7
-rw-r--r--REFLECTION12
-rw-r--r--php-pecl-mongodb.spec10
3 files changed, 20 insertions, 9 deletions
diff --git a/PHPINFO b/PHPINFO
index 9936ecb..2765e04 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
mongodb
MongoDB support => enabled
-MongoDB extension version => 1.8.0beta1
+MongoDB extension version => 1.8.0beta2
MongoDB extension stability => beta
libbson headers version => 1.17.0-pre
libbson library version => 1.17.0-pre
@@ -18,8 +18,9 @@ libmongoc ICU => enabled
libmongoc compression => enabled
libmongoc compression snappy => enabled
libmongoc compression zlib => enabled
-libmongocrypt headers version => 1.0.3
-libmongocrypt library version => 1.0.3
+libmongoc compression zstd => enabled
+libmongocrypt headers version => 1.0.4
+libmongocrypt library version => 1.0.4
libmongocrypt crypto => enabled
libmongocrypt crypto library => libcrypto
diff --git a/REFLECTION b/REFLECTION
index f5c70d2..7d2d8d0 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #109 mongodb version 1.8.0beta1 ] {
+Extension [ <persistent> extension #110 mongodb version 1.8.0beta2 ] {
- Dependencies {
Dependency [ date (Required) ]
@@ -14,7 +14,7 @@ Extension [ <persistent> extension #109 mongodb version 1.8.0beta1 ] {
}
- Constants [2] {
- Constant [ string MONGODB_VERSION ] { 1.8.0beta1 }
+ Constant [ string MONGODB_VERSION ] { 1.8.0beta2 }
Constant [ string MONGODB_STABILITY ] { beta }
}
@@ -1715,7 +1715,7 @@ Extension [ <persistent> extension #109 mongodb version 1.8.0beta1 ] {
- Properties [0] {
}
- - Methods [8] {
+ - Methods [9] {
Method [ <internal:mongodb, ctor> final public method __construct ] {
- Parameters [3] {
@@ -1725,6 +1725,12 @@ Extension [ <persistent> extension #109 mongodb version 1.8.0beta1 ] {
}
}
+ Method [ <internal:mongodb> final public method getHedge ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:mongodb> final public method getMaxStalenessSeconds ] {
- Parameters [0] {
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index b97f570..7c07ac5 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -39,15 +39,15 @@
%global libcryptver %(pkg-config --silence-errors --modversion libmongocrypt 2>/dev/null || echo %{libcrypt})
%else
%global with_syslib 0
-%global libmongo 1.17.0~beta
+%global libmongo 1.17.0~beta2
%global libcrypt 1.0.3
%endif
Summary: MongoDB driver for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
%global upstream_version 1.8.0
-%global upstream_prever beta1
-%global upstream_lower ~beta1
+%global upstream_prever beta2
+%global upstream_lower ~beta2
Version: %{upstream_version}%{?upstream_lower}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
@@ -342,6 +342,10 @@ exit $ret
%changelog
+* Thu Jun 11 2020 Remi Collet <remi@remirepo.net> - 1.8.0~beta2-1
+- update to 1.8.0beta2
+- with libbson and libmongoc 1.18.0-beta2
+
* Wed Apr 15 2020 Remi Collet <remi@remirepo.net> - 1.8.0~beta1-1
- update to 1.8.0beta1
- with libbson and libmongoc 1.18.0-beta