summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-09-07 19:00:07 +0200
committerRemi Collet <remi@remirepo.net>2017-09-07 19:00:07 +0200
commita20db44389445f0cc429955e6e624b971b5f6797 (patch)
tree6233b0c53f23fe11d04680e7c0cdfd0c71241990
parent1ba344800fb8ce4fcec8fe8434144eb4e23cf203 (diff)
v1.2.10
-rw-r--r--REFLECTION202
-rw-r--r--php-pecl-mongodb.spec18
2 files changed, 113 insertions, 107 deletions
diff --git a/REFLECTION b/REFLECTION
index aa9f834..e261cdb 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
+Extension [ <persistent> extension #84 mongodb version 1.2.10 ] {
- Dependencies {
Dependency [ date (Required) ]
@@ -14,7 +14,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
- Constants [2] {
- Constant [ string MONGODB_VERSION ] { 1.2.9 }
+ Constant [ string MONGODB_VERSION ] { 1.2.10 }
Constant [ string MONGODB_STABILITY ] { stable }
}
@@ -1460,7 +1460,7 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
}
}
- Class [ <internal:mongodb> class MongoDB\Driver\Exception\LogicException extends LogicException implements Throwable, MongoDB\Driver\Exception\Exception ] {
+ Class [ <internal:mongodb> class MongoDB\Driver\Exception\LogicException extends LogicException implements MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -1491,33 +1491,33 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception> final public method getCode ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception> final public method getFile ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception> final public method getLine ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception> final public method getTrace ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception> public method __toString ] {
}
}
}
- Class [ <internal:mongodb> class MongoDB\Driver\Exception\RuntimeException extends RuntimeException implements Throwable, MongoDB\Driver\Exception\Exception ] {
+ Class [ <internal:mongodb> class MongoDB\Driver\Exception\RuntimeException extends RuntimeException implements MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -1548,33 +1548,33 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception> final public method getCode ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception> final public method getFile ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception> final public method getLine ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception> final public method getTrace ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception> public method __toString ] {
}
}
}
- Class [ <internal:mongodb> class MongoDB\Driver\Exception\UnexpectedValueException extends UnexpectedValueException implements Throwable, MongoDB\Driver\Exception\Exception ] {
+ Class [ <internal:mongodb> class MongoDB\Driver\Exception\UnexpectedValueException extends UnexpectedValueException implements MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -1605,33 +1605,33 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception> final public method getCode ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception> final public method getFile ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception> final public method getLine ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception> final public method getTrace ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception> public method __toString ] {
}
}
}
- Class [ <internal:mongodb> class MongoDB\Driver\Exception\InvalidArgumentException extends InvalidArgumentException implements Throwable, MongoDB\Driver\Exception\Exception ] {
+ Class [ <internal:mongodb> class MongoDB\Driver\Exception\InvalidArgumentException extends InvalidArgumentException implements MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -1662,33 +1662,33 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception> final public method getCode ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception> final public method getFile ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception> final public method getLine ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception> final public method getTrace ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception> public method __toString ] {
}
}
}
- Class [ <internal:mongodb> class MongoDB\Driver\Exception\ConnectionException extends MongoDB\Driver\Exception\RuntimeException implements MongoDB\Driver\Exception\Exception, Throwable ] {
+ Class [ <internal:mongodb> class MongoDB\Driver\Exception\ConnectionException extends MongoDB\Driver\Exception\RuntimeException implements MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -1719,33 +1719,33 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception> final public method getCode ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception> final public method getFile ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception> final public method getLine ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception> final public method getTrace ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception> public method __toString ] {
}
}
}
- Class [ <internal:mongodb> class MongoDB\Driver\Exception\AuthenticationException extends MongoDB\Driver\Exception\ConnectionException implements Throwable, MongoDB\Driver\Exception\Exception ] {
+ Class [ <internal:mongodb> class MongoDB\Driver\Exception\AuthenticationException extends MongoDB\Driver\Exception\ConnectionException implements MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -1776,33 +1776,33 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception> final public method getCode ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception> final public method getFile ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception> final public method getLine ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception> final public method getTrace ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception> public method __toString ] {
}
}
}
- Class [ <internal:mongodb> final class MongoDB\Driver\Exception\SSLConnectionException extends MongoDB\Driver\Exception\ConnectionException implements Throwable, MongoDB\Driver\Exception\Exception ] {
+ Class [ <internal:mongodb> final class MongoDB\Driver\Exception\SSLConnectionException extends MongoDB\Driver\Exception\ConnectionException implements MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -1833,33 +1833,33 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception> final public method getCode ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception> final public method getFile ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception> final public method getLine ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception> final public method getTrace ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception> public method __toString ] {
}
}
}
- Class [ <internal:mongodb> abstract class MongoDB\Driver\Exception\WriteException extends MongoDB\Driver\Exception\RuntimeException implements MongoDB\Driver\Exception\Exception, Throwable ] {
+ Class [ <internal:mongodb> abstract class MongoDB\Driver\Exception\WriteException extends MongoDB\Driver\Exception\RuntimeException implements MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -1897,33 +1897,33 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception> final public method getCode ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception> final public method getFile ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception> final public method getLine ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception> final public method getTrace ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception> public method __toString ] {
}
}
}
- Class [ <internal:mongodb> class MongoDB\Driver\Exception\BulkWriteException extends MongoDB\Driver\Exception\WriteException implements Throwable, MongoDB\Driver\Exception\Exception ] {
+ Class [ <internal:mongodb> class MongoDB\Driver\Exception\BulkWriteException extends MongoDB\Driver\Exception\WriteException implements MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -1961,33 +1961,33 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception> final public method getCode ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception> final public method getFile ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception> final public method getLine ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception> final public method getTrace ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception> public method __toString ] {
}
}
}
- Class [ <internal:mongodb> final class MongoDB\Driver\Exception\ExecutionTimeoutException extends MongoDB\Driver\Exception\RuntimeException implements MongoDB\Driver\Exception\Exception, Throwable ] {
+ Class [ <internal:mongodb> final class MongoDB\Driver\Exception\ExecutionTimeoutException extends MongoDB\Driver\Exception\RuntimeException implements MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -2018,33 +2018,33 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception> final public method getCode ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception> final public method getFile ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception> final public method getLine ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception> final public method getTrace ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception> public method __toString ] {
}
}
}
- Class [ <internal:mongodb> final class MongoDB\Driver\Exception\ConnectionTimeoutException extends MongoDB\Driver\Exception\ConnectionException implements Throwable, MongoDB\Driver\Exception\Exception ] {
+ Class [ <internal:mongodb> final class MongoDB\Driver\Exception\ConnectionTimeoutException extends MongoDB\Driver\Exception\ConnectionException implements MongoDB\Driver\Exception\Exception ] {
- Constants [0] {
}
@@ -2075,28 +2075,28 @@ Extension [ <persistent> extension #170 mongodb version 1.2.9 ] {
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception> final public method getCode ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception> final public method getFile ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception> final public method getLine ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception> final public method getTrace ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception> public method __toString ] {
}
}
}
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index 2ff8a5d..843903a 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -32,6 +32,7 @@
%global with_tests 0%{?_with_tests:1}
%endif
+%global libver 1.5.5
%if 0%{?fedora} >= 26
%global with_syslib 1
%else
@@ -40,8 +41,8 @@
Summary: MongoDB driver for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.2.9
-Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.2.10
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -53,12 +54,14 @@ BuildRequires: %{?scl_prefix}php-json
BuildRequires: cyrus-sasl-devel
BuildRequires: openssl-devel
%if %{with_syslib}
-BuildRequires: pkgconfig(libbson-1.0) >= 1.6
-BuildRequires: pkgconfig(libmongoc-1.0) >= 1.6
+BuildRequires: pkgconfig(libbson-1.0) >= %{libver}
+BuildRequires: pkgconfig(libmongoc-1.0) >= %{libver}
%else
-Provides: bundled(libbson) = 1.6.1
-Provides: bundled(mongo-c-driver) = 1.6.1
+Provides: bundled(libbson) = %{libver}
+Provides: bundled(mongo-c-driver) = %{libver}
%endif
+BuildRequires: snappy-devel
+BuildRequires: zlib-devel
%if %{with_tests}
BuildRequires: mongodb-server
%endif
@@ -331,6 +334,9 @@ exit $ret
%changelog
+* Thu Sep 7 2017 Remi Collet <remi@remirepo.net> - 1.2.10-1
+- Update to 1.2.10
+
* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 1.2.9-4
- rebuild for PHP 7.2.0beta1 new API