summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-03-24 07:34:52 +0100
committerRemi Collet <remi@php.net>2022-03-24 07:34:52 +0100
commit8449199e5772072f7dafc6b7d2832e5a761ba1e2 (patch)
treeb11eca88686c9a24b6c5c598bd9dfb5df8623a56
parentdcfbca398032e9639e65996bcc718331aa8c7c6f (diff)
update to 1.13.0
with libbson and libmongoc 1.21.1 and libmongocrypt 1.3.2
-rw-r--r--PHPINFO14
-rw-r--r--REFLECTION660
-rw-r--r--php-pecl-mongodb.spec22
3 files changed, 675 insertions, 21 deletions
diff --git a/PHPINFO b/PHPINFO
index d302290..62508ff 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,12 +2,12 @@
mongodb
MongoDB support => enabled
-MongoDB extension version => 1.12.1
+MongoDB extension version => 1.13.0
MongoDB extension stability => stable
-libbson headers version => 1.21.0
-libbson library version => 1.21.0
-libmongoc headers version => 1.21.0
-libmongoc library version => 1.21.0
+libbson headers version => 1.21.1
+libbson library version => 1.21.1
+libmongoc headers version => 1.21.1
+libmongoc library version => 1.21.1
libmongoc SSL => enabled
libmongoc SSL library => OpenSSL
libmongoc crypto => enabled
@@ -19,8 +19,8 @@ libmongoc compression => enabled
libmongoc compression snappy => enabled
libmongoc compression zlib => enabled
libmongoc compression zstd => enabled
-libmongocrypt headers version => 1.3.0
-libmongocrypt library version => 1.3.0
+libmongocrypt headers version => 1.3.2
+libmongocrypt library version => 1.3.2
libmongocrypt crypto => enabled
libmongocrypt crypto library => libcrypto
diff --git a/REFLECTION b/REFLECTION
index 583d740..49c5e95 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #114 mongodb version 1.12.1 ] {
+Extension [ <persistent> extension #114 mongodb version 1.13.0 ] {
- Dependencies {
Dependency [ date (Required) ]
@@ -17,7 +17,7 @@ Extension [ <persistent> extension #114 mongodb version 1.12.1 ] {
}
- Constants [2] {
- Constant [ string MONGODB_VERSION ] { 1.12.1 }
+ Constant [ string MONGODB_VERSION ] { 1.13.0 }
Constant [ string MONGODB_STABILITY ] { stable }
}
@@ -73,7 +73,7 @@ Extension [ <persistent> extension #114 mongodb version 1.12.1 ] {
}
}
- - Classes [63] {
+ - Classes [75] {
Interface [ <internal:mongodb> interface MongoDB\BSON\Type ] {
- Constants [0] {
@@ -2077,7 +2077,7 @@ Extension [ <persistent> extension #114 mongodb version 1.12.1 ] {
- Properties [0] {
}
- - Methods [19] {
+ - Methods [20] {
Method [ <internal:mongodb> final public method executeCommand ] {
- Parameters [3] {
@@ -2162,6 +2162,12 @@ Extension [ <persistent> extension #114 mongodb version 1.12.1 ] {
}
}
+ Method [ <internal:mongodb> final public method getServerDescription ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:mongodb> final public method getType ] {
- Parameters [0] {
@@ -2277,6 +2283,129 @@ Extension [ <persistent> extension #114 mongodb version 1.12.1 ] {
}
}
+ Class [ <internal:mongodb> final class MongoDB\Driver\ServerDescription ] {
+
+ - Constants [10] {
+ Constant [ public string TYPE_UNKNOWN ] { Unknown }
+ Constant [ public string TYPE_STANDALONE ] { Standalone }
+ Constant [ public string TYPE_MONGOS ] { Mongos }
+ Constant [ public string TYPE_POSSIBLE_PRIMARY ] { PossiblePrimary }
+ Constant [ public string TYPE_RS_PRIMARY ] { RSPrimary }
+ Constant [ public string TYPE_RS_SECONDARY ] { RSSecondary }
+ Constant [ public string TYPE_RS_ARBITER ] { RSArbiter }
+ Constant [ public string TYPE_RS_OTHER ] { RSOther }
+ Constant [ public string TYPE_RS_GHOST ] { RSGhost }
+ Constant [ public string TYPE_LOAD_BALANCER ] { LoadBalancer }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [7] {
+ Method [ <internal:mongodb> final public method getHelloResponse ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getHost ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getLastUpdateTime ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getPort ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getRoundTripTime ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getType ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb, ctor> final private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mongodb> final class MongoDB\Driver\TopologyDescription ] {
+
+ - Constants [6] {
+ Constant [ public string TYPE_UNKNOWN ] { Unknown }
+ Constant [ public string TYPE_SINGLE ] { Single }
+ Constant [ public string TYPE_SHARDED ] { Sharded }
+ Constant [ public string TYPE_REPLICA_SET_NO_PRIMARY ] { ReplicaSetNoPrimary }
+ Constant [ public string TYPE_REPLICA_SET_WITH_PRIMARY ] { ReplicaSetWithPrimary }
+ Constant [ public string TYPE_LOAD_BALANCED ] { LoadBalanced }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [5] {
+ Method [ <internal:mongodb> final public method getServers ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method hasReadableServer ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> MongoDB\Driver\ReadPreference $readPreference = <default> ]
+ }
+ }
+
+ Method [ <internal:mongodb> final public method hasWritableServer ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getType ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb, ctor> final private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
Class [ <internal:mongodb> final class MongoDB\Driver\Session ] {
- Constants [5] {
@@ -2296,7 +2425,7 @@ Extension [ <persistent> extension #114 mongodb version 1.12.1 ] {
- Properties [0] {
}
- - Methods [15] {
+ - Methods [16] {
Method [ <internal:mongodb> final public method abortTransaction ] {
- Parameters [0] {
@@ -2365,6 +2494,12 @@ Extension [ <persistent> extension #114 mongodb version 1.12.1 ] {
}
}
+ Method [ <internal:mongodb> final public method isDirty ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:mongodb> final public method isInTransaction ] {
- Parameters [0] {
@@ -4399,6 +4534,521 @@ Extension [ <persistent> extension #114 mongodb version 1.12.1 ] {
}
}
}
+
+ Interface [ <internal:mongodb> interface MongoDB\Driver\Monitoring\SDAMSubscriber extends MongoDB\Driver\Monitoring\Subscriber ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [9] {
+ Method [ <internal:mongodb> abstract public method serverChanged ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> MongoDB\Driver\Monitoring\ServerChangedEvent $event ]
+ }
+ }
+
+ Method [ <internal:mongodb> abstract public method serverClosed ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> MongoDB\Driver\Monitoring\ServerClosedEvent $event ]
+ }
+ }
+
+ Method [ <internal:mongodb> abstract public method serverOpening ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> MongoDB\Driver\Monitoring\ServerOpeningEvent $event ]
+ }
+ }
+
+ Method [ <internal:mongodb> abstract public method serverHeartbeatFailed ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> MongoDB\Driver\Monitoring\ServerHeartbeatFailedEvent $event ]
+ }
+ }
+
+ Method [ <internal:mongodb> abstract public method serverHeartbeatStarted ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> MongoDB\Driver\Monitoring\ServerHeartbeatStartedEvent $event ]
+ }
+ }
+
+ Method [ <internal:mongodb> abstract public method serverHeartbeatSucceeded ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> MongoDB\Driver\Monitoring\ServerHeartbeatSucceededEvent $event ]
+ }
+ }
+
+ Method [ <internal:mongodb> abstract public method topologyChanged ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> MongoDB\Driver\Monitoring\TopologyChangedEvent $event ]
+ }
+ }
+
+ Method [ <internal:mongodb> abstract public method topologyClosed ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> MongoDB\Driver\Monitoring\TopologyClosedEvent $event ]
+ }
+ }
+
+ Method [ <internal:mongodb> abstract public method topologyOpening ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> MongoDB\Driver\Monitoring\TopologyOpeningEvent $event ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mongodb> final class MongoDB\Driver\Monitoring\ServerChangedEvent ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [7] {
+ Method [ <internal:mongodb, ctor> final private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getHost ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getPort ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getNewDescription ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getPreviousDescription ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getTopologyId ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method __wakeup ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mongodb> final class MongoDB\Driver\Monitoring\ServerClosedEvent ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [5] {
+ Method [ <internal:mongodb, ctor> final private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getHost ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getPort ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getTopologyId ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method __wakeup ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mongodb> final class MongoDB\Driver\Monitoring\ServerHeartbeatFailedEvent ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [7] {
+ Method [ <internal:mongodb, ctor> final private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getDurationMicros ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getError ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getHost ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getPort ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method isAwaited ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method __wakeup ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mongodb> final class MongoDB\Driver\Monitoring\ServerHeartbeatStartedEvent ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [5] {
+ Method [ <internal:mongodb, ctor> final private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getHost ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getPort ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method isAwaited ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method __wakeup ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mongodb> final class MongoDB\Driver\Monitoring\ServerHeartbeatSucceededEvent ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [7] {
+ Method [ <internal:mongodb, ctor> final private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getDurationMicros ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getHost ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getPort ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getReply ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method isAwaited ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method __wakeup ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mongodb> final class MongoDB\Driver\Monitoring\ServerOpeningEvent ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [5] {
+ Method [ <internal:mongodb, ctor> final private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getHost ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getPort ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getTopologyId ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method __wakeup ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mongodb> final class MongoDB\Driver\Monitoring\TopologyChangedEvent ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [5] {
+ Method [ <internal:mongodb, ctor> final private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getNewDescription ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getPreviousDescription ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getTopologyId ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method __wakeup ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mongodb> final class MongoDB\Driver\Monitoring\TopologyClosedEvent ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [3] {
+ Method [ <internal:mongodb, ctor> final private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getTopologyId ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method __wakeup ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mongodb> final class MongoDB\Driver\Monitoring\TopologyOpeningEvent ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [3] {
+ Method [ <internal:mongodb, ctor> final private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method getTopologyId ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method __wakeup ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
}
}
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index e3ca50d..caf3540 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-mongodb
#
-# Copyright (c) 2015-2021 Remi Collet
+# Copyright (c) 2015-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -34,20 +34,20 @@
%if %{with syslib}
# Build dependency
-%global libmongo 1.20.0
-%global libcrypt 1.3.0
+%global libmongo 1.21
+%global libcrypt 1.3
# Runtime dependency
%global libmongover %(pkg-config --silence-errors --modversion libmongoc-1.0 2>/dev/null || echo %{libmongo})
%global libcryptver %(pkg-config --silence-errors --modversion libmongocrypt 2>/dev/null || echo %{libcrypt})
%else
# Bundled versions
-%global libmongo 1.20.1
-%global libcrypt 1.3.0
+%global libmongo 1.21.1
+%global libcrypt 1.3.2
%endif
Summary: MongoDB driver for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-%global upstream_version 1.12.1
+%global upstream_version 1.13.0
#global upstream_prever alpha1
#global upstream_lower ~alpha1
Version: %{upstream_version}%{?upstream_lower}
@@ -140,13 +140,13 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%if 0%{?rhel} == 8
+%if %{with syslib}
# temporary: lower minimal required version
-sed -e 's/1.20.1/1.20.0/;s/1.3.0/1.3.0/' -i config.m4
+sed -e 's/1.21.1/%{libmongo}/;s/1.3.2/%{libcrypt}/' -i config.m4
%endif
# Sanity check, really often broken
-extver=$(sed -n '/#define PHP_MONGODB_VERSION /{s/.* "//;s/".*$//;p}' phongo_version.h)
+extver=$(sed -n '/#define PHP_MONGODB_VERSION /{s/.* "//;s/".*$//;p}' src/phongo_version.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
: Error: Upstream extension version is ${extver}, expecting %{upstream_version}%{?upstream_prever}.
exit 1
@@ -329,6 +329,10 @@ exit $ret
%changelog
+* Thu Mar 24 2022 Remi Collet <remi@remirepo.net> - 1.13.0-1
+- update to 1.13.0
+- with libbson and libmongoc 1.21.1 and libmongocrypt 1.3.2
+
* Wed Feb 23 2022 Remi Collet <remi@remirepo.net> - 1.12.1-1
- update to 1.12.1 (no change)
- with libbson and libmongoc 1.20.1