summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-11-11 08:02:42 +0100
committerRemi Collet <remi@remirepo.net>2020-11-11 08:02:42 +0100
commit3bc9a48545bfaa6fccf4ce7914e87708b8cf7745 (patch)
treef94b54ab7c4f8172afd359112c0217f4e3cf3bd7
parentac35bf9e4a1d04b4fec70ea2c13fbe898fbccfb3 (diff)
update to 1.9.0RC1 (beta)
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION45
-rw-r--r--php-pecl-mongodb.spec15
3 files changed, 52 insertions, 12 deletions
diff --git a/PHPINFO b/PHPINFO
index 7b6a222..b2c161f 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,8 +2,8 @@
mongodb
MongoDB support => enabled
-MongoDB extension version => 1.8.2
-MongoDB extension stability => stable
+MongoDB extension version => 1.9.0RC1
+MongoDB extension stability => beta
libbson headers version => 1.17.2
libbson library version => 1.17.2
libmongoc headers version => 1.17.2
diff --git a/REFLECTION b/REFLECTION
index 2c1042b..65bfdd2 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #113 mongodb version 1.8.2 ] {
+Extension [ <persistent> extension #113 mongodb version 1.9.0RC1 ] {
- Dependencies {
Dependency [ date (Required) ]
@@ -14,8 +14,8 @@ Extension [ <persistent> extension #113 mongodb version 1.8.2 ] {
}
- Constants [2] {
- Constant [ string MONGODB_VERSION ] { 1.8.2 }
- Constant [ string MONGODB_STABILITY ] { stable }
+ Constant [ string MONGODB_VERSION ] { 1.9.0RC1 }
+ Constant [ string MONGODB_STABILITY ] { beta }
}
- Functions {
@@ -888,7 +888,7 @@ Extension [ <persistent> extension #113 mongodb version 1.8.2 ] {
- Parameters [2] {
Parameter #0 [ <required> $pattern ]
- Parameter #1 [ <required> $flags ]
+ Parameter #1 [ <optional> $flags ]
}
}
@@ -1335,8 +1335,9 @@ Extension [ <persistent> extension #113 mongodb version 1.8.2 ] {
- Methods [2] {
Method [ <internal:mongodb, ctor> final public method __construct ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $document ]
+ Parameter #1 [ <optional> array or NULL $options ]
}
}
@@ -1348,7 +1349,7 @@ Extension [ <persistent> extension #113 mongodb version 1.8.2 ] {
}
}
- Class [ <internal:mongodb> <iterateable> final class MongoDB\Driver\Cursor implements MongoDB\Driver\CursorInterface, Traversable ] {
+ Class [ <internal:mongodb> <iterateable> final class MongoDB\Driver\Cursor implements Iterator, Traversable, MongoDB\Driver\CursorInterface ] {
- Constants [0] {
}
@@ -1362,7 +1363,7 @@ Extension [ <persistent> extension #113 mongodb version 1.8.2 ] {
- Properties [0] {
}
- - Methods [7] {
+ - Methods [12] {
Method [ <internal:mongodb, prototype MongoDB\Driver\CursorInterface> final public method setTypeMap ] {
- Parameters [1] {
@@ -1394,6 +1395,36 @@ Extension [ <persistent> extension #113 mongodb version 1.8.2 ] {
}
}
+ Method [ <internal:mongodb, prototype Iterator> public method current ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb, prototype Iterator> public method key ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb, prototype Iterator> public method next ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb, prototype Iterator> public method valid ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb, prototype Iterator> public method rewind ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index bacc5fc..ad2ac50 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -41,9 +41,9 @@
Summary: MongoDB driver for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-%global upstream_version 1.8.2
-#global upstream_prever RC1
-#global upstream_lower ~rc1
+%global upstream_version 1.9.0
+%global upstream_prever RC1
+%global upstream_lower ~rc1
Version: %{upstream_version}%{?upstream_lower}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
@@ -54,6 +54,9 @@ BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel > 7.0
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
+%if 0%{?rhel} == 6
+BuildRequires: autoconf268
+%endif
%if %{with_syslib}
BuildRequires: pkgconfig(libbson-1.0) >= %{libmongo}
BuildRequires: pkgconfig(libmongoc-1.0) >= %{libmongo}
@@ -173,6 +176,9 @@ EOF
%build
+%if 0%{?rhel} == 6
+export PHP_AUTOCONF=autoconf268;export PHP_AUTOHEADER=autoheader268
+%endif
%{?dtsenable}
peclbuild() {
@@ -340,6 +346,9 @@ exit $ret
%changelog
+* Wed Nov 11 2020 Remi Collet <remi@remirepo.net> - 1.9.0~RC1-1
+- update to 1.9.0RC1 (beta)
+
* Thu Nov 5 2020 Remi Collet <remi@remirepo.net> - 1.8.2-1
- update to 1.8.2 (no change)
- with libbson and libmongoc 1.17.2