summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-12-03 16:07:36 +0100
committerRemi Collet <remi@remirepo.net>2018-12-03 16:07:36 +0100
commit3b566427234628d6c02a16b7794cbff5f2db43fb (patch)
treeb3d38d9a026933d0d86c7f799ff9f3add352c41c
parent290429a8fff0d85652e79306379957bc2d27635b (diff)
v1.6.0alpha1
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION240
-rw-r--r--php-pecl-mongodb.spec11
3 files changed, 205 insertions, 50 deletions
diff --git a/PHPINFO b/PHPINFO
index f220cde..3435773 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,8 +2,8 @@
mongodb
MongoDB support => enabled
-MongoDB extension version => 1.5.3
-MongoDB extension stability => stable
+MongoDB extension version => 1.6.0alpha1
+MongoDB extension stability => alpha
libbson headers version => 1.13.0
libbson library version => 1.13.0
libmongoc headers version => 1.13.0
diff --git a/REFLECTION b/REFLECTION
index 32cc2f5..a54808f 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #190 mongodb version 1.5.3 ] {
+Extension [ <persistent> extension #191 mongodb version 1.6.0alpha1 ] {
- Dependencies {
Dependency [ date (Required) ]
@@ -14,8 +14,8 @@ Extension [ <persistent> extension #190 mongodb version 1.5.3 ] {
}
- Constants [2] {
- Constant [ string MONGODB_VERSION ] { 1.5.3 }
- Constant [ string MONGODB_STABILITY ] { stable }
+ Constant [ string MONGODB_VERSION ] { 1.6.0alpha1 }
+ Constant [ string MONGODB_STABILITY ] { alpha }
}
- Functions {
@@ -70,7 +70,7 @@ Extension [ <persistent> extension #190 mongodb version 1.5.3 ] {
}
}
- - Classes [59] {
+ - Classes [60] {
Interface [ <internal:mongodb> interface MongoDB\BSON\Type ] {
- Constants [0] {
@@ -1155,6 +1155,54 @@ Extension [ <persistent> extension #190 mongodb version 1.5.3 ] {
}
}
+ Interface [ <internal:mongodb> interface MongoDB\Driver\CursorInterface extends Traversable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [5] {
+ Method [ <internal:mongodb> abstract public method getId ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> abstract public method getServer ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> abstract public method isDead ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> abstract public method setTypeMap ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $typemap ]
+ }
+ }
+
+ Method [ <internal:mongodb> abstract public method toArray ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
Class [ <internal:mongodb> final class MongoDB\Driver\BulkWrite implements Countable ] {
- Constants [0] {
@@ -1245,7 +1293,7 @@ Extension [ <persistent> extension #190 mongodb version 1.5.3 ] {
}
}
- Class [ <internal:mongodb> <iterateable> final class MongoDB\Driver\Cursor implements Traversable ] {
+ Class [ <internal:mongodb> <iterateable> final class MongoDB\Driver\Cursor implements MongoDB\Driver\CursorInterface, Traversable ] {
- Constants [0] {
}
@@ -1260,32 +1308,32 @@ Extension [ <persistent> extension #190 mongodb version 1.5.3 ] {
}
- Methods [7] {
- Method [ <internal:mongodb> final public method setTypeMap ] {
+ Method [ <internal:mongodb, prototype MongoDB\Driver\CursorInterface> final public method setTypeMap ] {
- Parameters [1] {
Parameter #0 [ <required> array $typemap ]
}
}
- Method [ <internal:mongodb> final public method toArray ] {
+ Method [ <internal:mongodb, prototype MongoDB\Driver\CursorInterface> final public method toArray ] {
- Parameters [0] {
}
}
- Method [ <internal:mongodb> final public method getId ] {
+ Method [ <internal:mongodb, prototype MongoDB\Driver\CursorInterface> final public method getId ] {
- Parameters [0] {
}
}
- Method [ <internal:mongodb> final public method getServer ] {
+ Method [ <internal:mongodb, prototype MongoDB\Driver\CursorInterface> final public method getServer ] {
- Parameters [0] {
}
}
- Method [ <internal:mongodb> final public method isDead ] {
+ Method [ <internal:mongodb, prototype MongoDB\Driver\CursorInterface> final public method isDead ] {
- Parameters [0] {
}
@@ -1507,7 +1555,13 @@ Extension [ <persistent> extension #190 mongodb version 1.5.3 ] {
- Static properties [0] {
}
- - Static methods [0] {
+ - Static methods [1] {
+ Method [ <internal:mongodb> static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $properties ]
+ }
+ }
}
- Properties [0] {
@@ -1556,7 +1610,13 @@ Extension [ <persistent> extension #190 mongodb version 1.5.3 ] {
- Static properties [0] {
}
- - Static methods [0] {
+ - Static methods [1] {
+ Method [ <internal:mongodb> static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $properties ]
+ }
+ }
}
- Properties [0] {
@@ -1770,7 +1830,13 @@ Extension [ <persistent> extension #190 mongodb version 1.5.3 ] {
- Properties [0] {
}
- - Methods [11] {
+ - Methods [12] {
+ Method [ <internal:mongodb> final public method abortTransaction ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:mongodb> final public method advanceClusterTime ] {
- Parameters [1] {
@@ -1785,46 +1851,46 @@ Extension [ <persistent> extension #190 mongodb version 1.5.3 ] {
}
}
- Method [ <internal:mongodb> final public method getClusterTime ] {
+ Method [ <internal:mongodb> final public method commitTransaction ] {
- Parameters [0] {
}
}
- Method [ <internal:mongodb> final public method getLogicalSessionId ] {
+ Method [ <internal:mongodb> final public method endSession ] {
- Parameters [0] {
}
}
- Method [ <internal:mongodb> final public method getOperationTime ] {
+ Method [ <internal:mongodb> final public method getClusterTime ] {
- Parameters [0] {
}
}
- Method [ <internal:mongodb> final public method startTransaction ] {
+ Method [ <internal:mongodb> final public method getLogicalSessionId ] {
- - Parameters [1] {
- Parameter #0 [ <optional> $options ]
+ - Parameters [0] {
}
}
- Method [ <internal:mongodb> final public method commitTransaction ] {
+ Method [ <internal:mongodb> final public method getOperationTime ] {
- Parameters [0] {
}
}
- Method [ <internal:mongodb> final public method abortTransaction ] {
+ Method [ <internal:mongodb> final public method isInTransaction ] {
- Parameters [0] {
}
}
- Method [ <internal:mongodb> final public method endSession ] {
+ Method [ <internal:mongodb> final public method startTransaction ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $options ]
}
}
@@ -1851,7 +1917,13 @@ Extension [ <persistent> extension #190 mongodb version 1.5.3 ] {
- Static properties [0] {
}
- - Static methods [0] {
+ - Static methods [1] {
+ Method [ <internal:mongodb> static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $properties ]
+ }
+ }
}
- Properties [0] {
@@ -2117,14 +2189,22 @@ Extension [ <persistent> extension #190 mongodb version 1.5.3 ] {
- Static methods [0] {
}
- - Properties [4] {
+ - Properties [5] {
Property [ <default> protected $message ]
Property [ <default> protected $code ]
Property [ <default> protected $file ]
Property [ <default> protected $line ]
+ Property [ <default> protected $errorLabels ]
}
- - Methods [10] {
+ - Methods [11] {
+ Method [ <internal:mongodb> final public method hasErrorLabel ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $label ]
+ }
+ }
+
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
@@ -2174,14 +2254,22 @@ Extension [ <persistent> extension #190 mongodb version 1.5.3 ] {
- Static methods [0] {
}
- - Properties [4] {
+ - Properties [5] {
Property [ <default> protected $message ]
Property [ <default> protected $code ]
Property [ <default> protected $file ]
Property [ <default> protected $line ]
+ Property [ <default> protected $errorLabels ]
}
- - Methods [10] {
+ - Methods [11] {
+ Method [ <internal:mongodb, inherits MongoDB\Driver\Exception\RuntimeException> final public method hasErrorLabel ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $label ]
+ }
+ }
+
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
@@ -2231,14 +2319,22 @@ Extension [ <persistent> extension #190 mongodb version 1.5.3 ] {
- Static methods [0] {
}
- - Properties [4] {
+ - Properties [5] {
Property [ <default> protected $message ]
Property [ <default> protected $code ]
Property [ <default> protected $file ]
Property [ <default> protected $line ]
+ Property [ <default> protected $errorLabels ]
}
- - Methods [10] {
+ - Methods [11] {
+ Method [ <internal:mongodb, inherits MongoDB\Driver\Exception\RuntimeException> final public method hasErrorLabel ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $label ]
+ }
+ }
+
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
@@ -2288,21 +2384,29 @@ Extension [ <persistent> extension #190 mongodb version 1.5.3 ] {
- Static methods [0] {
}
- - Properties [5] {
+ - Properties [6] {
Property [ <default> protected $message ]
Property [ <default> protected $code ]
Property [ <default> protected $file ]
Property [ <default> protected $line ]
+ Property [ <default> protected $errorLabels ]
Property [ <default> protected $writeResult ]
}
- - Methods [11] {
+ - Methods [12] {
Method [ <internal:mongodb> final public method getWriteResult ] {
- Parameters [0] {
}
}
+ Method [ <internal:mongodb, inherits MongoDB\Driver\Exception\RuntimeException> final public method hasErrorLabel ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $label ]
+ }
+ }
+
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
@@ -2352,14 +2456,22 @@ Extension [ <persistent> extension #190 mongodb version 1.5.3 ] {
- Static methods [0] {
}
- - Properties [4] {
+ - Properties [5] {
Property [ <default> protected $message ]
Property [ <default> protected $code ]
Property [ <default> protected $file ]
Property [ <default> protected $line ]
+ Property [ <default> protected $errorLabels ]
}
- - Methods [10] {
+ - Methods [11] {
+ Method [ <internal:mongodb, inherits MongoDB\Driver\Exception\RuntimeException> final public method hasErrorLabel ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $label ]
+ }
+ }
+
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
@@ -2409,21 +2521,29 @@ Extension [ <persistent> extension #190 mongodb version 1.5.3 ] {
- Static methods [0] {
}
- - Properties [5] {
+ - Properties [6] {
Property [ <default> protected $message ]
Property [ <default> protected $code ]
Property [ <default> protected $file ]
Property [ <default> protected $line ]
+ Property [ <default> protected $errorLabels ]
Property [ <default> protected $writeResult ]
}
- - Methods [11] {
+ - Methods [12] {
Method [ <internal:mongodb, inherits MongoDB\Driver\Exception\WriteException> final public method getWriteResult ] {
- Parameters [0] {
}
}
+ Method [ <internal:mongodb, inherits MongoDB\Driver\Exception\RuntimeException> final public method hasErrorLabel ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $label ]
+ }
+ }
+
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
@@ -2473,21 +2593,29 @@ Extension [ <persistent> extension #190 mongodb version 1.5.3 ] {
- Static methods [0] {
}
- - Properties [5] {
+ - Properties [6] {
Property [ <default> protected $message ]
Property [ <default> protected $code ]
Property [ <default> protected $file ]
Property [ <default> protected $line ]
+ Property [ <default> protected $errorLabels ]
Property [ <default> protected $resultDocument ]
}
- - Methods [11] {
+ - Methods [12] {
Method [ <internal:mongodb> final public method getResultDocument ] {
- Parameters [0] {
}
}
+ Method [ <internal:mongodb, inherits MongoDB\Driver\Exception\RuntimeException> final public method hasErrorLabel ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $label ]
+ }
+ }
+
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
@@ -2537,14 +2665,22 @@ Extension [ <persistent> extension #190 mongodb version 1.5.3 ] {
- Static methods [0] {
}
- - Properties [4] {
+ - Properties [5] {
Property [ <default> protected $message ]
Property [ <default> protected $code ]
Property [ <default> protected $file ]
Property [ <default> protected $line ]
+ Property [ <default> protected $errorLabels ]
}
- - Methods [10] {
+ - Methods [11] {
+ Method [ <internal:mongodb, inherits MongoDB\Driver\Exception\RuntimeException> final public method hasErrorLabel ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $label ]
+ }
+ }
+
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
@@ -2594,14 +2730,22 @@ Extension [ <persistent> extension #190 mongodb version 1.5.3 ] {
- Static methods [0] {
}
- - Properties [4] {
+ - Properties [5] {
Property [ <default> protected $message ]
Property [ <default> protected $code ]
Property [ <default> protected $file ]
Property [ <default> protected $line ]
+ Property [ <default> protected $errorLabels ]
}
- - Methods [10] {
+ - Methods [11] {
+ Method [ <internal:mongodb, inherits MongoDB\Driver\Exception\RuntimeException> final public method hasErrorLabel ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $label ]
+ }
+ }
+
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
@@ -2765,14 +2909,22 @@ Extension [ <persistent> extension #190 mongodb version 1.5.3 ] {
- Static methods [0] {
}
- - Properties [4] {
+ - Properties [5] {
Property [ <default> protected $message ]
Property [ <default> protected $code ]
Property [ <default> protected $file ]
Property [ <default> protected $line ]
+ Property [ <default> protected $errorLabels ]
}
- - Methods [10] {
+ - Methods [11] {
+ Method [ <internal:mongodb, inherits MongoDB\Driver\Exception\RuntimeException> final public method hasErrorLabel ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $label ]
+ }
+ }
+
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index 7da03b2..cc128c6 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -46,11 +46,11 @@
Summary: MongoDB driver for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-%global upstream_version 1.5.3
-#global upstream_prever RC2
-#global upstream_lower ~rc2
+%global upstream_version 1.6.0
+%global upstream_prever alpha1
+%global upstream_lower ~alpha1
Version: %{upstream_version}%{?upstream_lower}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
@@ -328,6 +328,9 @@ exit $ret
%changelog
+* Mon Dec 3 2018 Remi Collet <remi@remirepo.net> - 1.6.0~alpha1-1
+- update to 1.6.0alpha1
+
* Sat Dec 1 2018 Remi Collet <remi@remirepo.net> - 1.5.3-2
- EL-8 build (using bundled libmongc for now)