summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-02-05 07:03:52 +0100
committerRemi Collet <remi@remirepo.net>2020-02-05 07:03:52 +0100
commit06a6b6baec1dbbd557d4b423dbc2af1e9ec38991 (patch)
tree0eea240758a7eadee4cf83468a9a1910a88f70be
parent501053e2de2a1f7a1ba87cd899a978a7316b3e48 (diff)
update to 1.7.1 (no change)
drop patch merged upstream
-rw-r--r--1095.patch44
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION4
-rw-r--r--php-pecl-mongodb.spec10
4 files changed, 8 insertions, 52 deletions
diff --git a/1095.patch b/1095.patch
deleted file mode 100644
index 2f82487..0000000
--- a/1095.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-From 71a86ccd0c6338a18aced544cd798593d7ad93ea Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Tue, 4 Feb 2020 16:47:47 +0100
-Subject: [PATCH] Fix build with system libraries
-
----
- config.m4 | 10 +++++-----
- php_phongo.c | 2 +-
- 2 files changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/config.m4 b/config.m4
-index 39e0627b..e00ceb44 100644
---- a/config.m4
-+++ b/config.m4
-@@ -257,11 +257,11 @@ if test "$PHP_MONGODB" != "no"; then
- AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
- AC_MSG_CHECKING(for libmongocrypt)
-
-- if test -x "$PKG_CONFIG" && $PKG_CONFIG --exists libmongocrypt-1.0; then
-- if $PKG_CONFIG libmongocrypt-1.0 --atleast-version 1.0.1; then
-- PHP_MONGODB_MONGOCRYPT_CFLAGS=`$PKG_CONFIG libmongocrypt-1.0 --cflags`
-- PHP_MONGODB_MONGOCRYPT_LIBS=`$PKG_CONFIG libmongocrypt-1.0 --libs`
-- PHP_MONGODB_MONGOCRYPT_VERSION=`$PKG_CONFIG libmongocrypt-1.0 --modversion`
-+ if test -x "$PKG_CONFIG" && $PKG_CONFIG --exists libmongocrypt; then
-+ if $PKG_CONFIG libmongocrypt --atleast-version 1.0.1; then
-+ PHP_MONGODB_MONGOCRYPT_CFLAGS=`$PKG_CONFIG libmongocrypt --cflags`
-+ PHP_MONGODB_MONGOCRYPT_LIBS=`$PKG_CONFIG libmongocrypt --libs`
-+ PHP_MONGODB_MONGOCRYPT_VERSION=`$PKG_CONFIG libmongocrypt --modversion`
- AC_MSG_RESULT(version $PHP_MONGODB_MONGOCRYPT_VERSION found)
-
- PHP_MONGODB_CFLAGS="$PHP_MONGODB_CFLAGS $PHP_MONGODB_MONGOCRYPT_CFLAGS"
-diff --git a/php_phongo.c b/php_phongo.c
-index ef3600b8..83f5dfd4 100644
---- a/php_phongo.c
-+++ b/php_phongo.c
-@@ -3924,7 +3924,7 @@ PHP_MINFO_FUNCTION(mongodb)
- #ifdef MONGOC_ENABLE_CLIENT_SIDE_ENCRYPTION
- #ifdef HAVE_SYSTEM_LIBMONGOCRYPT
- php_info_print_table_row(2, "libmongocrypt headers version", MONGOCRYPT_VERSION);
-- php_info_print_table_row(2, "libmongocrypt library version", mongocrypt_version());
-+ php_info_print_table_row(2, "libmongocrypt library version", mongocrypt_version(NULL));
- #else
- php_info_print_table_row(2, "libmongocrypt bundled version", MONGOCRYPT_VERSION);
- #endif
diff --git a/PHPINFO b/PHPINFO
index d6106b3..596f09d 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
mongodb
MongoDB support => enabled
-MongoDB extension version => 1.7.0
+MongoDB extension version => 1.7.1
MongoDB extension stability => stable
libbson headers version => 1.16.1
libbson library version => 1.16.1
diff --git a/REFLECTION b/REFLECTION
index ab42c66..b836fd8 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #106 mongodb version 1.7.0 ] {
+Extension [ <persistent> extension #106 mongodb version 1.7.1 ] {
- Dependencies {
Dependency [ date (Required) ]
@@ -14,7 +14,7 @@ Extension [ <persistent> extension #106 mongodb version 1.7.0 ] {
}
- Constants [2] {
- Constant [ string MONGODB_VERSION ] { 1.7.0 }
+ Constant [ string MONGODB_VERSION ] { 1.7.1 }
Constant [ string MONGODB_STABILITY ] { stable }
}
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index caddfeb..6781006 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -44,7 +44,7 @@
Summary: MongoDB driver for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-%global upstream_version 1.7.0
+%global upstream_version 1.7.1
#global upstream_prever RC1
#global upstream_lower ~rc1
Version: %{upstream_version}%{?upstream_lower}
@@ -53,8 +53,6 @@ License: ASL 2.0
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
-Patch0: https://patch-diff.githubusercontent.com/raw/mongodb/mongo-php-driver/pull/1095.patch
-
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel > 5.6
BuildRequires: %{?scl_prefix}php-pear
@@ -147,8 +145,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1 -b .pr1095
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_MONGODB_VERSION /{s/.* "//;s/".*$//;p}' phongo_version.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -340,6 +336,10 @@ exit $ret
%changelog
+* Wed Feb 5 2020 Remi Collet <remi@remirepo.net> - 1.7.1-1
+- update to 1.7.1 (no change)
+- drop patch merged upstream
+
* Tue Feb 4 2020 Remi Collet <remi@remirepo.net> - 1.7.0-1
- update to 1.7.0
- with libbson and libmongoc 1.16.1