summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION56
-rw-r--r--php-pecl-mongo.spec7
2 files changed, 48 insertions, 15 deletions
diff --git a/REFLECTION b/REFLECTION
index facecc4..223723a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #186 mongo version 1.6.10 ] {
+Extension [ <persistent> extension #190 mongo version 1.6.11 ] {
- Dependencies {
Dependency [ openssl (Optional) ]
@@ -77,7 +77,7 @@ Extension [ <persistent> extension #186 mongo version 1.6.10 ] {
- Constants [8] {
Constant [ string DEFAULT_HOST ] { localhost }
Constant [ integer DEFAULT_PORT ] { 27017 }
- Constant [ string VERSION ] { 1.6.10 }
+ Constant [ string VERSION ] { 1.6.11 }
Constant [ string RP_PRIMARY ] { primary }
Constant [ string RP_PRIMARY_PREFERRED ] { primaryPreferred }
Constant [ string RP_SECONDARY ] { secondary }
@@ -213,7 +213,7 @@ Extension [ <persistent> extension #186 mongo version 1.6.10 ] {
- Constants [8] {
Constant [ string DEFAULT_HOST ] { localhost }
Constant [ integer DEFAULT_PORT ] { 27017 }
- Constant [ string VERSION ] { 1.6.10 }
+ Constant [ string VERSION ] { 1.6.11 }
Constant [ string RP_PRIMARY ] { primary }
Constant [ string RP_PRIMARY_PREFERRED ] { primaryPreferred }
Constant [ string RP_SECONDARY ] { secondary }
@@ -2286,7 +2286,7 @@ Extension [ <persistent> extension #186 mongo version 1.6.10 ] {
Property [ <default> protected $line ]
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> <visibility error> method __construct ] {
- Parameters [3] {
@@ -2296,6 +2296,9 @@ Extension [ <persistent> extension #186 mongo version 1.6.10 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -2340,7 +2343,7 @@ Extension [ <persistent> extension #186 mongo version 1.6.10 ] {
Property [ <default> protected $line ]
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> <visibility error> method __construct ] {
- Parameters [3] {
@@ -2350,6 +2353,9 @@ Extension [ <persistent> extension #186 mongo version 1.6.10 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -2395,7 +2401,7 @@ Extension [ <persistent> extension #186 mongo version 1.6.10 ] {
Property [ <default> private $host ]
}
- - Methods [10] {
+ - Methods [11] {
Method [ <internal:mongo> public method getHost ] {
- Parameters [0] {
@@ -2411,6 +2417,9 @@ Extension [ <persistent> extension #186 mongo version 1.6.10 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -2455,7 +2464,7 @@ Extension [ <persistent> extension #186 mongo version 1.6.10 ] {
Property [ <default> protected $line ]
}
- - Methods [10] {
+ - Methods [11] {
Method [ <internal:mongo, inherits MongoCursorException> public method getHost ] {
- Parameters [0] {
@@ -2471,6 +2480,9 @@ Extension [ <persistent> extension #186 mongo version 1.6.10 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -2515,7 +2527,7 @@ Extension [ <persistent> extension #186 mongo version 1.6.10 ] {
Property [ <default> protected $line ]
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> <visibility error> method __construct ] {
- Parameters [3] {
@@ -2525,6 +2537,9 @@ Extension [ <persistent> extension #186 mongo version 1.6.10 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -2571,7 +2586,7 @@ Extension [ <persistent> extension #186 mongo version 1.6.10 ] {
Property [ <default> private $host ]
}
- - Methods [11] {
+ - Methods [12] {
Method [ <internal:mongo> public method getDocument ] {
- Parameters [0] {
@@ -2593,6 +2608,9 @@ Extension [ <persistent> extension #186 mongo version 1.6.10 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -2638,7 +2656,7 @@ Extension [ <persistent> extension #186 mongo version 1.6.10 ] {
Property [ <default> private $document ]
}
- - Methods [11] {
+ - Methods [12] {
Method [ <internal:mongo> public method getDocument ] {
- Parameters [0] {
@@ -2660,6 +2678,9 @@ Extension [ <persistent> extension #186 mongo version 1.6.10 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -2704,7 +2725,7 @@ Extension [ <persistent> extension #186 mongo version 1.6.10 ] {
Property [ <default> protected $line ]
}
- - Methods [11] {
+ - Methods [12] {
Method [ <internal:mongo, inherits MongoWriteConcernException> public method getDocument ] {
- Parameters [0] {
@@ -2726,6 +2747,9 @@ Extension [ <persistent> extension #186 mongo version 1.6.10 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -2770,7 +2794,7 @@ Extension [ <persistent> extension #186 mongo version 1.6.10 ] {
Property [ <default> protected $line ]
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> <visibility error> method __construct ] {
- Parameters [3] {
@@ -2780,6 +2804,9 @@ Extension [ <persistent> extension #186 mongo version 1.6.10 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -2824,7 +2851,7 @@ Extension [ <persistent> extension #186 mongo version 1.6.10 ] {
Property [ <default> protected $line ]
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> <visibility error> method __construct ] {
- Parameters [3] {
@@ -2834,6 +2861,9 @@ Extension [ <persistent> extension #186 mongo version 1.6.10 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
diff --git a/php-pecl-mongo.spec b/php-pecl-mongo.spec
index 8f62304..5738c3f 100644
--- a/php-pecl-mongo.spec
+++ b/php-pecl-mongo.spec
@@ -20,7 +20,7 @@
%global with_zts 0%{?__ztsphp:1}
#global prever RC3
# see https://github.com/mongodb/mongo-php-driver/releases
-%global gh_commit bbc5be0cdfe06a4cded8e209badf9dbd8696a58d
+%global gh_commit e9a467683d83580281edeab3f6ddc09771a3cda0
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner mongodb
%global gh_project mongo-php-driver
@@ -35,7 +35,7 @@
Summary: PHP MongoDB database driver
Name: %{?scl_prefix}php-pecl-mongo
-Version: 1.6.10
+Version: 1.6.11
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: ASL 2.0
Group: Development/Languages
@@ -246,6 +246,9 @@ rm -rf data
%changelog
+* Tue Aug 25 2015 Remi Collet <remi@fedoraproject.org> - 1.6.11-1
+- update to 1.6.11 (stable)
+
* Fri Jul 3 2015 Remi Collet <remi@fedoraproject.org> - 1.6.10-1
- update to 1.6.10 (stable)