summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION45
-rw-r--r--php-pecl-mongo-dev.spec9
2 files changed, 43 insertions, 11 deletions
diff --git a/REFLECTION b/REFLECTION
index 95e0276..7831616 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #171 mongo version 1.6.0RC1 ] {
+Extension [ <persistent> extension #171 mongo version 1.6.0RC3 ] {
- Dependencies {
Dependency [ openssl (Optional) ]
@@ -77,7 +77,7 @@ Extension [ <persistent> extension #171 mongo version 1.6.0RC1 ] {
- Constants [8] {
Constant [ string DEFAULT_HOST ] { localhost }
Constant [ integer DEFAULT_PORT ] { 27017 }
- Constant [ string VERSION ] { 1.6.0RC1 }
+ Constant [ string VERSION ] { 1.6.0RC3 }
Constant [ string RP_PRIMARY ] { primary }
Constant [ string RP_PRIMARY_PREFERRED ] { primaryPreferred }
Constant [ string RP_SECONDARY ] { secondary }
@@ -213,7 +213,7 @@ Extension [ <persistent> extension #171 mongo version 1.6.0RC1 ] {
- Constants [8] {
Constant [ string DEFAULT_HOST ] { localhost }
Constant [ integer DEFAULT_PORT ] { 27017 }
- Constant [ string VERSION ] { 1.6.0RC1 }
+ Constant [ string VERSION ] { 1.6.0RC3 }
Constant [ string RP_PRIMARY ] { primary }
Constant [ string RP_PRIMARY_PREFERRED ] { primaryPreferred }
Constant [ string RP_SECONDARY ] { secondary }
@@ -437,7 +437,7 @@ Extension [ <persistent> extension #171 mongo version 1.6.0RC1 ] {
Property [ <default> public $wtimeout ]
}
- - Methods [28] {
+ - Methods [29] {
Method [ <internal:mongo, ctor> public method __construct ] {
- Parameters [2] {
@@ -569,6 +569,13 @@ Extension [ <persistent> extension #171 mongo version 1.6.0RC1 ] {
}
}
+ Method [ <internal:mongo> public method getCollectionInfo ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $includeSystemCollections ]
+ }
+ }
+
Method [ <internal:mongo> public method createDBRef ] {
- Parameters [2] {
@@ -914,7 +921,7 @@ Extension [ <persistent> extension #171 mongo version 1.6.0RC1 ] {
- Properties [0] {
}
- - Methods [8] {
+ - Methods [9] {
Method [ <internal:mongo> abstract public method batchSize ] {
- Parameters [1] {
@@ -934,6 +941,13 @@ Extension [ <persistent> extension #171 mongo version 1.6.0RC1 ] {
}
}
+ Method [ <internal:mongo> abstract public method timeout ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $timeoutMS ]
+ }
+ }
+
Method [ <internal:Core, inherits Iterator> abstract public method current ] {
}
@@ -1116,7 +1130,11 @@ Extension [ <persistent> extension #171 mongo version 1.6.0RC1 ] {
}
}
- Method [ <internal:mongo> public method timeout ] {
+ Method [ <internal:mongo, prototype MongoCursorInterface> public method timeout ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $timeoutMS ]
+ }
}
Method [ <internal, deprecated:mongo> final protected method doQuery ] {
@@ -1204,7 +1222,7 @@ Extension [ <persistent> extension #171 mongo version 1.6.0RC1 ] {
- Properties [0] {
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:mongo, ctor> public method __construct ] {
- Parameters [3] {
@@ -1221,6 +1239,13 @@ Extension [ <persistent> extension #171 mongo version 1.6.0RC1 ] {
}
}
+ Method [ <internal:mongo, prototype MongoCursorInterface> public method timeout ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $timeoutMS ]
+ }
+ }
+
Method [ <internal:mongo, prototype MongoCursorInterface> public method info ] {
- Parameters [0] {
@@ -1751,7 +1776,11 @@ Extension [ <persistent> extension #171 mongo version 1.6.0RC1 ] {
}
}
- Method [ <internal:mongo, inherits MongoCursor> public method timeout ] {
+ Method [ <internal:mongo, inherits MongoCursor, prototype MongoCursorInterface> public method timeout ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $timeoutMS ]
+ }
}
Method [ <internal, deprecated:mongo, inherits MongoCursor> final protected method doQuery ] {
diff --git a/php-pecl-mongo-dev.spec b/php-pecl-mongo-dev.spec
index dd5b10e..f9e4cda 100644
--- a/php-pecl-mongo-dev.spec
+++ b/php-pecl-mongo-dev.spec
@@ -5,8 +5,8 @@
%global pecl_name mongo
%global with_zts 0%{?__ztsphp:1}
-%global prever RC2
-%global gh_commit 6f85524af47f7ebb08e97a97f5f20193fd27f9e7
+%global prever RC3
+%global gh_commit faa744382a00a773d8e5e8ff1455a21c6dd971aa
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner mongodb
%global gh_project mongo-php-driver
@@ -22,7 +22,7 @@
Summary: PHP MongoDB database driver
Name: %{?scl_prefix}php-pecl-mongo
Version: 1.6.0
-Release: 0.2.%{prever}%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 0.3.%{prever}%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: ASL 2.0
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -219,6 +219,9 @@ rm -rf data
%changelog
+* Fri Dec 19 2014 Remi Collet <remi@fedoraproject.org> - 1.6.0-0.3.RC3
+- Update to 1.6.0RC3 (beta)
+
* Wed Nov 19 2014 Remi Collet <remi@fedoraproject.org> - 1.6.0-0.2.RC2
- Update to 1.6.0RC2 (beta)