summaryrefslogtreecommitdiffstats
path: root/php-pecl-mongo.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-09-04 08:33:07 +0200
committerRemi Collet <remi@remirepo.net>2017-09-04 08:33:07 +0200
commit0bfe134abfae6e174fca392e4a7e620431c711ae (patch)
treeec1c6490ffe7a447fd16d3104fb7d60059aae552 /php-pecl-mongo.spec
parentcc610d8417e738407174021692c11277fcf93fb6 (diff)
v1.6.15
Diffstat (limited to 'php-pecl-mongo.spec')
-rw-r--r--php-pecl-mongo.spec26
1 files changed, 14 insertions, 12 deletions
diff --git a/php-pecl-mongo.spec b/php-pecl-mongo.spec
index bc4a7a4..d4442f4 100644
--- a/php-pecl-mongo.spec
+++ b/php-pecl-mongo.spec
@@ -14,10 +14,10 @@
%{?scl: %scl_package php-pecl-mongo}
%global pecl_name mongo
-%global with_zts 0%{?__ztsphp:1}
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
#global prever RC3
# see https://github.com/mongodb/mongo-php-driver-legacy/releases
-%global gh_commit 0b2945e4d96ad9407b68cd9ac403e5824b3f364e
+%global gh_commit 026eaed503bc927b2ef6c79fd53314e07f44ddfb
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner mongodb
%global gh_project mongo-php-driver-legacy
@@ -32,7 +32,7 @@
Summary: PHP MongoDB database driver
Name: %{?scl_prefix}php-pecl-mongo
-Version: 1.6.14
+Version: 1.6.15
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: ASL 2.0
Group: Development/Languages
@@ -42,8 +42,10 @@ URL: http://pecl.php.net/package/%{pecl_name}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}%{?prever}.tar.gz
Source1: %{pecl_name}.ini
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: %{?scl_prefix}php-devel >= 5.2.6
+# https://jira.mongodb.org/browse/PHP-1529
+Patch0: 883.patch
+
+BuildRequires: %{?scl_prefix}php-devel < 7
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: cyrus-sasl-devel
BuildRequires: openssl-devel
@@ -108,6 +110,8 @@ mv NTS/package.xml .
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
+%patch0 -p1 -b .pr883
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_MONGO_VERSION/{s/.* "//;s/".*$//;p}' php_mongo.h)
if test "x${extver}" != "x%{version}%{?prever}"; then
@@ -140,8 +144,6 @@ make %{?_smp_mflags}
%install
-rm -rf %{buildroot}
-
make -C NTS install INSTALL_ROOT=%{buildroot}
# Drop in the bit of configuration
@@ -161,10 +163,6 @@ do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
-%clean
-rm -rf %{buildroot}
-
-
%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
@@ -237,7 +235,6 @@ rm -rf data
%files
-%defattr(-, root, root, -)
%{?_licensedir:%license NTS/LICENSE.md}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -252,6 +249,11 @@ rm -rf data
%changelog
+* Mon Sep 4 2017 Remi Collet <remi@remirepo.net> - 1.6.15-1
+- Update to 1.6.15
+- add patch to fix undefine symbol
+ https://jira.mongodb.org/browse/PHP-1529
+
* Tue Apr 26 2016 Remi Collet <remi@fedoraproject.org> - 1.6.14-1
- update to 1.6.14 (stable)