summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-06-06 06:53:53 +0200
committerRemi Collet <fedora@famillecollet.com>2014-06-06 06:53:53 +0200
commit73f8b94ba9af55c8f9099605475c116c9e68fc84 (patch)
tree55ef4f4dc9d4f34deacaa96f9d90a67369e7d310
parentaa928c091fdcac02aec0604c523e822bf7178179 (diff)
php-pecl-mongo: 1.5.3 (stable)
-rw-r--r--REFLECTION15
-rw-r--r--mongo-json.patch16
-rw-r--r--php-pecl-mongo.spec19
3 files changed, 14 insertions, 36 deletions
diff --git a/REFLECTION b/REFLECTION
index 781b814..b7d96b4 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,8 +1,7 @@
-Extension [ <persistent> extension #157 mongo version 1.5.2 ] {
+Extension [ <persistent> extension #157 mongo version 1.5.3 ] {
- Dependencies {
Dependency [ openssl (Optional) ]
- Dependency [ json (Required) ]
}
- INI {
@@ -77,7 +76,7 @@ Extension [ <persistent> extension #157 mongo version 1.5.2 ] {
- Constants [8] {
Constant [ string DEFAULT_HOST ] { localhost }
Constant [ integer DEFAULT_PORT ] { 27017 }
- Constant [ string VERSION ] { 1.5.2 }
+ Constant [ string VERSION ] { 1.5.3 }
Constant [ string RP_PRIMARY ] { primary }
Constant [ string RP_PRIMARY_PREFERRED ] { primaryPreferred }
Constant [ string RP_SECONDARY ] { secondary }
@@ -213,7 +212,7 @@ Extension [ <persistent> extension #157 mongo version 1.5.2 ] {
- Constants [8] {
Constant [ string DEFAULT_HOST ] { localhost }
Constant [ integer DEFAULT_PORT ] { 27017 }
- Constant [ string VERSION ] { 1.5.2 }
+ Constant [ string VERSION ] { 1.5.3 }
Constant [ string RP_PRIMARY ] { primary }
Constant [ string RP_PRIMARY_PREFERRED ] { primaryPreferred }
Constant [ string RP_SECONDARY ] { secondary }
@@ -1841,7 +1840,7 @@ Extension [ <persistent> extension #157 mongo version 1.5.2 ] {
Method [ <internal:mongo> public method add ] {
- Parameters [1] {
- Parameter #0 [ <required> array $item ]
+ Parameter #0 [ <required> $item ]
}
}
@@ -1895,7 +1894,7 @@ Extension [ <persistent> extension #157 mongo version 1.5.2 ] {
Method [ <internal:mongo, inherits MongoWriteBatch> public method add ] {
- Parameters [1] {
- Parameter #0 [ <required> array $item ]
+ Parameter #0 [ <required> $item ]
}
}
@@ -1949,7 +1948,7 @@ Extension [ <persistent> extension #157 mongo version 1.5.2 ] {
Method [ <internal:mongo, inherits MongoWriteBatch> public method add ] {
- Parameters [1] {
- Parameter #0 [ <required> array $item ]
+ Parameter #0 [ <required> $item ]
}
}
@@ -2003,7 +2002,7 @@ Extension [ <persistent> extension #157 mongo version 1.5.2 ] {
Method [ <internal:mongo, inherits MongoWriteBatch> public method add ] {
- Parameters [1] {
- Parameter #0 [ <required> array $item ]
+ Parameter #0 [ <required> $item ]
}
}
diff --git a/mongo-json.patch b/mongo-json.patch
deleted file mode 100644
index fe43a1f..0000000
--- a/mongo-json.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- config.m4.old 2014-02-26 14:17:31.000000000 +0100
-+++ config.m4 2014-02-26 14:22:36.000000000 +0100
-@@ -148,4 +148,13 @@
- -L$MONGO_SASL_DIR/$PHP_LIBDIR
- ])
- PHP_SUBST(MONGO_SHARED_LIBADD)
-+
-+fi
-+
-+AC_MSG_CHECKING(for JSON)
-+if test -f "$phpincludedir/ext/json/php_json.h"; then
-+ AC_DEFINE(HAVE_JSON, 1, [JSON support])
-+ AC_MSG_RESULT(Yes)
-+else
-+ AC_MSG_RESULT(Missing json or jsonc extension)
- fi
diff --git a/php-pecl-mongo.spec b/php-pecl-mongo.spec
index cb684c0..cd688ff 100644
--- a/php-pecl-mongo.spec
+++ b/php-pecl-mongo.spec
@@ -5,7 +5,7 @@
%global pecl_name mongo
%global with_zts 0%{?__ztsphp:1}
#global prever RC2
-%global gh_commit 9ed256e3a3097e39291a68aadeaacdbbcc32dae2
+%global gh_commit 9d31e46a1eaf58e56c550217aecc5a092cfce439
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner mongodb
%global gh_project mongo-php-driver
@@ -20,7 +20,7 @@
Summary: PHP MongoDB database driver
Name: php-pecl-mongo
-Version: 1.5.2
+Version: 1.5.3
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: ASL 2.0
Group: Development/Languages
@@ -33,9 +33,9 @@ Source1: %{pecl_name}.ini
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: php-devel >= 5.2.6
BuildRequires: php-pear
-BuildRequires: php-json
BuildRequires: cyrus-sasl-devel
%if %{with_tests}
+BuildRequires: php-json
BuildRequires: mongodb
BuildRequires: mongodb-server
%endif
@@ -44,13 +44,6 @@ Requires(post): %{__pecl}
Requires(postun): %{__pecl}
Requires: php(zend-abi) = %{php_zend_api}
Requires: php(api) = %{php_core_api}
-%if "%{php_version}" < "5.4"
-# php 5.3.3 in EL-6 don't use arched virtual provides
-# so only requires real packages instead
-Requires: php-common%{?_isa}
-%else
-Requires: php-json%{?_isa}
-%endif
Provides: php-%{pecl_name} = %{version}
Provides: php-%{pecl_name}%{?_isa} = %{version}
@@ -162,7 +155,6 @@ fi
%check
: Minimal load test for NTS extension
%{__php} -n \
- -d extension=json.so \
-d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
-i | grep "MongoDB Support => enabled"
@@ -200,7 +192,6 @@ rm -rf data
%if %{with_zts}
: Minimal load test for ZTS extension
%{__ztsphp} -n \
- -d extension=json.so \
-d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
-i | grep "MongoDB Support => enabled"
%endif
@@ -221,6 +212,10 @@ rm -rf data
%changelog
+* Fri Jun 06 2014 Remi Collet <remi@fedoraproject.org> - 1.5.3-1
+- Update to 1.5.3 (stable)
+- drop dependency on php-json
+
* Tue May 06 2014 Remi Collet <remi@fedoraproject.org> - 1.5.2-1
- Update to 1.5.2 (stable)