summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-02-17 10:33:44 +0100
committerRemi Collet <remi@remirepo.net>2018-02-17 10:33:44 +0100
commitd63926a749219b80d927d5697f9e31101b132994 (patch)
treebaeba55f09a11bce7421d5af86a5e6be2c30827e
parent0255bfc3b180896d8c12a1b1972ab796ed83a652 (diff)
cleanup
-rw-r--r--REFLECTION23
-rw-r--r--REFLECTION-PHP7238
-rw-r--r--php-pecl-mogilefs-php7.spec257
-rw-r--r--php-pecl-mogilefs.spec75
4 files changed, 53 insertions, 540 deletions
diff --git a/REFLECTION b/REFLECTION
index a249282..880e6b2 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #125 mogilefs version 0.9.2 ] {
+Extension [ <persistent> extension #62 mogilefs version 0.9.3.1 ] {
- Classes [2] {
Class [ <internal:mogilefs> class MogileFs ] {
@@ -42,8 +42,9 @@ Extension [ <persistent> extension #125 mogilefs version 0.9.2 ] {
Method [ <internal:mogilefs> public method get ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $pathcount ]
}
}
@@ -176,7 +177,7 @@ Extension [ <persistent> extension #125 mogilefs version 0.9.2 ] {
}
}
- Class [ <internal:mogilefs> class MogileFsException extends Exception ] {
+ Class [ <internal:mogilefs> class MogileFsException extends Exception implements Throwable ] {
- Constants [0] {
}
@@ -207,28 +208,28 @@ Extension [ <persistent> extension #125 mogilefs version 0.9.2 ] {
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
}
- Method [ <internal:Core, inherits Exception> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
}
- Method [ <internal:Core, inherits Exception> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
}
- Method [ <internal:Core, inherits Exception> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
}
- Method [ <internal:Core, inherits Exception> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
}
- Method [ <internal:Core, inherits Exception> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
}
- Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits Exception> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
}
}
}
diff --git a/REFLECTION-PHP7 b/REFLECTION-PHP7
deleted file mode 100644
index 880e6b2..0000000
--- a/REFLECTION-PHP7
+++ /dev/null
@@ -1,238 +0,0 @@
-Extension [ <persistent> extension #62 mogilefs version 0.9.3.1 ] {
-
- - Classes [2] {
- Class [ <internal:mogilefs> class MogileFs ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [1] {
- Method [ <internal:mogilefs> static public method isInDebuggingMode ] {
-
- - Parameters [0] {
- }
- }
- }
-
- - Properties [0] {
- }
-
- - Methods [33] {
- Method [ <internal:mogilefs, ctor> public method __construct ] {
- }
-
- Method [ <internal:mogilefs> public method isConnected ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mogilefs> public method connect ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $host ]
- Parameter #1 [ <required> $port ]
- Parameter #2 [ <required> $domain ]
- Parameter #3 [ <required> $timeout ]
- }
- }
-
- Method [ <internal:mogilefs> public method get ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $key ]
- Parameter #1 [ <required> $pathcount ]
- }
- }
-
- Method [ <internal:mogilefs> public method getDomains ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mogilefs> public method fileInfo ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $key ]
- }
- }
-
- Method [ <internal:mogilefs> public method listKeys ] {
- }
-
- Method [ <internal:mogilefs> public method listFids ] {
- }
-
- Method [ <internal:mogilefs> public method getHosts ] {
- }
-
- Method [ <internal:mogilefs> public method getDevices ] {
- }
-
- Method [ <internal:mogilefs> public method sleep ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $seconds ]
- }
- }
-
- Method [ <internal:mogilefs> public method stats ] {
- }
-
- Method [ <internal:mogilefs> public method replicate ] {
- }
-
- Method [ <internal:mogilefs> public method createDevice ] {
- }
-
- Method [ <internal:mogilefs> public method createDomain ] {
- }
-
- Method [ <internal:mogilefs> public method deleteDomain ] {
- }
-
- Method [ <internal:mogilefs> public method createClass ] {
- }
-
- Method [ <internal:mogilefs> public method updateClass ] {
- }
-
- Method [ <internal:mogilefs> public method deleteClass ] {
- }
-
- Method [ <internal:mogilefs> public method createHost ] {
- }
-
- Method [ <internal:mogilefs> public method updateHost ] {
- }
-
- Method [ <internal:mogilefs> public method deleteHost ] {
- }
-
- Method [ <internal:mogilefs> public method setWeight ] {
- }
-
- Method [ <internal:mogilefs> public method setState ] {
- }
-
- Method [ <internal:mogilefs> public method checker ] {
- }
-
- Method [ <internal:mogilefs> public method monitorRound ] {
- }
-
- Method [ <internal:mogilefs> public method put ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $filename ]
- Parameter #1 [ <required> $key ]
- Parameter #2 [ <required> $class ]
- Parameter #3 [ <optional> $file_only ]
- }
- }
-
- Method [ <internal:mogilefs> public method close ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mogilefs> public method delete ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $key ]
- }
- }
-
- Method [ <internal:mogilefs> public method rename ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $key ]
- Parameter #1 [ <required> $destination ]
- }
- }
-
- Method [ <internal:mogilefs> public method setReadTimeout ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $readTimeout ]
- }
- }
-
- Method [ <internal:mogilefs> public method getReadTimeout ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:mogilefs> public method disconnect ] {
-
- - Parameters [0] {
- }
- }
- }
- }
-
- Class [ <internal:mogilefs> class MogileFsException extends Exception implements Throwable ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
- }
-
- - Methods [10] {
- Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
-
- - Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
- }
- }
-
- Method [ <internal:Core, inherits Exception> public method __wakeup ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
- }
- }
- }
- }
-}
-
diff --git a/php-pecl-mogilefs-php7.spec b/php-pecl-mogilefs-php7.spec
deleted file mode 100644
index f1c04dd..0000000
--- a/php-pecl-mogilefs-php7.spec
+++ /dev/null
@@ -1,257 +0,0 @@
-# remirepo spec file for php-pecl-mogilefs
-#
-# Copyright (c) 2015-2017 Remi Collet
-# License: CC-BY-SA
-# http://creativecommons.org/licenses/by-sa/4.0/
-#
-# Please, preserve the changelog entries
-#
-%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
-%endif
-
-%{?scl: %scl_package php-pecl-mogilefs}
-
-# Broken for now
-%global with_zts 0
-%global pecl_name mogilefs
-# Running test suite requires a server
-%global with_tests 0%{?_with_tests:1}
-%global ini_name 40-%{pecl_name}.ini
-
-Summary: PHP client library to communicate with the MogileFS storage
-Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 0.9.3.1
-Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-# https://github.com/lstrojny/pecl-mogilefs/issues/15
-License: BSD
-Group: Development/Languages
-URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: libxml2-devel
-BuildRequires: neon-devel
-BuildRequires: %{?scl_prefix}php-devel > 7
-BuildRequires: %{?scl_prefix}php-pear
-
-Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
-Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name} <= %{version}
-Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
-
-
-%description
-PHP MogileFS is a client library to communicate with MogileFS trackers.
-Those trackers are part of the distributed filesystem MogileFS created by
-Danga Interactive (http://www.danga.com/) and used in serveral large scale
-projects like LiveJournal.
-
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{scl_vendor})}.
-
-
-%prep
-%setup -q -c
-mv %{pecl_name}-%{version} NTS
-
-# Don't install tests
-sed -e '/role="test"/d' \
- %{?_licensedir: -e '/LICENSE/s/role="doc"/role="test"/'} \
- -i package.xml
-
-cd NTS
-
-: Sanity check, really often broken
-extver=$(sed -n '/#define PHP_MOGILEFS_VERSION/{s/.* "//;s/".*$//;p}' php_mogilefs.h)
-if test "x${extver}" != "x%{version}"; then
- : Error: Upstream extension version is ${extver}, expecting %{version}.
- exit 1
-fi
-cd ..
-
-%if %{with_zts}
-# Duplicate source tree for NTS / ZTS build
-cp -pr NTS ZTS
-%endif
-
-# Create configuration file
-cat > %{ini_name} << 'EOF'
-; Enable %{pecl_name} extension module
-extension=%{pecl_name}.so
-EOF
-
-
-%build
-cd NTS
-%{_bindir}/phpize
-%configure \
- --with-mogilefs \
- --with-php-config=%{_bindir}/php-config
-make %{?_smp_mflags}
-
-%if %{with_zts}
-cd ../ZTS
-%{_bindir}/zts-phpize
-%configure \
- --with-mogilefs \
- --with-php-config=%{_bindir}/zts-php-config
-make %{?_smp_mflags}
-%endif
-
-
-%install
-rm -rf %{buildroot}
-
-make -C NTS install INSTALL_ROOT=%{buildroot}
-
-# install config file
-install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
-
-# Install XML package description
-install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
-
-%if %{with_zts}
-make -C ZTS install INSTALL_ROOT=%{buildroot}
-
-install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
-%endif
-
-# Documentation
-for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
-done
-
-
-%check
-cd NTS
-: Minimal load test for NTS extension
-%{__php} --no-php-ini \
- --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
-
-%if %{with_tests}
-: Upstream test suite for NTS extension
-TEST_PHP_EXECUTABLE=%{__php} \
-TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php --show-diff
-%endif
-
-%if %{with_zts}
-cd ../ZTS
-: Minimal load test for ZTS extension
-%{__ztsphp} --no-php-ini \
- --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
-
-%if %{with_tests}
-: Upstream test suite for ZTS extension
-TEST_PHP_EXECUTABLE=%{_bindir}/zts-php \
-TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
-%{_bindir}/zts-php -n run-tests.php --show-diff
-%endif
-%endif
-
-
-%if 0%{?fedora} < 24
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
-%clean
-rm -rf %{buildroot}
-
-
-%files
-%defattr(-,root,root,-)
-%doc %{pecl_docdir}/%{pecl_name}
-%{?_licensedir:%license NTS/LICENSE}
-
-%{pecl_xmldir}/%{name}.xml
-%config(noreplace) %{php_inidir}/%{ini_name}
-%{php_extdir}/%{pecl_name}.so
-
-%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{ini_name}
-%{php_ztsextdir}/%{pecl_name}.so
-%endif
-
-
-%changelog
-* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 0.9.3.1-5
-- rebuild for PHP 7.2.0beta1 new API
-
-* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 0.9.3.1-4
-- rebuild with PHP 7.1.0 GA
-
-* Wed Sep 14 2016 Remi Collet <remi@fedoraproject.org> - 0.9.3.1-3
-- rebuild for PHP 7.1 new API version
-
-* Sat Mar 5 2016 Remi Collet <remi@fedoraproject.org> - 0.9.3.1-2
-- adapt for F24
-
-* Wed Jan 20 2016 Remi Collet <remi@fedoraproject.org> - 0.9.3.1-1
-- Update to 0.9.3.1 (php 7, beta, no change)
-
-* Tue Jan 19 2016 Remi Collet <remi@fedoraproject.org> - 0.9.3-1
-- Update to 0.9.3 (php 7, beta)
-
-* Thu Sep 3 2015 Remi Collet <remi@fedoraproject.org> - 0.9.2-1
-- initial package, version 0.9.2 (beta)
-- missing license file
- open https://github.com/lstrojny/pecl-mogilefs/issues/15
-- ZTS build is broken
- open https://github.com/lstrojny/pecl-mogilefs/pull/16
-
diff --git a/php-pecl-mogilefs.spec b/php-pecl-mogilefs.spec
index 0eccf0f..8ac4e15 100644
--- a/php-pecl-mogilefs.spec
+++ b/php-pecl-mogilefs.spec
@@ -6,41 +6,34 @@
#
# Please, preserve the changelog entries
#
+
+# we don't want -z defs linker flag
+%undefine _strict_symbol_defs_build
+
%if 0%{?scl:1}
-%if "%{scl}" == "rh-php56"
-%global sub_prefix more-php56-
-%else
%global sub_prefix %{scl_prefix}
+%scl_package php-pecl-mogilefs
%endif
-%endif
-
-%{?scl: %scl_package php-pecl-mogilefs}
# Broken for now
%global with_zts 0
%global pecl_name mogilefs
# Running test suite requires a server
%global with_tests 0%{?_with_tests:1}
-%if "%{php_version}" < "5.6"
-%global ini_name %{pecl_name}.ini
-%else
%global ini_name 40-%{pecl_name}.ini
-%endif
Summary: PHP client library to communicate with the MogileFS storage
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 0.9.2
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 0.9.3.1
+Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# https://github.com/lstrojny/pecl-mogilefs/issues/15
License: BSD
-Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: libxml2-devel
BuildRequires: neon-devel
-BuildRequires: %{?scl_prefix}php-devel > 5.2
+BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
@@ -49,10 +42,10 @@ Requires: %{?scl_prefix}php(api) = %{php_core_api}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
@@ -60,17 +53,19 @@ Obsoletes: php53-pecl-%{pecl_name} <= %{version}
Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
Obsoletes: php54-pecl-%{pecl_name} <= %{version}
Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "5.5"
Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "5.6"
Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.0"
Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.2"
+Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -95,11 +90,11 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
mv %{pecl_name}-%{version} NTS
# Don't install tests
-sed -e '/role="test"/d' -i package.xml
+sed -e '/role="test"/d' \
+ %{?_licensedir: -e '/LICENSE/s/role="doc"/role="test"/'} \
+ -i package.xml
cd NTS
-: Fix version
-sed -e '/PHP_MOGILEFS_VERSION/s/0.9.2-dev/%{version}/' -i php_mogilefs.h
: Sanity check, really often broken
extver=$(sed -n '/#define PHP_MOGILEFS_VERSION/{s/.* "//;s/".*$//;p}' php_mogilefs.h)
@@ -122,6 +117,8 @@ EOF
%build
+%{?dtsenable}
+
cd NTS
%{_bindir}/phpize
%configure \
@@ -140,7 +137,7 @@ make %{?_smp_mflags}
%install
-rm -rf %{buildroot}
+%{?dtsenable}
make -C NTS install INSTALL_ROOT=%{buildroot}
@@ -196,7 +193,7 @@ REPORT_EXIT_STATUS=1 \
%endif
-%if 0%{?fedora} < 24
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -216,14 +213,9 @@ fi
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%doc %{pecl_docdir}/%{pecl_name}
-#{?_licensedir:%license NTS/LICENSE}
+%{?_licensedir:%license NTS/LICENSE}
%{pecl_xmldir}/%{name}.xml
%config(noreplace) %{php_inidir}/%{ini_name}
@@ -236,9 +228,24 @@ rm -rf %{buildroot}
%changelog
-* Tue Mar 8 2016 Remi Collet <remi@fedoraproject.org> - 0.9.2-2
+* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 0.9.3.1-5
+- rebuild for PHP 7.2.0beta1 new API
+
+* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 0.9.3.1-4
+- rebuild with PHP 7.1.0 GA
+
+* Wed Sep 14 2016 Remi Collet <remi@fedoraproject.org> - 0.9.3.1-3
+- rebuild for PHP 7.1 new API version
+
+* Sat Mar 5 2016 Remi Collet <remi@fedoraproject.org> - 0.9.3.1-2
- adapt for F24
+* Wed Jan 20 2016 Remi Collet <remi@fedoraproject.org> - 0.9.3.1-1
+- Update to 0.9.3.1 (php 7, beta, no change)
+
+* Tue Jan 19 2016 Remi Collet <remi@fedoraproject.org> - 0.9.3-1
+- Update to 0.9.3 (php 7, beta)
+
* Thu Sep 3 2015 Remi Collet <remi@fedoraproject.org> - 0.9.2-1
- initial package, version 0.9.2 (beta)
- missing license file