summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-09-03 15:28:43 +0200
committerRemi Collet <fedora@famillecollet.com>2015-09-03 15:28:43 +0200
commit653aebb1982164b31af8ab9070339a5a37d516cb (patch)
tree749947f9cbed1d27b52c3959e7dd781fc3c25ef1
php-pecl-mogilefs: 0.9.2 - New package
-rw-r--r--Makefile4
-rw-r--r--REFLECTION237
-rw-r--r--php-pecl-mogilefs.spec240
3 files changed, 481 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..a249282
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,237 @@
+Extension [ <persistent> extension #125 mogilefs version 0.9.2 ] {
+
+ - Classes [2] {
+ Class [ <internal:mogilefs> class MogileFs ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [1] {
+ Method [ <internal:mogilefs> static public method isInDebuggingMode ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [33] {
+ Method [ <internal:mogilefs, ctor> public method __construct ] {
+ }
+
+ Method [ <internal:mogilefs> public method isConnected ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mogilefs> public method connect ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $host ]
+ Parameter #1 [ <required> $port ]
+ Parameter #2 [ <required> $domain ]
+ Parameter #3 [ <required> $timeout ]
+ }
+ }
+
+ Method [ <internal:mogilefs> public method get ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+
+ Method [ <internal:mogilefs> public method getDomains ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mogilefs> public method fileInfo ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+
+ Method [ <internal:mogilefs> public method listKeys ] {
+ }
+
+ Method [ <internal:mogilefs> public method listFids ] {
+ }
+
+ Method [ <internal:mogilefs> public method getHosts ] {
+ }
+
+ Method [ <internal:mogilefs> public method getDevices ] {
+ }
+
+ Method [ <internal:mogilefs> public method sleep ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $seconds ]
+ }
+ }
+
+ Method [ <internal:mogilefs> public method stats ] {
+ }
+
+ Method [ <internal:mogilefs> public method replicate ] {
+ }
+
+ Method [ <internal:mogilefs> public method createDevice ] {
+ }
+
+ Method [ <internal:mogilefs> public method createDomain ] {
+ }
+
+ Method [ <internal:mogilefs> public method deleteDomain ] {
+ }
+
+ Method [ <internal:mogilefs> public method createClass ] {
+ }
+
+ Method [ <internal:mogilefs> public method updateClass ] {
+ }
+
+ Method [ <internal:mogilefs> public method deleteClass ] {
+ }
+
+ Method [ <internal:mogilefs> public method createHost ] {
+ }
+
+ Method [ <internal:mogilefs> public method updateHost ] {
+ }
+
+ Method [ <internal:mogilefs> public method deleteHost ] {
+ }
+
+ Method [ <internal:mogilefs> public method setWeight ] {
+ }
+
+ Method [ <internal:mogilefs> public method setState ] {
+ }
+
+ Method [ <internal:mogilefs> public method checker ] {
+ }
+
+ Method [ <internal:mogilefs> public method monitorRound ] {
+ }
+
+ Method [ <internal:mogilefs> public method put ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $filename ]
+ Parameter #1 [ <required> $key ]
+ Parameter #2 [ <required> $class ]
+ Parameter #3 [ <optional> $file_only ]
+ }
+ }
+
+ Method [ <internal:mogilefs> public method close ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mogilefs> public method delete ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+
+ Method [ <internal:mogilefs> public method rename ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $destination ]
+ }
+ }
+
+ Method [ <internal:mogilefs> public method setReadTimeout ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $readTimeout ]
+ }
+ }
+
+ Method [ <internal:mogilefs> public method getReadTimeout ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mogilefs> public method disconnect ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:mogilefs> class MogileFsException extends Exception ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __toString ] {
+ }
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-mogilefs.spec b/php-pecl-mogilefs.spec
new file mode 100644
index 0000000..27fda04
--- /dev/null
+++ b/php-pecl-mogilefs.spec
@@ -0,0 +1,240 @@
+# remirepo spec file for php-pecl-mogilefs
+#
+# Copyright (c) 2015 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%if 0%{?scl:1}
+%if "%{scl}" == "rh-php56"
+%global sub_prefix more-php56-
+%else
+%global sub_prefix %{scl_prefix}
+%endif
+%endif
+
+%{?scl: %scl_package php-pecl-mogilefs}
+%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
+%{!?__pecl: %global __pecl %{_bindir}/pecl}
+%{!?__php: %global __php %{_bindir}/php}
+
+# Broken for now
+%global with_zts 0
+%global pecl_name mogilefs
+# Running test suite requires a server
+%global with_tests 0%{?_with_tests:1}
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
+
+Summary: PHP client library to communicate with the MogileFS storage
+Name: %{?sub_prefix}php-pecl-%{pecl_name}
+Version: 0.9.2
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+# https://github.com/lstrojny/pecl-mogilefs/issues/15
+License: BSD
+Group: Development/Languages
+URL: http://pecl.php.net/package/%{pecl_name}
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRequires: libxml2-devel
+BuildRequires: neon-devel
+BuildRequires: %{?scl_prefix}php-devel > 5.2
+BuildRequires: %{?scl_prefix}php-pear
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
+# Other third party repo stuff
+Obsoletes: php53-pecl-%{pecl_name} <= %{version}
+Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php54-pecl-%{pecl_name} <= %{version}
+Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "5.5"
+Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "5.6"
+Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.0"
+Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
+%endif
+%endif
+
+%if 0%{?fedora} < 20 && 0%{?rhel} < 7
+# Filter shared private
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+%endif
+
+
+%description
+PHP MogileFS is a client library to communicate with MogileFS trackers.
+Those trackers are part of the distributed filesystem MogileFS created by
+Danga Interactive (http://www.danga.com/) and used in serveral large scale
+projects like LiveJournal.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{scl_vendor})}.
+
+
+%prep
+%setup -q -c
+mv %{pecl_name}-%{version} NTS
+
+# Don't install tests
+sed -e '/role="test"/d' -i package.xml
+
+cd NTS
+! Fix version
+sed -e '/PHP_MOGILEFS_VERSION/s/0.9.2-dev/%{version}/' -i php_mogilefs.h
+
+: Sanity check, really often broken
+extver=$(sed -n '/#define PHP_MOGILEFS_VERSION/{s/.* "//;s/".*$//;p}' php_mogilefs.h)
+if test "x${extver}" != "x%{version}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}.
+ exit 1
+fi
+cd ..
+
+%if %{with_zts}
+# Duplicate source tree for NTS / ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Create configuration file
+cat > %{ini_name} << 'EOF'
+; Enable %{pecl_name} extension module
+extension=%{pecl_name}.so
+EOF
+
+
+%build
+cd NTS
+%{_bindir}/phpize
+%configure \
+ --with-mogilefs \
+ --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure \
+ --with-mogilefs \
+ --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+rm -rf %{buildroot}
+
+make -C NTS install INSTALL_ROOT=%{buildroot}
+
+# install config file
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%check
+cd NTS
+: Minimal load test for NTS extension
+%{__php} --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+%if %{with_tests}
+: Upstream test suite for NTS extension
+TEST_PHP_EXECUTABLE=%{__php} \
+TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__php} -n run-tests.php --show-diff
+%endif
+
+%if %{with_zts}
+cd ../ZTS
+: Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+%if %{with_tests}
+: Upstream test suite for ZTS extension
+TEST_PHP_EXECUTABLE=%{_bindir}/zts-php \
+TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{_bindir}/zts-php -n run-tests.php --show-diff
+%endif
+%endif
+
+
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pecl_docdir}/%{pecl_name}
+#{?_licensedir:%license NTS/LICENSE}
+
+%{pecl_xmldir}/%{name}.xml
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Thu Sep 3 2015 Remi Collet <remi@fedoraproject.org> - 0.9.2-1
+- initial package, version 0.9.2 (beta)
+- open https://github.com/lstrojny/pecl-mogilefs/issues/15 \ No newline at end of file