summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-02-17 10:30:20 +0100
committerRemi Collet <remi@remirepo.net>2018-02-17 10:30:20 +0100
commitdbef30ba23ff5a86967c93dbd5e5f5087196dbe2 (patch)
tree5425f16cc61c36e0855aa0fef057999c50ac128e
parent2b3a4aed67c3c41bcb5ab38b496495883bb197ff (diff)
cleanup
-rw-r--r--LICENSE19
-rw-r--r--REFLECTION2
-rw-r--r--REFLECTION-PHP750
-rw-r--r--php-pecl-memprof-php7.spec251
-rw-r--r--php-pecl-memprof.spec82
5 files changed, 47 insertions, 357 deletions
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index ed3a21c..0000000
--- a/LICENSE
+++ /dev/null
@@ -1,19 +0,0 @@
-Copyright (c) 2013 Arnaud Le Blanc
-
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the "Software"), to deal
-in the Software without restriction, including without limitation the rights
-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-copies of the Software, and to permit persons to whom the Software is furnished
-to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in all
-copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
-THE SOFTWARE.
diff --git a/REFLECTION b/REFLECTION
index 498fef2..feef5ff 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #106 memprof version 1.0.0 ] {
+Extension [ <persistent> extension #107 memprof version 2.0.0 ] {
- Functions {
Function [ <internal:memprof> function memprof_enabled ] {
diff --git a/REFLECTION-PHP7 b/REFLECTION-PHP7
deleted file mode 100644
index feef5ff..0000000
--- a/REFLECTION-PHP7
+++ /dev/null
@@ -1,50 +0,0 @@
-Extension [ <persistent> extension #107 memprof version 2.0.0 ] {
-
- - Functions {
- Function [ <internal:memprof> function memprof_enabled ] {
-
- - Parameters [0] {
- }
- }
- Function [ <internal:memprof> function memprof_enable ] {
-
- - Parameters [0] {
- }
- }
- Function [ <internal:memprof> function memprof_disable ] {
-
- - Parameters [0] {
- }
- }
- Function [ <internal:memprof> function memprof_dump_array ] {
-
- - Parameters [0] {
- }
- }
- Function [ <internal:memprof> function memprof_dump_callgrind ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $handle ]
- }
- }
- Function [ <internal:memprof> function memprof_dump_pprof ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $handle ]
- }
- }
- Function [ <internal:memprof> function memory_get_peak_usage ] {
-
- - Parameters [1] {
- Parameter #0 [ <optional> $real ]
- }
- }
- Function [ <internal:memprof> function memory_get_usage ] {
-
- - Parameters [1] {
- Parameter #0 [ <optional> $real ]
- }
- }
- }
-}
-
diff --git a/php-pecl-memprof-php7.spec b/php-pecl-memprof-php7.spec
deleted file mode 100644
index 8ab7868..0000000
--- a/php-pecl-memprof-php7.spec
+++ /dev/null
@@ -1,251 +0,0 @@
-# remirepo spec file for php-pecl-memprof
-# With SCL compatibility, from Fedora:
-#
-# Fedora spec file for php-pecl-memprof
-#
-# Copyright (c) 2013-2017 Remi Collet
-# License: CC-BY-SA
-# http://creativecommons.org/licenses/by-sa/4.0/
-#
-# Please, preserve the changelog entries
-#
-%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
-%scl_package php-pecl-memprof
-%endif
-
-# ZTS build is broken
-# https://github.com/arnaud-lb/php-memory-profiler/pull/7
-%global with_zts 0
-%global pecl_name memprof
-%global ini_name 40-%{pecl_name}.ini
-
-Summary: Memory usage profiler
-Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 2.0.0
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-License: BSD
-Group: Development/Languages
-URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-
-BuildRequires: %{?scl_prefix}php-devel > 7
-BuildRequires: %{?scl_prefix}php-pear
-BuildRequires: Judy-devel
-
-Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
-Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
-
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name} <= %{version}
-Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
-
-
-%description
-Memory usage profiler for PHP scripts.
-
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
-
-
-%prep
-%setup -q -c
-mv %{pecl_name}-%{version} NTS
-mv package2.xml package.xml
-
-# Don't install tests
-sed -e 's/role="test"/role="src"/' \
- %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
- -i package.xml
-
-cd NTS
-# https://github.com/arnaud-lb/php-memory-profiler/pull/13
-sed -e '/MEMPROF_VERSION/s/1.0.0/%{version}/' -i php_memprof.h
-
-# Sanity check, really often broken
-extver=$(sed -n '/#define MEMPROF_VERSION/{s/.* "//;s/".*$//;p}' php_memprof.h)
-if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
- : Error: Upstream extension version is ${extver}, expecting %{version}%{?prever:-%{prever}}.
- exit 1
-fi
-cd ..
-
-%if %{with_zts}
-# Duplicate source tree for NTS / ZTS build
-cp -pr NTS ZTS
-%endif
-
-# Create configuration file
-cat > %{ini_name} << 'EOF'
-; Enable %{pecl_name} extension module
-extension=%{pecl_name}.so
-EOF
-
-
-%build
-%{?dtsenable}
-
-cd NTS
-%{_bindir}/phpize
-%configure \
- --with-libdir=%{_lib} \
- --with-php-config=%{_bindir}/php-config
-
-make %{?_smp_mflags}
-
-%if %{with_zts}
-cd ../ZTS
-%{_bindir}/zts-phpize
-%configure \
- --with-libdir=%{_lib} \
- --with-php-config=%{_bindir}/zts-php-config
-
-make %{?_smp_mflags}
-%endif
-
-
-%install
-%{?dtsenable}
-
-make -C NTS install INSTALL_ROOT=%{buildroot}
-
-# install config file
-install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
-
-# Install XML package description
-install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
-
-%if %{with_zts}
-make -C ZTS install INSTALL_ROOT=%{buildroot}
-
-install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
-%endif
-
-# Documentation
-for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
-done
-
-
-
-%if 0%{?fedora} < 24
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
-%check
-: Minimal load test for NTS extension
-%{_bindir}/php --no-php-ini \
- --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
-
-%if %{with_zts}
-: Minimal load test for ZTS extension
-%{__ztsphp} --no-php-ini \
- --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
-%endif
-
-
-%files
-%{?_licensedir:%license NTS/LICENSE}
-%doc %{pecl_docdir}/%{pecl_name}
-%{pecl_xmldir}/%{name}.xml
-
-%config(noreplace) %{php_inidir}/%{ini_name}
-%{php_extdir}/%{pecl_name}.so
-
-%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{ini_name}
-%{php_ztsextdir}/%{pecl_name}.so
-%endif
-
-
-%changelog
-* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 2.0.0-3
-- rebuild for PHP 7.2.0beta1 new API
-
-* Sun Feb 5 2017 Remi Collet <remi@fedoraproject.org> - 2.0.0-2
-- use package2.xml for correct registration
-
-* Sat Jan 28 2017 Remi Collet <remi@fedoraproject.org> - 2.0.0-1
-- update to 2.0.0 for PHP 7+
-- open https://github.com/arnaud-lb/php-memory-profiler/pull/13
- fix version and use normalized macro name
-- open https://github.com/arnaud-lb/php-memory-profiler/issues/14
- usage clarification
-
-* Wed Mar 9 2016 Remi Collet <remi@fedoraproject.org> - 1.0.0-6
-- adapt for F24
-
-* Tue Jun 23 2015 Remi Collet <rcollet@redhat.com> - 1.0.0-6
-- allow build against rh-php56 (as more-php56)
-- drop runtime dependency on pear, new scriptlets
-
-* Wed Dec 24 2014 Remi Collet <remi@fedoraproject.org> - 1.0.0-5.1
-- Fedora 21 SCL mass rebuild
-
-* Mon Aug 25 2014 Remi Collet <rcollet@redhat.com> - 1.0.0-5
-- improve SCL build
-
-* Thu Apr 10 2014 Remi Collet <remi@fedoraproject.org> - 1.0.0-4
-- add numerical prefix to extension configuration file
-
-* Tue Oct 22 2013 Remi Collet <remi@fedoraproject.org> - 1.0.0-3
-- install doc in pecl doc_dir
-
-* Fri Oct 11 2013 Remi Collet <rcollet@redhat.com> - 1.0.0-2
-- allow SCL build
-
-* Sun Oct 6 2013 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
-- initial package, version 1.0.0 (stable)
-- open https://github.com/arnaud-lb/php-memory-profiler/pull/6
-- open https://github.com/arnaud-lb/php-memory-profiler/pull/7
diff --git a/php-pecl-memprof.spec b/php-pecl-memprof.spec
index 4d2a294..5f9fda2 100644
--- a/php-pecl-memprof.spec
+++ b/php-pecl-memprof.spec
@@ -9,41 +9,30 @@
#
# Please, preserve the changelog entries
#
+
+# we don't want -z defs linker flag
+%undefine _strict_symbol_defs_build
+
%if 0%{?scl:1}
-%if "%{scl}" == "rh-php56"
-%global sub_prefix more-php56-
-%else
%global sub_prefix %{scl_prefix}
-%endif
+%scl_package php-pecl-memprof
%endif
-%{?scl: %scl_package php-pecl-memprof}
-
# ZTS build is broken
# https://github.com/arnaud-lb/php-memory-profiler/pull/7
%global with_zts 0
%global pecl_name memprof
-%if "%{php_version}" < "5.6"
-%global ini_name %{pecl_name}.ini
-%else
%global ini_name 40-%{pecl_name}.ini
-%endif
Summary: Memory usage profiler
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.0.0
-Release: 7%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 2.0.0
+Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
-Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-# https://github.com/arnaud-lb/php-memory-profiler/pull/6
-Source1: https://raw.github.com/arnaud-lb/php-memory-profiler/master/LICENSE
-Source2: https://raw.github.com/arnaud-lb/php-memory-profiler/master/README.md
-
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: %{?scl_prefix}php-devel > 5.3
+BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: Judy-devel
@@ -55,8 +44,10 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+%if "%{?scl_prefix}" != "%{?sub_prefix}"
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+%endif
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
@@ -64,17 +55,19 @@ Obsoletes: php53-pecl-%{pecl_name} <= %{version}
Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
Obsoletes: php54-pecl-%{pecl_name} <= %{version}
Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "5.5"
Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "5.6"
Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.0"
Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.2"
+Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -94,11 +87,16 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -q -c
mv %{pecl_name}-%{version} NTS
+mv package2.xml package.xml
-cd NTS
-cp %{SOURCE1} %{SOURCE2} .
+# Don't install tests
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
-sed -e 's:/lib:/$PHP_LIBDIR:' -i config.m4
+cd NTS
+# https://github.com/arnaud-lb/php-memory-profiler/pull/13
+sed -e '/MEMPROF_VERSION/s/1.0.0/%{version}/' -i php_memprof.h
# Sanity check, really often broken
extver=$(sed -n '/#define MEMPROF_VERSION/{s/.* "//;s/".*$//;p}' php_memprof.h)
@@ -121,6 +119,8 @@ EOF
%build
+%{?dtsenable}
+
cd NTS
%{_bindir}/phpize
%configure \
@@ -141,7 +141,7 @@ make %{?_smp_mflags}
%install
-rm -rf %{buildroot}
+%{?dtsenable}
make -C NTS install INSTALL_ROOT=%{buildroot}
@@ -158,11 +158,13 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Documentation
-%{!?_licensedir:install -Dpm 644 LICENSE %{buildroot}%{pecl_docdir}/%{pecl_name}/LICENSE}
-install -Dpm 644 NTS/README.md %{buildroot}%{pecl_docdir}/%{pecl_name}/README.md
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
-%if 0%{?fedora} < 24
+
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -196,12 +198,7 @@ fi
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{?_licensedir:%license NTS/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -216,6 +213,19 @@ rm -rf %{buildroot}
%changelog
+* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 2.0.0-3
+- rebuild for PHP 7.2.0beta1 new API
+
+* Sun Feb 5 2017 Remi Collet <remi@fedoraproject.org> - 2.0.0-2
+- use package2.xml for correct registration
+
+* Sat Jan 28 2017 Remi Collet <remi@fedoraproject.org> - 2.0.0-1
+- update to 2.0.0 for PHP 7+
+- open https://github.com/arnaud-lb/php-memory-profiler/pull/13
+ fix version and use normalized macro name
+- open https://github.com/arnaud-lb/php-memory-profiler/issues/14
+ usage clarification
+
* Wed Mar 9 2016 Remi Collet <remi@fedoraproject.org> - 1.0.0-6
- adapt for F24