summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-09 11:42:18 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-09 11:42:18 +0100
commitc55d9aca0aa9d44a494cc99adada3fbe88c9c5cb (patch)
treec36bfe6421233d918dc155d6d9bd1d759cfb2ec1
parent06f0096eeee47aaaf99a93f27322187012f0daeb (diff)
php-pecl-memprof: F24
-rw-r--r--php-pecl-memprof.spec23
1 files changed, 15 insertions, 8 deletions
diff --git a/php-pecl-memprof.spec b/php-pecl-memprof.spec
index 33de8ca..87319c1 100644
--- a/php-pecl-memprof.spec
+++ b/php-pecl-memprof.spec
@@ -18,8 +18,6 @@
%endif
%{?scl: %scl_package php-pecl-memprof}
-%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
-%{!?__pecl: %global __pecl %{_bindir}/pecl}
# ZTS build is broken
# https://github.com/arnaud-lb/php-memory-profiler/pull/7
@@ -34,7 +32,7 @@
Summary: Memory usage profiler
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 1.0.0
-Release: 6%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 7%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -53,10 +51,12 @@ Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
@@ -88,6 +88,8 @@ Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
%description
Memory usage profiler for PHP scripts.
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
%prep
%setup -q -c
@@ -156,10 +158,11 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Documentation
-install -Dpm 644 NTS/LICENSE %{buildroot}%{pecl_docdir}/%{pecl_name}/LICENSE
+%{!?_licensedir:install -Dpm 644 LICENSE %{buildroot}%{pecl_docdir}/%{pecl_name}/LICENSE}
install -Dpm 644 NTS/README.md %{buildroot}%{pecl_docdir}/%{pecl_name}/README.md
+%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -176,6 +179,7 @@ fi
if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
+%endif
%check
@@ -212,6 +216,9 @@ rm -rf %{buildroot}
%changelog
+* Wed Mar 9 2016 Remi Collet <remi@fedoraproject.org> - 1.0.0-6
+- adapt for F24
+
* Tue Jun 23 2015 Remi Collet <rcollet@redhat.com> - 1.0.0-6
- allow build against rh-php56 (as more-php56)
- drop runtime dependency on pear, new scriptlets
@@ -234,4 +241,4 @@ rm -rf %{buildroot}
* Sun Oct 6 2013 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
- initial package, version 1.0.0 (stable)
- open https://github.com/arnaud-lb/php-memory-profiler/pull/6
-- open https://github.com/arnaud-lb/php-memory-profiler/pull/7 \ No newline at end of file
+- open https://github.com/arnaud-lb/php-memory-profiler/pull/7