summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-11-18 15:39:21 +0100
committerRemi Collet <remi@remirepo.net>2020-11-18 15:39:21 +0100
commita13e318e07d74457b008d407c0b3eef2d2b88b6a (patch)
treef647eadf7754583741e43345147e8b72511e2830
parent22ec5924ba2abd32720bc97b91a9c2c007badd60 (diff)
update to 2.1.1
open https://github.com/arnaud-lb/php-memory-profiler/pull/43 raise PHP minimal version to 7.1 and add tests to archive
-rw-r--r--PHPINFO2
-rw-r--r--README.md264
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-memprof.spec34
4 files changed, 13 insertions, 289 deletions
diff --git a/PHPINFO b/PHPINFO
index bab398e..a1bdf92 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,4 @@
memprof
memprof support => enabled
-memprof version => 2.1.0
+memprof version => 2.1.1
diff --git a/README.md b/README.md
deleted file mode 100644
index 2d5a721..0000000
--- a/README.md
+++ /dev/null
@@ -1,264 +0,0 @@
-# php-memprof
-
-php-memprof profiles memory usage of PHP scripts, and especially can tell which
-function has allocated every single byte of memory currently allocated.
-
-This is different from measuring the memory usage before and after a
-function call:
-
-``` php
-<?php
-
-// script 1
-
-function a() {
- $data = file_get_contents("huge-file");
-}
-
-a();
-
-$profile = memprof_dump_array();
-
-```
-
-In script 1, a before/after approach would designate file_get_contents() as huge
-memory consumer, while the memory it allocates is actually freed quickly after
-it returns. When dumping the memory usage after a() returns, the memprof
-approach would show that file_get_contents() is a small memory consumer since
-the memory it allocated has been freed at the time memprof_dump_array() is
-called.
-
-
-``` php
-<?php
-
-// script 2
-
-function a() {
- global $cache;
- $cache = file_get_contents("huge-file");
-}
-
-a();
-
-$profile = memprof_dump_array();
-```
-
-In script 2, the allocated memory remains allocated after file_get_contents()
-and a() return, and when memprof_dump_array() is called. This time a() and
-file_get_contents() are shown as huge memory consumers.
-
-## How it works
-
-See [INTERNALS.md][7]
-
-## Dependencies
-
- * [Judy Library][3] (e.g. libjudy-dev or judy package)
- * C Library with [malloc hooks][1] (optional; allows to track persistent allocations too)
-
-## Install
-
-### Using PECL
-
- pecl install memprof
-
-### Manually
-
-Download the source and run the following commands in the source directory:
-
- phpize
- ./configure
- make
- make install
-
-## Loading the extension
-
-The extension can be loaded on the command line, just for one script:
-
- php -dextension=memprof.so script.php
-
-Or permanently, in php.ini:
-
- extension=memprof.so
-
-## Usage
-
-Memprof can be enabled during script execution by calling ``memprof_enable()``.
-
-Then the memory usage can be dumped by calling one of the ``memprof_dump_``
-functions. Both tell which functions allocated all the currently allocated
-memory.
-
-Example:
-
-```
-<?php
-
-if (function_exists('memprof_enable')) {
- memprof_enable();
-}
-
-do_some_work();
-
-if (function_exists('memprof_enable')) {
- memprof_dump_callgrind(fopen("/tmp/callgrind.out", "w"));
-}
-```
-
-### memprof_enabled()
-
-Returns whether memprof is enabled.
-
-### memprof_enable()
-
-Enables memprof and start tracking memory allocations. Note: any memory
-allocation made before this call is ignored.
-
-### memprof_disable()
-
-Disables memprof and forget previous allocations.
-
-### memprof_dump_callgrind(resource $stream)
-
-The memprof_dump_callgrind function dumps the current memory usage to a stream
-in callgrind format. The file can then be read with tools such as
-[KCacheGrind][2] or [QCacheGrind][6].
-
-``` php
-<?php
-memprof_dump_callgrind(fopen("output", "w"));
-```
-
-Here is a KcacheGrind screenshot:
-
-![KCacheGrind screenshot](http://img820.imageshack.us/img820/5530/screenshot3kve.png)
-
-### memprof_dump_pprof(resource $stream)
-
-The memprof_dump_pprof function dumps the current memory usage to a stream in
-[pprof][4] format.
-
-``` php
-<?php
-memprof_dump_pprof(fopen("profile.heap", "w"));
-```
-
-The file can be visualized using [google-perftools][5]'s [``pprof``][4] tool.
-
-Display annotated call-graph in web browser or in ``gv``:
-
-```
-$ pprof --web profile.heap
-$ # or:
-$ pprof --gv profile.heap
-```
-
-![pprof call-graph screenshot](http://img707.imageshack.us/img707/7697/screenshot3go.png)
-
-Output one line per function, sorted by own memory usage:
-
-```
-$ pprof --text profile.heap
-```
-
-### memprof_dump_array()
-
-``` php
-<?php
-$dump = memprof_dump_array();
-```
-
-The dump exposes the following information:
-
- * Inclusive and exclusive memory usage of functions (counting only the memory
- that has is still in use when memprof_dump_array is called)
- * Inclusive and exclusive blocks count of functions (number of allocated;
- counting only the blocks that are still in use when memprof_dump_array is
- called)
- * The data is presented in call stacks. This way, if a function is called from
- multiple places, it is possible to see which call path caused it to leak the
- most memory
-
-Example output:
-
- Array
- (
- [memory_size] => 11578
- [blocks_count] => 236
- [memory_size_inclusive] => 10497691
- [blocks_count_inclusive] => 244
- [calls] => 1
- [called_functions] => Array
- (
- [main] => Array
- (
- [memory_size] => 288
- [blocks_count] => 3
- [memory_size_inclusive] => 10486113
- [blocks_count_inclusive] => 8
- [calls] => 1
- [called_functions] => Array
- (
- [a] => Array
- (
- [memory_size] => 4
- [blocks_count] => 1
- [memory_size_inclusive] => 10485825
- [blocks_count_inclusive] => 5
- [calls] => 1
- [called_functions] => Array
- (
- [b] => Array
- (
- [memory_size] => 10485821
- [blocks_count] => 4
- [memory_size_inclusive] => 10485821
- [blocks_count_inclusive] => 4
- [calls] => 1
- [called_functions] => Array
- (
- [str_repeat] => Array
- (
- [memory_size] => 0
- [blocks_count] => 0
- [memory_size_inclusive] => 0
- [blocks_count_inclusive] => 0
- [calls] => 1
- [called_functions] => Array
- (
- )
- )
- )
- )
- )
- )
- [memprof_dump_array] => Array
- (
- [memory_size] => 0
- [blocks_count] => 0
- [memory_size_inclusive] => 0
- [blocks_count_inclusive] => 0
- [calls] => 1
- [called_functions] => Array
- (
- )
- )
- )
- )
- )
- )
-
-## Todo
-
- * Support for tracking persistent (non-zend-alloc) allocations when libc
- doesn't have malloc hooks
-
-[1]: https://www.gnu.org/software/libc/manual/html_node/Hooks-for-Malloc.html#Hooks-for-Malloc
-[2]: http://kcachegrind.sourceforge.net/html/Home.html
-[3]: http://judy.sourceforge.net/index.html
-[4]: https://google-perftools.googlecode.com/svn/trunk/doc/heapprofile.html
-[5]: https://google-perftools.googlecode.com/
-[6]: https://www.google.com/search?q=qcachegrind
-[7]: https://github.com/arnaud-lb/php-memory-profiler/blob/master/INTERNALS.md
-
diff --git a/REFLECTION b/REFLECTION
index b6209b3..1c07c39 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #116 memprof version 2.1.0 ] {
+Extension [ <persistent> extension #117 memprof version 2.1.1 ] {
- Functions {
Function [ <internal:memprof> function memprof_enabled ] {
diff --git a/php-pecl-memprof.spec b/php-pecl-memprof.spec
index ea49b31..089cc7c 100644
--- a/php-pecl-memprof.spec
+++ b/php-pecl-memprof.spec
@@ -26,14 +26,14 @@
Summary: Memory usage profiler
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 2.1.0
+Version: 2.1.1
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel > 7
+BuildRequires: %{?scl_prefix}php-devel >= 7.1
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: Judy-devel
@@ -50,33 +50,16 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{rele
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%endif
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name} <= %{version}
-Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.3"
Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "8.0"
+Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -220,6 +203,11 @@ fi
%changelog
+* Wed Nov 18 2020 Remi Collet <remi@remirepo.net> - 2.1.1-1
+- update to 2.1.1
+- open https://github.com/arnaud-lb/php-memory-profiler/pull/43
+ raise PHP minimal version to 7.1 and add tests to archive
+
* Sun Jul 5 2020 Remi Collet <remi@remirepo.net> - 2.1.0-1
- update to 2.1.0