summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-01-02 14:40:20 +0100
committerRemi Collet <fedora@famillecollet.com>2014-01-02 14:40:20 +0100
commit80eded66d5dd579346e34f522170869a3d0c0088 (patch)
treefb549a6b90cf3d2a4cf28e7f06f72585a7ee94ea
parent3bc74d470bf734d18ff7cbe5285b1349724414da (diff)
php-pecl-memprof: switch to our spec
-rw-r--r--php-pecl-memprof-dev.spec178
-rw-r--r--php-pecl-memprof.spec30
2 files changed, 19 insertions, 189 deletions
diff --git a/php-pecl-memprof-dev.spec b/php-pecl-memprof-dev.spec
deleted file mode 100644
index 9ea7865..0000000
--- a/php-pecl-memprof-dev.spec
+++ /dev/null
@@ -1,178 +0,0 @@
-# spec file for php-pecl-memprof
-#
-# Copyright (c) 2013-2014 Remi Collet
-# License: CC-BY-SA
-# http://creativecommons.org/licenses/by-sa/3.0/
-#
-# Please, preserve the changelog entries
-#
-%{?scl:%scl_package php-pecl-memprof}
-%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
-%{!?__pecl: %global __pecl %{_bindir}/pecl}
-
-# ZTS build is broken
-# https://github.com/arnaud-lb/php-memory-profiler/pull/7
-%global with_zts 0
-%global pecl_name memprof
-
-Summary: Memory usage profiler
-Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.0.0
-Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
-License: BSD
-Group: Development/Languages
-URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-
-# https://github.com/arnaud-lb/php-memory-profiler/pull/6
-Source1: https://raw.github.com/arnaud-lb/php-memory-profiler/master/LICENSE
-Source2: https://raw.github.com/arnaud-lb/php-memory-profiler/master/README.md
-
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: %{?scl_prefix}php-devel > 5.3
-BuildRequires: %{?scl_prefix}php-pear
-BuildRequires: Judy-devel
-
-Requires(post): %{__pecl}
-Requires(postun): %{__pecl}
-Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
-Requires: %{?scl_prefix}php(api) = %{php_core_api}
-
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-
-%if 0%{?fedora} < 20
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
-
-
-%description
-Memory usage profiler for PHP scripts.
-
-
-%prep
-%setup -q -c
-mv %{pecl_name}-%{version} NTS
-cp %{SOURCE1} %{SOURCE2} .
-
-cd NTS
-sed -e 's:/lib:/$PHP_LIBDIR:' -i config.m4
-
-# Sanity check, really often broken
-extver=$(sed -n '/#define MEMPROF_VERSION/{s/.* "//;s/".*$//;p}' php_memprof.h)
-if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
- : Error: Upstream extension version is ${extver}, expecting %{version}%{?prever:-%{prever}}.
- exit 1
-fi
-cd ..
-
-%if %{with_zts}
-# Duplicate source tree for NTS / ZTS build
-cp -pr NTS ZTS
-%endif
-
-# Create configuration file
-cat > %{pecl_name}.ini << 'EOF'
-; Enable %{pecl_name} extension module
-extension=%{pecl_name}.so
-EOF
-
-
-%build
-cd NTS
-%{_bindir}/phpize
-%configure \
- --with-libdir=%{_lib} \
- --with-php-config=%{_bindir}/php-config
-
-make %{?_smp_mflags}
-
-%if %{with_zts}
-cd ../ZTS
-%{_bindir}/zts-phpize
-%configure \
- --with-libdir=%{_lib} \
- --with-php-config=%{_bindir}/zts-php-config
-
-make %{?_smp_mflags}
-%endif
-
-
-%install
-rm -rf %{buildroot}
-
-make -C NTS install INSTALL_ROOT=%{buildroot}
-
-# install config file
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_inidir}/%{pecl_name}.ini
-
-# Install XML package description
-install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
-
-%if %{with_zts}
-make -C ZTS install INSTALL_ROOT=%{buildroot}
-
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
-%endif
-
-# Documentation
-install -Dpm 644 LICENSE %{buildroot}%{pecl_docdir}/%{pecl_name}/LICENSE
-install -Dpm 644 README.md %{buildroot}%{pecl_docdir}/%{pecl_name}/README.md
-
-
-%post
-%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-
-
-%postun
-if [ $1 -eq 0 ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-
-
-%check
-: Minimal load test for NTS extension
-%{_bindir}/php --no-php-ini \
- --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
-
-%if %{with_zts}
-: Minimal load test for ZTS extension
-%{__ztsphp} --no-php-ini \
- --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
-%endif
-
-
-%clean
-rm -rf %{buildroot}
-
-
-%files
-%defattr(-,root,root,-)
-%doc %{pecl_docdir}/%{pecl_name}
-%{pecl_xmldir}/%{name}.xml
-%config(noreplace) %{php_inidir}/%{pecl_name}.ini
-%{php_extdir}/%{pecl_name}.so
-
-%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
-%{php_ztsextdir}/%{pecl_name}.so
-%endif
-
-
-%changelog
-* Tue Oct 22 2013 Remi Collet <remi@fedoraproject.org> - 1.0.0-3
-- install doc in pecl doc_dir
-
-* Fri Oct 11 2013 Remi Collet <rcollet@redhat.com> - 1.0.0-2
-- allow SCL build
-
-* Sun Oct 6 2013 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
-- initial package, version 1.0.0 (stable)
-- open https://github.com/arnaud-lb/php-memory-profiler/pull/6
-- open https://github.com/arnaud-lb/php-memory-profiler/pull/7
diff --git a/php-pecl-memprof.spec b/php-pecl-memprof.spec
index 4a0c728..9ea7865 100644
--- a/php-pecl-memprof.spec
+++ b/php-pecl-memprof.spec
@@ -6,6 +6,7 @@
#
# Please, preserve the changelog entries
#
+%{?scl:%scl_package php-pecl-memprof}
%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
%{!?__pecl: %global __pecl %{_bindir}/pecl}
@@ -15,9 +16,9 @@
%global pecl_name memprof
Summary: Memory usage profiler
-Name: php-pecl-%{pecl_name}
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 1.0.0
-Release: 3%{?dist}
+Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -27,19 +28,20 @@ Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
Source1: https://raw.github.com/arnaud-lb/php-memory-profiler/master/LICENSE
Source2: https://raw.github.com/arnaud-lb/php-memory-profiler/master/README.md
-BuildRequires: php-devel > 5.3
-BuildRequires: php-pear
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRequires: %{?scl_prefix}php-devel > 5.3
+BuildRequires: %{?scl_prefix}php-pear
BuildRequires: Judy-devel
Requires(post): %{__pecl}
Requires(postun): %{__pecl}
-Requires: php(zend-abi) = %{php_zend_api}
-Requires: php(api) = %{php_core_api}
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
-Provides: php-%{pecl_name} = %{version}
-Provides: php-%{pecl_name}%{?_isa} = %{version}
-Provides: php-pecl(%{pecl_name}) = %{version}
-Provides: php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
%if 0%{?fedora} < 20
# Filter shared private
@@ -101,6 +103,8 @@ make %{?_smp_mflags}
%install
+rm -rf %{buildroot}
+
make -C NTS install INSTALL_ROOT=%{buildroot}
# install config file
@@ -144,7 +148,12 @@ fi
%endif
+%clean
+rm -rf %{buildroot}
+
+
%files
+%defattr(-,root,root,-)
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
%config(noreplace) %{php_inidir}/%{pecl_name}.ini
@@ -158,7 +167,6 @@ fi
%changelog
* Tue Oct 22 2013 Remi Collet <remi@fedoraproject.org> - 1.0.0-3
-- cleanups for review
- install doc in pecl doc_dir
* Fri Oct 11 2013 Remi Collet <rcollet@redhat.com> - 1.0.0-2