summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-03-30 08:37:49 +0200
committerRemi Collet <remi@remirepo.net>2021-03-30 08:37:49 +0200
commit1afeb875434ce18ccbf11dbba0814d68587376c6 (patch)
tree9249e990d55465efd3745946e7a46570eb2ec4b5
parenta3e5a5a55d313a3b87f5f83e1b017f143a6d0814 (diff)
update to 3.0.0
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION13
-rw-r--r--php-pecl-memprof.spec21
3 files changed, 26 insertions, 14 deletions
diff --git a/PHPINFO b/PHPINFO
index 7ade6e2..b7c6b5b 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,8 @@
memprof
memprof support => enabled
-memprof version => 2.1.2
+memprof version => 3.0.0
+memprof native malloc support => Yes
+
+Directive => Local Value => Master Value
+memprof.output_dir => /tmp => /tmp
diff --git a/REFLECTION b/REFLECTION
index 354a1be..c05f402 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,10 @@
-Extension [ <persistent> extension #117 memprof version 2.1.2 ] {
+Extension [ <persistent> extension #119 memprof version 3.0.0 ] {
+
+ - INI {
+ Entry [ memprof.output_dir <ALL> ]
+ Current = '/tmp'
+ }
+ }
- Functions {
Function [ <internal:memprof> function memprof_enabled ] {
@@ -6,6 +12,11 @@ Extension [ <persistent> extension #117 memprof version 2.1.2 ] {
- Parameters [0] {
}
}
+ Function [ <internal:memprof> function memprof_enabled_flags ] {
+
+ - Parameters [0] {
+ }
+ }
Function [ <internal:memprof> function memprof_enable ] {
- Parameters [0] {
diff --git a/php-pecl-memprof.spec b/php-pecl-memprof.spec
index f68964d..f03cd5d 100644
--- a/php-pecl-memprof.spec
+++ b/php-pecl-memprof.spec
@@ -3,7 +3,7 @@
#
# Fedora spec file for php-pecl-memprof
#
-# Copyright (c) 2013-2020 Remi Collet
+# Copyright (c) 2013-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -33,12 +33,13 @@
Summary: Memory usage profiler
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 2.1.2
+Version: 3.0.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.1
BuildRequires: %{?scl_prefix}php-pear
@@ -52,10 +53,6 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
@@ -70,12 +67,6 @@ Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
%endif
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
-
%description
Memprof is a fast and accurate memory profiler that can be used
@@ -111,6 +102,9 @@ cp -pr NTS ZTS
cat > %{ini_name} << 'EOF'
; Enable %{pecl_name} extension module
extension=%{pecl_name}.so
+
+; Configuration
+;memprof.output_dir = '/tmp'
EOF
@@ -229,6 +223,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Tue Mar 30 2021 Remi Collet <remi@remirepo.net> - 3.0.0-1
+- update to 3.0.0
+
* Thu Nov 19 2020 Remi Collet <remi@remirepo.net> - 2.1.2-1
- update to 2.1.2 (no change)
- run upstream test suite during the build