summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-memcached.spec13
3 files changed, 10 insertions, 7 deletions
diff --git a/PHPINFO b/PHPINFO
index 89ed0a2..70f19f9 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
memcached
memcached support => enabled
-Version => 3.3.0RC1
+Version => 3.3.0
libmemcached-awesome version => 1.1.4
SASL support => yes
Session support => yes
diff --git a/REFLECTION b/REFLECTION
index 80a5679..58da66f 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #112 memcached version 3.3.0RC1 ] {
+Extension [ <persistent> extension #118 memcached version 3.3.0 ] {
- Dependencies {
Dependency [ session (Required) ]
diff --git a/php-pecl-memcached.spec b/php-pecl-memcached.spec
index d31bf78..7b1a83f 100644
--- a/php-pecl-memcached.spec
+++ b/php-pecl-memcached.spec
@@ -29,7 +29,7 @@
%global ini_name 50-%{pecl_name}.ini
%global upstream_version 3.3.0
-%global upstream_prever RC1
+#global upstream_prever RC1
# upstream use dev => alpha => beta => RC
# make RPM happy DEV => alpha => beta => rc
%global upstream_lower %(echo %{upstream_prever} | tr '[:upper:]' '[:lower:]')
@@ -75,6 +75,7 @@ BuildRequires: %{?vendeur:%{vendeur}-}libmemcached-awesome-devel >= 1.1
Requires: libevent%{?_isa}
Requires: fastlz%{?_isa}
Requires: zlib%{?_isa}
+Requires: libzstd%{?_isa}
Requires: cyrus-sasl-lib%{?_isa}
Requires: %{?vendeur:%{vendeur}-}libmemcached-awesome%{?_isa}
%else
@@ -98,9 +99,8 @@ Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
%if %{move_to_opt}
-%{?filter_requires_in: %filter_requires_in %{_libdir}/.*\.so$}
+%global __requires_exclude_from ^%{_libdir}/.*$
%endif
-%{?filter_setup}
%description
@@ -268,12 +268,12 @@ rm tests/memcachedserver6.phpt
%endif
: Launch the Memcached service
-port=$(%{__php} -r 'echo 10000 + PHP_MAJOR_VERSION*100 + PHP_MINOR_VERSION*10 + PHP_INT_SIZE + 0%{?scl:1};')
+port=$(%{__php} -r 'echo 10000 + PHP_MAJOR_VERSION*1000 + PHP_MINOR_VERSION*100 + PHP_INT_SIZE + 0%{?scl:10} + %{?fedora}%{?rhel};')
memcached -p $port -U $port -d -P $PWD/memcached.pid
sed -e "s/11211/$port/" -i tests/*
: Port for MemcachedServer
-port=$(%{__php} -r 'echo 11000 + PHP_MAJOR_VERSION*100 + PHP_MINOR_VERSION*10 + PHP_INT_SIZE + 0%{?scl:1};')
+port=$(%{__php} -r 'echo 12000 + PHP_MAJOR_VERSION*1000 + PHP_MINOR_VERSION*100 + PHP_INT_SIZE + 0%{?scl:10} + %{?fedora}%{?rhel};')
sed -e "s/3434/$port/" -i tests/*
: Run the upstream test Suite for NTS extension
@@ -307,6 +307,9 @@ exit $ret
%changelog
+* Fri Oct 18 2024 Remi Collet <remi@remirepo.net> - 3.3.0-1
+- update to 3.3.0
+
* Fri Oct 4 2024 Remi Collet <remi@remirepo.net> - 3.3.0~RC1-1
- update to 3.3.0RC1
- enable zstd compression support