summaryrefslogtreecommitdiffstats
path: root/php-pecl-memcached.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-10-08 14:01:28 +0200
committerRemi Collet <remi@remirepo.net>2020-10-08 14:01:28 +0200
commitf9a74f77ea1bdce93dfe19fae9edd141bfe23b9b (patch)
tree0149f7f721743fa3ba2350b698ab39383e3d3870 /php-pecl-memcached.spec
parentb74826b326fdf9ad4a4ccdc85256f80c86dc405b (diff)
more fix for 8
Diffstat (limited to 'php-pecl-memcached.spec')
-rw-r--r--php-pecl-memcached.spec14
1 files changed, 5 insertions, 9 deletions
diff --git a/php-pecl-memcached.spec b/php-pecl-memcached.spec
index 3061fcd..288a3a2 100644
--- a/php-pecl-memcached.spec
+++ b/php-pecl-memcached.spec
@@ -31,7 +31,7 @@
Summary: Extension to work with the Memcached caching daemon
Name: %{?sub_prefix}php-pecl-memcached
Version: 3.1.5
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: https://pecl.php.net/package/%{pecl_name}
@@ -302,9 +302,6 @@ OPT="-n"
%endif
%if %{with_tests}
-# XFAIL and very slow so no value
-rm ?TS/tests/expire.phpt
-
ret=0
: Launch the Memcached service
@@ -314,29 +311,28 @@ sed -e "s/11211/$port/" -i ?TS/tests/*
: Run the upstream test Suite for NTS extension
pushd NTS
-rm tests/flush_buffers.phpt tests/touch_binary.phpt
TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="$OPT -d extension=$PWD/modules/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php --show-diff || ret=1
+%{__php} -n run-tests.php -x --show-diff || ret=1
popd
%if %{with_zts}
: Run the upstream test Suite for ZTS extension
pushd ZTS
-rm tests/flush_buffers.phpt tests/touch_binary.phpt
TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="$OPT -d extension=$PWD/modules/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php --show-diff || ret=1
+%{__ztsphp} -n run-tests.php -x --show-diff || ret=1
popd
%endif
# Cleanup
if [ -f memcached.pid ]; then
kill $(cat memcached.pid)
+ sleep 1
fi
exit $ret
@@ -358,7 +354,7 @@ exit $ret
%changelog
-* Thu Oct 8 2020 Remi Collet <remi@remirepo.net> - 3.1.5-2
+* Thu Oct 8 2020 Remi Collet <remi@remirepo.net> - 3.1.5-3
- add patches for PHP 8 from
https://github.com/php-memcached-dev/php-memcached/pull/461
https://github.com/php-memcached-dev/php-memcached/pull/463