summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-03 10:47:28 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-03 10:47:28 +0100
commitfd2b82ae963178973117f75c2fe87eb32757a370 (patch)
tree260348a593e0e2608775c1708e3b63ce4d6611f5
parent072d145521245754507f67cbed38e101e53f9cef (diff)
php-pecl-memcached: 3.0.0-dev
-rw-r--r--REFLECTION-PHP7116
-rw-r--r--php-pecl-memcached-dev.spec32
2 files changed, 77 insertions, 71 deletions
diff --git a/REFLECTION-PHP7 b/REFLECTION-PHP7
index 94f1b1a..65506bc 100644
--- a/REFLECTION-PHP7
+++ b/REFLECTION-PHP7
@@ -1,26 +1,33 @@
-Extension [ <persistent> extension #85 memcached version 2.2.1-dev ] {
+Extension [ <persistent> extension #85 memcached version 3.0.0-dev ] {
+
+ - Dependencies {
+ Dependency [ session (Required) ]
+ Dependency [ igbinary (Required) ]
+ Dependency [ msgpack (Required) ]
+ Dependency [ spl (Required) ]
+ }
- INI {
Entry [ memcached.sess_locking <ALL> ]
Current = '1'
}
- Entry [ memcached.sess_consistent_hash <ALL> ]
- Current = ''
- }
- Entry [ memcached.sess_binary <ALL> ]
- Current = ''
- }
- Entry [ memcached.sess_lock_wait <ALL> ]
- Current = '150000'
+ Entry [ memcached.sess_lock_wait_min <ALL> ]
+ Current = '0'
}
- Entry [ memcached.sess_lock_max_wait <ALL> ]
+ Entry [ memcached.sess_lock_wait_max <ALL> ]
Current = '0'
}
+ Entry [ memcached.sess_lock_retries <ALL> ]
+ Current = '5'
+ }
Entry [ memcached.sess_lock_expire <ALL> ]
Current = '0'
}
- Entry [ memcached.sess_prefix <ALL> ]
- Current = 'memc.sess.key.'
+ Entry [ memcached.sess_binary_protocol <ALL> ]
+ Current = '1'
+ }
+ Entry [ memcached.sess_consistent_hash <ALL> ]
+ Current = ''
}
Entry [ memcached.sess_number_of_replicas <ALL> ]
Current = '0'
@@ -28,8 +35,11 @@ Extension [ <persistent> extension #85 memcached version 2.2.1-dev ] {
Entry [ memcached.sess_randomize_replica_read <ALL> ]
Current = ''
}
- Entry [ memcached.sess_remove_failed <ALL> ]
- Current = '1'
+ Entry [ memcached.sess_remove_failed_servers <ALL> ]
+ Current = '0'
+ }
+ Entry [ memcached.sess_server_failure_limit <ALL> ]
+ Current = '0'
}
Entry [ memcached.sess_connect_timeout <ALL> ]
Current = '1000'
@@ -40,6 +50,18 @@ Extension [ <persistent> extension #85 memcached version 2.2.1-dev ] {
Entry [ memcached.sess_sasl_password <ALL> ]
Current = ''
}
+ Entry [ memcached.sess_prefix <ALL> ]
+ Current = 'memc.sess.key.'
+ }
+ Entry [ memcached.sess_persistent <ALL> ]
+ Current = '0'
+ }
+ Entry [ memcached.sess_lock_wait <ALL> ]
+ Current = 'not set'
+ }
+ Entry [ memcached.sess_lock_max_wait <ALL> ]
+ Current = 'not set'
+ }
Entry [ memcached.compression_type <ALL> ]
Current = 'fastlz'
}
@@ -52,23 +74,30 @@ Extension [ <persistent> extension #85 memcached version 2.2.1-dev ] {
Entry [ memcached.serializer <ALL> ]
Current = 'igbinary'
}
- Entry [ memcached.use_sasl <SYSTEM> ]
- Current = ''
- }
Entry [ memcached.store_retry_count <ALL> ]
Current = '2'
}
+ Entry [ memcached.default_consistent_hash <ALL> ]
+ Current = '0'
+ }
+ Entry [ memcached.default_binary_protocol <ALL> ]
+ Current = '0'
+ }
+ Entry [ memcached.default_connect_timeout <ALL> ]
+ Current = '0'
+ }
}
- Classes [2] {
Class [ <internal:memcached> class Memcached ] {
- - Constants [99] {
+ - Constants [101] {
Constant [ integer LIBMEMCACHED_VERSION_HEX ] { 16777240 }
Constant [ integer OPT_COMPRESSION ] { -1001 }
Constant [ integer OPT_COMPRESSION_TYPE ] { -1004 }
Constant [ integer OPT_PREFIX_KEY ] { -1002 }
Constant [ integer OPT_SERIALIZER ] { -1003 }
+ Constant [ integer OPT_USER_FLAGS ] { -1006 }
Constant [ integer OPT_STORE_RETRY_COUNT ] { -1005 }
Constant [ integer HAVE_IGBINARY ] { 1 }
Constant [ integer HAVE_JSON ] { 1 }
@@ -162,6 +191,7 @@ Extension [ <persistent> extension #85 memcached version 2.2.1-dev ] {
Constant [ integer COMPRESSION_FASTLZ ] { 2 }
Constant [ integer COMPRESSION_ZLIB ] { 1 }
Constant [ integer GET_PRESERVE_ORDER ] { 1 }
+ Constant [ integer GET_EXTENDED ] { 2 }
Constant [ boolean GET_ERROR_RETURN_VALUE ] { }
}
@@ -197,43 +227,35 @@ Extension [ <persistent> extension #85 memcached version 2.2.1-dev ] {
Method [ <internal:memcached> public method get ] {
- - Parameters [4] {
+ - Parameters [2] {
Parameter #0 [ <required> $key ]
Parameter #1 [ <optional> $cache_cb ]
- Parameter #2 [ <optional> &$cas_token ]
- Parameter #3 [ <optional> &$udf_flags ]
}
}
Method [ <internal:memcached> public method getByKey ] {
- - Parameters [5] {
+ - Parameters [3] {
Parameter #0 [ <required> $server_key ]
Parameter #1 [ <required> $key ]
Parameter #2 [ <optional> $cache_cb ]
- Parameter #3 [ <optional> &$cas_token ]
- Parameter #4 [ <optional> &$udf_flags ]
}
}
Method [ <internal:memcached> public method getMulti ] {
- - Parameters [4] {
+ - Parameters [2] {
Parameter #0 [ <required> array $keys ]
- Parameter #1 [ <optional> &$cas_tokens ]
- Parameter #2 [ <optional> $flags ]
- Parameter #3 [ <optional> &$udf_flags ]
+ Parameter #1 [ <optional> $get_flags ]
}
}
Method [ <internal:memcached> public method getMultiByKey ] {
- - Parameters [5] {
+ - Parameters [3] {
Parameter #0 [ <required> $server_key ]
Parameter #1 [ <required> array $keys ]
- Parameter #2 [ <optional> &$cas_tokens ]
- Parameter #3 [ <optional> $flags ]
- Parameter #4 [ <optional> &$udf_flags ]
+ Parameter #2 [ <optional> $get_flags ]
}
}
@@ -270,22 +292,20 @@ Extension [ <persistent> extension #85 memcached version 2.2.1-dev ] {
Method [ <internal:memcached> public method set ] {
- - Parameters [4] {
+ - Parameters [3] {
Parameter #0 [ <required> $key ]
Parameter #1 [ <required> $value ]
Parameter #2 [ <optional> $expiration ]
- Parameter #3 [ <optional> $udf_flags ]
}
}
Method [ <internal:memcached> public method setByKey ] {
- - Parameters [5] {
+ - Parameters [4] {
Parameter #0 [ <required> $server_key ]
Parameter #1 [ <required> $key ]
Parameter #2 [ <required> $value ]
Parameter #3 [ <optional> $expiration ]
- Parameter #4 [ <optional> $udf_flags ]
}
}
@@ -308,64 +328,58 @@ Extension [ <persistent> extension #85 memcached version 2.2.1-dev ] {
Method [ <internal:memcached> public method setMulti ] {
- - Parameters [3] {
+ - Parameters [2] {
Parameter #0 [ <required> array $items ]
Parameter #1 [ <optional> $expiration ]
- Parameter #2 [ <optional> $udf_flags ]
}
}
Method [ <internal:memcached> public method setMultiByKey ] {
- - Parameters [4] {
+ - Parameters [3] {
Parameter #0 [ <required> $server_key ]
Parameter #1 [ <required> array $items ]
Parameter #2 [ <optional> $expiration ]
- Parameter #3 [ <optional> $udf_flags ]
}
}
Method [ <internal:memcached> public method cas ] {
- - Parameters [5] {
+ - Parameters [4] {
Parameter #0 [ <required> $cas_token ]
Parameter #1 [ <required> $key ]
Parameter #2 [ <required> $value ]
Parameter #3 [ <optional> $expiration ]
- Parameter #4 [ <optional> $udf_flags ]
}
}
Method [ <internal:memcached> public method casByKey ] {
- - Parameters [6] {
+ - Parameters [5] {
Parameter #0 [ <required> $cas_token ]
Parameter #1 [ <required> $server_key ]
Parameter #2 [ <required> $key ]
Parameter #3 [ <required> $value ]
Parameter #4 [ <optional> $expiration ]
- Parameter #5 [ <optional> $udf_flags ]
}
}
Method [ <internal:memcached> public method add ] {
- - Parameters [4] {
+ - Parameters [3] {
Parameter #0 [ <required> $key ]
Parameter #1 [ <required> $value ]
Parameter #2 [ <optional> $expiration ]
- Parameter #3 [ <optional> $udf_flags ]
}
}
Method [ <internal:memcached> public method addByKey ] {
- - Parameters [5] {
+ - Parameters [4] {
Parameter #0 [ <required> $server_key ]
Parameter #1 [ <required> $key ]
Parameter #2 [ <required> $value ]
Parameter #3 [ <optional> $expiration ]
- Parameter #4 [ <optional> $udf_flags ]
}
}
@@ -409,22 +423,20 @@ Extension [ <persistent> extension #85 memcached version 2.2.1-dev ] {
Method [ <internal:memcached> public method replace ] {
- - Parameters [4] {
+ - Parameters [3] {
Parameter #0 [ <required> $key ]
Parameter #1 [ <required> $value ]
Parameter #2 [ <optional> $expiration ]
- Parameter #3 [ <optional> $udf_flags ]
}
}
Method [ <internal:memcached> public method replaceByKey ] {
- - Parameters [5] {
+ - Parameters [4] {
Parameter #0 [ <required> $server_key ]
Parameter #1 [ <required> $key ]
Parameter #2 [ <required> $value ]
Parameter #3 [ <optional> $expiration ]
- Parameter #4 [ <optional> $udf_flags ]
}
}
diff --git a/php-pecl-memcached-dev.spec b/php-pecl-memcached-dev.spec
index c0c08b0..146107f 100644
--- a/php-pecl-memcached-dev.spec
+++ b/php-pecl-memcached-dev.spec
@@ -28,13 +28,11 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
%global pecl_name memcached
-# https://github.com/rlerdorf/php-memcached/commits/php7
-%global gh_commit 3c79a97aeb6e8c946116c536831816a36eb4eb0f
+# https://github.com/php-memcached-dev/php-memcached/commits/php7
+%global gh_commit 6ace07da69a5ebc021e56a9d2f52cdc8897b4f23
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_date 20150628
-#global gh_owner php-memcached-dev
-# Temporarily use Rasmus fork
-%global gh_owner rlerdorf
+%global gh_date 20160217
+%global gh_owner php-memcached-dev
%global gh_project php-memcached
#global prever RC1
#global intver rc1
@@ -48,17 +46,14 @@
Summary: Extension to work with the Memcached caching daemon
Name: %{?sub_prefix}php-pecl-memcached
-Version: 2.2.1
-Release: 0.2.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 3.0.0
+Release: 0.1.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}%{?prever}-%{gh_short}.tar.gz
-# https://github.com/rlerdorf/php-memcached/pull/3
-Patch0: %{pecl_name}-pr3.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
# 5.2.10 required to HAVE_JSON enabled
BuildRequires: %{?scl_prefix}php-devel >= 5.2.10
@@ -156,7 +151,7 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -c -q
mv %{gh_project}-%{gh_commit} NTS
-sed -e '/PHP_MEMCACHED_VERSION/s/2.2.0/%{version}-dev/' -i NTS/php_memcached.h
+sed -e '/PHP_MEMCACHED_VERSION/s/3.0.0b1/%{version}-dev/' -i NTS/php_memcached.h
%{__php} -r '
$pkg = simplexml_load_file("NTS/package.xml");
$pkg->date = substr("%{gh_date}",0,4)."-".substr("%{gh_date}",4,2)."-".substr("%{gh_date}",6,2);
@@ -171,8 +166,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1 -b .pr3
-
%if %{with_fastlz}
rm -r fastlz
sed -e '/name=.fastlz/d' -i ../package.xml
@@ -324,9 +317,6 @@ ret=0
: Launch the Memcached service
memcached -p 11211 -U 11211 -d -P $PWD/memcached.pid
-rm ?TS/tests/experimental/serializer_json.phpt
-rm ?TS/tests/experimental/serializer_igbinary.phpt
-
: Run the upstream test Suite for NTS extension
pushd NTS
rm tests/flush_buffers.phpt tests/touch_binary.phpt
@@ -334,7 +324,7 @@ TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="$OPT -d extension=$PWD/modules/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php --show-diff || ret=1
+%{__php} -n run-tests.php --show-diff tests/*phpt || ret=1
popd
%if %{with_zts}
@@ -345,7 +335,7 @@ TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="$OPT -d extension=$PWD/modules/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php --show-diff || ret=1
+%{__ztsphp} -n run-tests.php --show-diff tests/*phpt || ret=1
popd
%endif
@@ -374,6 +364,10 @@ exit $ret
%changelog
+* Thu Mar 3 2016 Remi Collet <remi@fedoraproject.org> - 3.0.0-0.1.20160217git6ace07d
+- update to 3.0.0-dev
+- switch back to php-memcached-dev sources
+
* Wed Mar 2 2016 Remi Collet <remi@fedoraproject.org> - 2.2.1-0.2.20150628git3c79a97
- add patch for igbinary, see
https://github.com/rlerdorf/php-memcached/pull/3