summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-12-04 07:28:34 +0100
committerRemi Collet <remi@remirepo.net>2019-12-04 07:28:34 +0100
commita8804e752ba2226f3d22112f2162a4ed79cecd00 (patch)
tree0bb213b8e4ce275a8e3e7afa1f8e6c52f186e9ad
parent049eca659e8b999e77fb54db18fd0bfda47524d4 (diff)
v3.1.5
-rw-r--r--PHPINFO40
-rw-r--r--REFLECTION356
-rw-r--r--php-pecl-memcached.spec5
3 files changed, 202 insertions, 199 deletions
diff --git a/PHPINFO b/PHPINFO
index 6b2317a..9c480b2 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
memcached
memcached support => enabled
-Version => 3.1.4
+Version => 3.1.5
libmemcached version => 1.0.18
SASL support => yes
Session support => yes
@@ -11,30 +11,30 @@ json support => yes
msgpack support => yes
Directive => Local Value => Master Value
-memcached.sess_locking => On => On
-memcached.sess_lock_wait_min => 150 => 150
-memcached.sess_lock_wait_max => 150 => 150
-memcached.sess_lock_retries => 5 => 5
-memcached.sess_lock_expire => 0 => 0
+memcached.compression_factor => 1.3 => 1.3
+memcached.compression_threshold => 2000 => 2000
+memcached.compression_type => fastlz => fastlz
+memcached.default_binary_protocol => Off => Off
+memcached.default_connect_timeout => 0 => 0
+memcached.default_consistent_hash => Off => Off
+memcached.serializer => igbinary => igbinary
memcached.sess_binary_protocol => On => On
+memcached.sess_connect_timeout => 0 => 0
memcached.sess_consistent_hash => On => On
memcached.sess_consistent_hash_type => ketama => ketama
+memcached.sess_lock_expire => 0 => 0
+memcached.sess_lock_max_wait => not set => not set
+memcached.sess_lock_retries => 5 => 5
+memcached.sess_lock_wait => not set => not set
+memcached.sess_lock_wait_max => 150 => 150
+memcached.sess_lock_wait_min => 150 => 150
+memcached.sess_locking => On => On
memcached.sess_number_of_replicas => 0 => 0
+memcached.sess_persistent => Off => Off
+memcached.sess_prefix => memc.sess.key. => memc.sess.key.
memcached.sess_randomize_replica_read => Off => Off
memcached.sess_remove_failed_servers => Off => Off
-memcached.sess_server_failure_limit => 0 => 0
-memcached.sess_connect_timeout => 0 => 0
-memcached.sess_sasl_username => no value => no value
memcached.sess_sasl_password => no value => no value
-memcached.sess_persistent => Off => Off
-memcached.sess_prefix => memc.sess.key. => memc.sess.key.
-memcached.sess_lock_wait => not set => not set
-memcached.sess_lock_max_wait => not set => not set
-memcached.compression_type => fastlz => fastlz
-memcached.compression_factor => 1.3 => 1.3
-memcached.compression_threshold => 2000 => 2000
-memcached.serializer => igbinary => igbinary
+memcached.sess_sasl_username => no value => no value
+memcached.sess_server_failure_limit => 0 => 0
memcached.store_retry_count => 2 => 2
-memcached.default_consistent_hash => Off => Off
-memcached.default_binary_protocol => Off => Off
-memcached.default_connect_timeout => 0 => 0
diff --git a/REFLECTION b/REFLECTION
index c9cbe14..6f3e7d8 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #193 memcached version 3.1.4 ] {
+Extension [ <persistent> extension #181 memcached version 3.1.5 ] {
- Dependencies {
Dependency [ session (Required) ]
@@ -8,50 +8,62 @@ Extension [ <persistent> extension #193 memcached version 3.1.4 ] {
}
- INI {
- Entry [ memcached.sess_locking <ALL> ]
- Current = '1'
+ Entry [ memcached.compression_factor <ALL> ]
+ Current = '1.3'
}
- Entry [ memcached.sess_lock_wait_min <ALL> ]
- Current = '150'
+ Entry [ memcached.compression_threshold <ALL> ]
+ Current = '2000'
}
- Entry [ memcached.sess_lock_wait_max <ALL> ]
- Current = '150'
+ Entry [ memcached.compression_type <ALL> ]
+ Current = 'fastlz'
}
- Entry [ memcached.sess_lock_retries <ALL> ]
- Current = '5'
+ Entry [ memcached.default_binary_protocol <ALL> ]
+ Current = '0'
}
- Entry [ memcached.sess_lock_expire <ALL> ]
+ Entry [ memcached.default_connect_timeout <ALL> ]
Current = '0'
}
+ Entry [ memcached.default_consistent_hash <ALL> ]
+ Current = '0'
+ }
+ Entry [ memcached.serializer <ALL> ]
+ Current = 'igbinary'
+ }
Entry [ memcached.sess_binary_protocol <ALL> ]
Current = '1'
}
+ Entry [ memcached.sess_connect_timeout <ALL> ]
+ Current = '0'
+ }
Entry [ memcached.sess_consistent_hash <ALL> ]
Current = '1'
}
Entry [ memcached.sess_consistent_hash_type <ALL> ]
Current = 'ketama'
}
- Entry [ memcached.sess_number_of_replicas <ALL> ]
+ Entry [ memcached.sess_lock_expire <ALL> ]
Current = '0'
}
- Entry [ memcached.sess_randomize_replica_read <ALL> ]
- Current = '0'
+ Entry [ memcached.sess_lock_max_wait <ALL> ]
+ Current = 'not set'
}
- Entry [ memcached.sess_remove_failed_servers <ALL> ]
- Current = '0'
+ Entry [ memcached.sess_lock_retries <ALL> ]
+ Current = '5'
}
- Entry [ memcached.sess_server_failure_limit <ALL> ]
- Current = '0'
+ Entry [ memcached.sess_lock_wait <ALL> ]
+ Current = 'not set'
}
- Entry [ memcached.sess_connect_timeout <ALL> ]
- Current = '0'
+ Entry [ memcached.sess_lock_wait_max <ALL> ]
+ Current = '150'
}
- Entry [ memcached.sess_sasl_username <ALL> ]
- Current = ''
+ Entry [ memcached.sess_lock_wait_min <ALL> ]
+ Current = '150'
}
- Entry [ memcached.sess_sasl_password <ALL> ]
- Current = ''
+ Entry [ memcached.sess_locking <ALL> ]
+ Current = '1'
+ }
+ Entry [ memcached.sess_number_of_replicas <ALL> ]
+ Current = '0'
}
Entry [ memcached.sess_persistent <ALL> ]
Current = '0'
@@ -59,175 +71,163 @@ Extension [ <persistent> extension #193 memcached version 3.1.4 ] {
Entry [ memcached.sess_prefix <ALL> ]
Current = 'memc.sess.key.'
}
- Entry [ memcached.sess_lock_wait <ALL> ]
- Current = 'not set'
- }
- Entry [ memcached.sess_lock_max_wait <ALL> ]
- Current = 'not set'
+ Entry [ memcached.sess_randomize_replica_read <ALL> ]
+ Current = '0'
}
- Entry [ memcached.compression_type <ALL> ]
- Current = 'fastlz'
+ Entry [ memcached.sess_remove_failed_servers <ALL> ]
+ Current = '0'
}
- Entry [ memcached.compression_factor <ALL> ]
- Current = '1.3'
+ Entry [ memcached.sess_sasl_password <ALL> ]
+ Current = ''
}
- Entry [ memcached.compression_threshold <ALL> ]
- Current = '2000'
+ Entry [ memcached.sess_sasl_username <ALL> ]
+ Current = ''
}
- Entry [ memcached.serializer <ALL> ]
- Current = 'igbinary'
+ Entry [ memcached.sess_server_failure_limit <ALL> ]
+ Current = '0'
}
Entry [ memcached.store_retry_count <ALL> ]
Current = '2'
}
- Entry [ memcached.default_consistent_hash <ALL> ]
- Current = '0'
- }
- Entry [ memcached.default_binary_protocol <ALL> ]
- Current = '0'
- }
- Entry [ memcached.default_connect_timeout <ALL> ]
- Current = '0'
- }
}
- Classes [3] {
Class [ <internal:memcached> class Memcached ] {
- Constants [133] {
- Constant [ public integer LIBMEMCACHED_VERSION_HEX ] { 16777240 }
- Constant [ public integer OPT_COMPRESSION ] { -1001 }
- Constant [ public integer OPT_COMPRESSION_TYPE ] { -1004 }
- Constant [ public integer OPT_PREFIX_KEY ] { -1002 }
- Constant [ public integer OPT_SERIALIZER ] { -1003 }
- Constant [ public integer OPT_USER_FLAGS ] { -1006 }
- Constant [ public integer OPT_STORE_RETRY_COUNT ] { -1005 }
- Constant [ public boolean HAVE_IGBINARY ] { 1 }
- Constant [ public boolean HAVE_JSON ] { 1 }
- Constant [ public boolean HAVE_MSGPACK ] { 1 }
- Constant [ public boolean HAVE_ENCODING ] { 1 }
- Constant [ public boolean HAVE_SESSION ] { 1 }
- Constant [ public boolean HAVE_SASL ] { 1 }
- Constant [ public integer OPT_HASH ] { 2 }
- Constant [ public integer HASH_DEFAULT ] { 0 }
- Constant [ public integer HASH_MD5 ] { 1 }
- Constant [ public integer HASH_CRC ] { 2 }
- Constant [ public integer HASH_FNV1_64 ] { 3 }
- Constant [ public integer HASH_FNV1A_64 ] { 4 }
- Constant [ public integer HASH_FNV1_32 ] { 5 }
- Constant [ public integer HASH_FNV1A_32 ] { 6 }
- Constant [ public integer HASH_HSIEH ] { 7 }
- Constant [ public integer HASH_MURMUR ] { 8 }
- Constant [ public integer OPT_DISTRIBUTION ] { 9 }
- Constant [ public integer DISTRIBUTION_MODULA ] { 0 }
- Constant [ public integer DISTRIBUTION_CONSISTENT ] { 1 }
- Constant [ public integer DISTRIBUTION_VIRTUAL_BUCKET ] { 6 }
- Constant [ public integer OPT_LIBKETAMA_COMPATIBLE ] { 16 }
- Constant [ public integer OPT_LIBKETAMA_HASH ] { 17 }
- Constant [ public integer OPT_TCP_KEEPALIVE ] { 32 }
- Constant [ public integer OPT_BUFFER_WRITES ] { 10 }
- Constant [ public integer OPT_BINARY_PROTOCOL ] { 18 }
- Constant [ public integer OPT_NO_BLOCK ] { 0 }
- Constant [ public integer OPT_TCP_NODELAY ] { 1 }
- Constant [ public integer OPT_SOCKET_SEND_SIZE ] { 4 }
- Constant [ public integer OPT_SOCKET_RECV_SIZE ] { 5 }
- Constant [ public integer OPT_CONNECT_TIMEOUT ] { 14 }
- Constant [ public integer OPT_RETRY_TIMEOUT ] { 15 }
- Constant [ public integer OPT_DEAD_TIMEOUT ] { 36 }
- Constant [ public integer OPT_SEND_TIMEOUT ] { 19 }
- Constant [ public integer OPT_RECV_TIMEOUT ] { 20 }
- Constant [ public integer OPT_POLL_TIMEOUT ] { 8 }
- Constant [ public integer OPT_CACHE_LOOKUPS ] { 6 }
- Constant [ public integer OPT_SERVER_FAILURE_LIMIT ] { 21 }
- Constant [ public integer OPT_AUTO_EJECT_HOSTS ] { 28 }
- Constant [ public integer OPT_HASH_WITH_PREFIX_KEY ] { 25 }
- Constant [ public integer OPT_NOREPLY ] { 26 }
- Constant [ public integer OPT_SORT_HOSTS ] { 12 }
- Constant [ public integer OPT_VERIFY_KEY ] { 13 }
- Constant [ public integer OPT_USE_UDP ] { 27 }
- Constant [ public integer OPT_NUMBER_OF_REPLICAS ] { 29 }
- Constant [ public integer OPT_RANDOMIZE_REPLICA_READ ] { 30 }
- Constant [ public integer OPT_REMOVE_FAILED_SERVERS ] { 35 }
- Constant [ public integer OPT_SERVER_TIMEOUT_LIMIT ] { 37 }
- Constant [ public integer RES_SUCCESS ] { 0 }
- Constant [ public integer RES_FAILURE ] { 1 }
- Constant [ public integer RES_HOST_LOOKUP_FAILURE ] { 2 }
- Constant [ public integer RES_UNKNOWN_READ_FAILURE ] { 7 }
- Constant [ public integer RES_PROTOCOL_ERROR ] { 8 }
- Constant [ public integer RES_CLIENT_ERROR ] { 9 }
- Constant [ public integer RES_SERVER_ERROR ] { 10 }
- Constant [ public integer RES_WRITE_FAILURE ] { 5 }
- Constant [ public integer RES_DATA_EXISTS ] { 12 }
- Constant [ public integer RES_NOTSTORED ] { 14 }
- Constant [ public integer RES_NOTFOUND ] { 16 }
- Constant [ public integer RES_PARTIAL_READ ] { 18 }
- Constant [ public integer RES_SOME_ERRORS ] { 19 }
- Constant [ public integer RES_NO_SERVERS ] { 20 }
- Constant [ public integer RES_END ] { 21 }
- Constant [ public integer RES_ERRNO ] { 26 }
- Constant [ public integer RES_BUFFERED ] { 32 }
- Constant [ public integer RES_TIMEOUT ] { 31 }
- Constant [ public integer RES_BAD_KEY_PROVIDED ] { 33 }
- Constant [ public integer RES_STORED ] { 15 }
- Constant [ public integer RES_DELETED ] { 22 }
- Constant [ public integer RES_STAT ] { 24 }
- Constant [ public integer RES_ITEM ] { 25 }
- Constant [ public integer RES_NOT_SUPPORTED ] { 28 }
- Constant [ public integer RES_FETCH_NOTFINISHED ] { 30 }
- Constant [ public integer RES_SERVER_MARKED_DEAD ] { 35 }
- Constant [ public integer RES_UNKNOWN_STAT_KEY ] { 36 }
- Constant [ public integer RES_INVALID_HOST_PROTOCOL ] { 34 }
- Constant [ public integer RES_MEMORY_ALLOCATION_FAILURE ] { 17 }
- Constant [ public integer RES_CONNECTION_SOCKET_CREATE_FAILURE ] { 11 }
- Constant [ public integer RES_E2BIG ] { 37 }
- Constant [ public integer RES_KEY_TOO_BIG ] { 39 }
- Constant [ public integer RES_SERVER_TEMPORARILY_DISABLED ] { 47 }
- Constant [ public integer RES_SERVER_MEMORY_ALLOCATION_FAILURE ] { 48 }
- Constant [ public integer RES_AUTH_PROBLEM ] { 40 }
- Constant [ public integer RES_AUTH_FAILURE ] { 41 }
- Constant [ public integer RES_AUTH_CONTINUE ] { 42 }
- Constant [ public integer RES_PAYLOAD_FAILURE ] { -1001 }
- Constant [ public integer SERIALIZER_PHP ] { 1 }
- Constant [ public integer SERIALIZER_IGBINARY ] { 2 }
- Constant [ public integer SERIALIZER_JSON ] { 3 }
- Constant [ public integer SERIALIZER_JSON_ARRAY ] { 4 }
- Constant [ public integer SERIALIZER_MSGPACK ] { 5 }
- Constant [ public integer COMPRESSION_FASTLZ ] { 2 }
- Constant [ public integer COMPRESSION_ZLIB ] { 1 }
- Constant [ public integer GET_PRESERVE_ORDER ] { 1 }
- Constant [ public integer GET_EXTENDED ] { 2 }
- Constant [ public integer ON_CONNECT ] { 0 }
- Constant [ public integer ON_ADD ] { 1 }
- Constant [ public integer ON_APPEND ] { 2 }
- Constant [ public integer ON_DECREMENT ] { 3 }
- Constant [ public integer ON_DELETE ] { 4 }
- Constant [ public integer ON_FLUSH ] { 5 }
- Constant [ public integer ON_GET ] { 6 }
- Constant [ public integer ON_INCREMENT ] { 7 }
- Constant [ public integer ON_NOOP ] { 8 }
- Constant [ public integer ON_PREPEND ] { 9 }
- Constant [ public integer ON_QUIT ] { 10 }
- Constant [ public integer ON_REPLACE ] { 11 }
- Constant [ public integer ON_SET ] { 12 }
- Constant [ public integer ON_STAT ] { 13 }
- Constant [ public integer ON_VERSION ] { 14 }
- Constant [ public integer RESPONSE_SUCCESS ] { 0 }
- Constant [ public integer RESPONSE_KEY_ENOENT ] { 1 }
- Constant [ public integer RESPONSE_KEY_EEXISTS ] { 2 }
- Constant [ public integer RESPONSE_E2BIG ] { 3 }
- Constant [ public integer RESPONSE_EINVAL ] { 4 }
- Constant [ public integer RESPONSE_NOT_STORED ] { 5 }
- Constant [ public integer RESPONSE_DELTA_BADVAL ] { 6 }
- Constant [ public integer RESPONSE_NOT_MY_VBUCKET ] { 7 }
- Constant [ public integer RESPONSE_AUTH_ERROR ] { 32 }
- Constant [ public integer RESPONSE_AUTH_CONTINUE ] { 33 }
- Constant [ public integer RESPONSE_UNKNOWN_COMMAND ] { 129 }
- Constant [ public integer RESPONSE_ENOMEM ] { 130 }
- Constant [ public integer RESPONSE_NOT_SUPPORTED ] { 131 }
- Constant [ public integer RESPONSE_EINTERNAL ] { 132 }
- Constant [ public integer RESPONSE_EBUSY ] { 133 }
- Constant [ public integer RESPONSE_ETMPFAIL ] { 134 }
- Constant [ public boolean GET_ERROR_RETURN_VALUE ] { }
+ Constant [ public int LIBMEMCACHED_VERSION_HEX ] { 16777240 }
+ Constant [ public int OPT_COMPRESSION ] { -1001 }
+ Constant [ public int OPT_COMPRESSION_TYPE ] { -1004 }
+ Constant [ public int OPT_PREFIX_KEY ] { -1002 }
+ Constant [ public int OPT_SERIALIZER ] { -1003 }
+ Constant [ public int OPT_USER_FLAGS ] { -1006 }
+ Constant [ public int OPT_STORE_RETRY_COUNT ] { -1005 }
+ Constant [ public bool HAVE_IGBINARY ] { 1 }
+ Constant [ public bool HAVE_JSON ] { 1 }
+ Constant [ public bool HAVE_MSGPACK ] { 1 }
+ Constant [ public bool HAVE_ENCODING ] { 1 }
+ Constant [ public bool HAVE_SESSION ] { 1 }
+ Constant [ public bool HAVE_SASL ] { 1 }
+ Constant [ public int OPT_HASH ] { 2 }
+ Constant [ public int HASH_DEFAULT ] { 0 }
+ Constant [ public int HASH_MD5 ] { 1 }
+ Constant [ public int HASH_CRC ] { 2 }
+ Constant [ public int HASH_FNV1_64 ] { 3 }
+ Constant [ public int HASH_FNV1A_64 ] { 4 }
+ Constant [ public int HASH_FNV1_32 ] { 5 }
+ Constant [ public int HASH_FNV1A_32 ] { 6 }
+ Constant [ public int HASH_HSIEH ] { 7 }
+ Constant [ public int HASH_MURMUR ] { 8 }
+ Constant [ public int OPT_DISTRIBUTION ] { 9 }
+ Constant [ public int DISTRIBUTION_MODULA ] { 0 }
+ Constant [ public int DISTRIBUTION_CONSISTENT ] { 1 }
+ Constant [ public int DISTRIBUTION_VIRTUAL_BUCKET ] { 6 }
+ Constant [ public int OPT_LIBKETAMA_COMPATIBLE ] { 16 }
+ Constant [ public int OPT_LIBKETAMA_HASH ] { 17 }
+ Constant [ public int OPT_TCP_KEEPALIVE ] { 32 }
+ Constant [ public int OPT_BUFFER_WRITES ] { 10 }
+ Constant [ public int OPT_BINARY_PROTOCOL ] { 18 }
+ Constant [ public int OPT_NO_BLOCK ] { 0 }
+ Constant [ public int OPT_TCP_NODELAY ] { 1 }
+ Constant [ public int OPT_SOCKET_SEND_SIZE ] { 4 }
+ Constant [ public int OPT_SOCKET_RECV_SIZE ] { 5 }
+ Constant [ public int OPT_CONNECT_TIMEOUT ] { 14 }
+ Constant [ public int OPT_RETRY_TIMEOUT ] { 15 }
+ Constant [ public int OPT_DEAD_TIMEOUT ] { 36 }
+ Constant [ public int OPT_SEND_TIMEOUT ] { 19 }
+ Constant [ public int OPT_RECV_TIMEOUT ] { 20 }
+ Constant [ public int OPT_POLL_TIMEOUT ] { 8 }
+ Constant [ public int OPT_CACHE_LOOKUPS ] { 6 }
+ Constant [ public int OPT_SERVER_FAILURE_LIMIT ] { 21 }
+ Constant [ public int OPT_AUTO_EJECT_HOSTS ] { 28 }
+ Constant [ public int OPT_HASH_WITH_PREFIX_KEY ] { 25 }
+ Constant [ public int OPT_NOREPLY ] { 26 }
+ Constant [ public int OPT_SORT_HOSTS ] { 12 }
+ Constant [ public int OPT_VERIFY_KEY ] { 13 }
+ Constant [ public int OPT_USE_UDP ] { 27 }
+ Constant [ public int OPT_NUMBER_OF_REPLICAS ] { 29 }
+ Constant [ public int OPT_RANDOMIZE_REPLICA_READ ] { 30 }
+ Constant [ public int OPT_REMOVE_FAILED_SERVERS ] { 35 }
+ Constant [ public int OPT_SERVER_TIMEOUT_LIMIT ] { 37 }
+ Constant [ public int RES_SUCCESS ] { 0 }
+ Constant [ public int RES_FAILURE ] { 1 }
+ Constant [ public int RES_HOST_LOOKUP_FAILURE ] { 2 }
+ Constant [ public int RES_UNKNOWN_READ_FAILURE ] { 7 }
+ Constant [ public int RES_PROTOCOL_ERROR ] { 8 }
+ Constant [ public int RES_CLIENT_ERROR ] { 9 }
+ Constant [ public int RES_SERVER_ERROR ] { 10 }
+ Constant [ public int RES_WRITE_FAILURE ] { 5 }
+ Constant [ public int RES_DATA_EXISTS ] { 12 }
+ Constant [ public int RES_NOTSTORED ] { 14 }
+ Constant [ public int RES_NOTFOUND ] { 16 }
+ Constant [ public int RES_PARTIAL_READ ] { 18 }
+ Constant [ public int RES_SOME_ERRORS ] { 19 }
+ Constant [ public int RES_NO_SERVERS ] { 20 }
+ Constant [ public int RES_END ] { 21 }
+ Constant [ public int RES_ERRNO ] { 26 }
+ Constant [ public int RES_BUFFERED ] { 32 }
+ Constant [ public int RES_TIMEOUT ] { 31 }
+ Constant [ public int RES_BAD_KEY_PROVIDED ] { 33 }
+ Constant [ public int RES_STORED ] { 15 }
+ Constant [ public int RES_DELETED ] { 22 }
+ Constant [ public int RES_STAT ] { 24 }
+ Constant [ public int RES_ITEM ] { 25 }
+ Constant [ public int RES_NOT_SUPPORTED ] { 28 }
+ Constant [ public int RES_FETCH_NOTFINISHED ] { 30 }
+ Constant [ public int RES_SERVER_MARKED_DEAD ] { 35 }
+ Constant [ public int RES_UNKNOWN_STAT_KEY ] { 36 }
+ Constant [ public int RES_INVALID_HOST_PROTOCOL ] { 34 }
+ Constant [ public int RES_MEMORY_ALLOCATION_FAILURE ] { 17 }
+ Constant [ public int RES_CONNECTION_SOCKET_CREATE_FAILURE ] { 11 }
+ Constant [ public int RES_E2BIG ] { 37 }
+ Constant [ public int RES_KEY_TOO_BIG ] { 39 }
+ Constant [ public int RES_SERVER_TEMPORARILY_DISABLED ] { 47 }
+ Constant [ public int RES_SERVER_MEMORY_ALLOCATION_FAILURE ] { 48 }
+ Constant [ public int RES_AUTH_PROBLEM ] { 40 }
+ Constant [ public int RES_AUTH_FAILURE ] { 41 }
+ Constant [ public int RES_AUTH_CONTINUE ] { 42 }
+ Constant [ public int RES_PAYLOAD_FAILURE ] { -1001 }
+ Constant [ public int SERIALIZER_PHP ] { 1 }
+ Constant [ public int SERIALIZER_IGBINARY ] { 2 }
+ Constant [ public int SERIALIZER_JSON ] { 3 }
+ Constant [ public int SERIALIZER_JSON_ARRAY ] { 4 }
+ Constant [ public int SERIALIZER_MSGPACK ] { 5 }
+ Constant [ public int COMPRESSION_FASTLZ ] { 2 }
+ Constant [ public int COMPRESSION_ZLIB ] { 1 }
+ Constant [ public int GET_PRESERVE_ORDER ] { 1 }
+ Constant [ public int GET_EXTENDED ] { 2 }
+ Constant [ public int ON_CONNECT ] { 0 }
+ Constant [ public int ON_ADD ] { 1 }
+ Constant [ public int ON_APPEND ] { 2 }
+ Constant [ public int ON_DECREMENT ] { 3 }
+ Constant [ public int ON_DELETE ] { 4 }
+ Constant [ public int ON_FLUSH ] { 5 }
+ Constant [ public int ON_GET ] { 6 }
+ Constant [ public int ON_INCREMENT ] { 7 }
+ Constant [ public int ON_NOOP ] { 8 }
+ Constant [ public int ON_PREPEND ] { 9 }
+ Constant [ public int ON_QUIT ] { 10 }
+ Constant [ public int ON_REPLACE ] { 11 }
+ Constant [ public int ON_SET ] { 12 }
+ Constant [ public int ON_STAT ] { 13 }
+ Constant [ public int ON_VERSION ] { 14 }
+ Constant [ public int RESPONSE_SUCCESS ] { 0 }
+ Constant [ public int RESPONSE_KEY_ENOENT ] { 1 }
+ Constant [ public int RESPONSE_KEY_EEXISTS ] { 2 }
+ Constant [ public int RESPONSE_E2BIG ] { 3 }
+ Constant [ public int RESPONSE_EINVAL ] { 4 }
+ Constant [ public int RESPONSE_NOT_STORED ] { 5 }
+ Constant [ public int RESPONSE_DELTA_BADVAL ] { 6 }
+ Constant [ public int RESPONSE_NOT_MY_VBUCKET ] { 7 }
+ Constant [ public int RESPONSE_AUTH_ERROR ] { 32 }
+ Constant [ public int RESPONSE_AUTH_CONTINUE ] { 33 }
+ Constant [ public int RESPONSE_UNKNOWN_COMMAND ] { 129 }
+ Constant [ public int RESPONSE_ENOMEM ] { 130 }
+ Constant [ public int RESPONSE_NOT_SUPPORTED ] { 131 }
+ Constant [ public int RESPONSE_EINTERNAL ] { 132 }
+ Constant [ public int RESPONSE_EBUSY ] { 133 }
+ Constant [ public int RESPONSE_ETMPFAIL ] { 134 }
+ Constant [ public bool GET_ERROR_RETURN_VALUE ] { }
}
- Static properties [0] {
diff --git a/php-pecl-memcached.spec b/php-pecl-memcached.spec
index ec2e8c5..f15807d 100644
--- a/php-pecl-memcached.spec
+++ b/php-pecl-memcached.spec
@@ -30,7 +30,7 @@
Summary: Extension to work with the Memcached caching daemon
Name: %{?sub_prefix}php-pecl-memcached
-Version: 3.1.4
+Version: 3.1.5
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: http://pecl.php.net/package/%{pecl_name}
@@ -354,6 +354,9 @@ exit $ret
%changelog
+* Wed Dec 4 2019 Remi Collet <remi@remirepo.net> - 3.1.5-1
+- update to 3.1.5
+
* Mon Oct 7 2019 Remi Collet <remi@remirepo.net> - 3.1.4-1
- update to 3.1.4