summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-04-12 13:13:52 +0200
committerRemi Collet <fedora@famillecollet.com>2016-04-12 13:13:52 +0200
commit1caee2bd377c2f444cb4346aa3f23b6b564a251e (patch)
tree4032dec9d91569d34fb78944aa2a757961197715
parente5364ec651568a66376f18d338a6529cda48d6dc (diff)
php-pecl-memcached: fix missing dep (more-php5*)
-rw-r--r--php-pecl-memcached-dev.spec17
-rw-r--r--php-pecl-memcached.spec16
2 files changed, 23 insertions, 10 deletions
diff --git a/php-pecl-memcached-dev.spec b/php-pecl-memcached-dev.spec
index 146107f..1e90f18 100644
--- a/php-pecl-memcached-dev.spec
+++ b/php-pecl-memcached-dev.spec
@@ -15,14 +15,11 @@
%else
%global sub_prefix %{scl_prefix}
%endif
+%scl_package php-pecl-memcached
+%else
+%global _root_prefix %{_prefix}
%endif
-%{?scl: %scl_package php-pecl-memcached}
-%{!?scl: %global _root_prefix %{_prefix}}
-%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
-%{!?__pecl: %global __pecl %{_bindir}/pecl}
-%{!?__php: %global __php %{_bindir}/php}
-
%global with_fastlz 1
%global with_igbin 1
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
@@ -82,6 +79,10 @@ BuildRequires: %{?sub_prefix}libevent-devel > 2
Requires: %{?sub_prefix}libevent%{_isa} > 2
BuildRequires: %{?sub_prefix}libmemcached-devel > 1
Requires: %{?sub_prefix}libmemcached-libs%{_isa} > 1
+%if %{with_fastlz}
+Requires: fastlz%{_isa}
+%endif
+Requires: cyrus-sasl-lib%{_isa}
%else
BuildRequires: libevent-devel >= 2.0.2
%if 0%{?rhel} == 5
@@ -107,6 +108,10 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+%if "%{?scl_prefix}" != "%{?sub_prefix}"
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+%endif
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
diff --git a/php-pecl-memcached.spec b/php-pecl-memcached.spec
index bb24820..2f7e155 100644
--- a/php-pecl-memcached.spec
+++ b/php-pecl-memcached.spec
@@ -15,11 +15,11 @@
%else
%global sub_prefix %{scl_prefix}
%endif
+%scl_package php-pecl-memcached
+%else
+%global _root_prefix %{_prefix}
%endif
-%{?scl: %scl_package php-pecl-memcached}
-%{!?scl: %global _root_prefix %{_prefix}}
-
%global with_fastlz 1
%global with_zts 0%{?__ztsphp:1}
%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
@@ -37,7 +37,7 @@
Summary: Extension to work with the Memcached caching daemon
Name: %{?sub_prefix}php-pecl-memcached
Version: 2.2.0
-Release: 8%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 9%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -73,7 +73,10 @@ BuildRequires: %{?sub_prefix}libevent-devel > 2
Requires: %{?sub_prefix}libevent%{_isa} > 2
BuildRequires: %{?sub_prefix}libmemcached-devel > 1
Requires: %{?sub_prefix}libmemcached-libs%{_isa} > 1
+%if %{with_fastlz}
Requires: fastlz%{_isa}
+%endif
+Requires: cyrus-sasl-lib%{_isa}
%else
BuildRequires: libevent-devel >= 2.0.2
%if 0%{?rhel} == 5
@@ -97,8 +100,10 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+%if "%{?scl_prefix}" != "%{?sub_prefix}"
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+%endif
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
@@ -348,6 +353,9 @@ exit $ret
%changelog
+* Tue Apr 12 2016 Remi Collet <remi@fedoraproject.org> - 2.2.0-9
+- fix dependencies for more-php5*
+
* Wed Mar 9 2016 Remi Collet <remi@fedoraproject.org> - 2.2.0-8
- adapt for F24