summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO14
-rw-r--r--REFLECTION559
-rw-r--r--php-pecl-memcache.spec44
3 files changed, 578 insertions, 39 deletions
diff --git a/PHPINFO b/PHPINFO
index 33e1dd6..194e253 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
memcache
memcache support => enabled
-Version => 4.0.5.2
+Version => 8.0
Revision => $Revision$
Directive => Local Value => Master Value
@@ -17,12 +17,12 @@ memcache.redundancy => 1 => 1
memcache.session_redundancy => 2 => 2
memcache.compress_threshold => 20000 => 20000
memcache.lock_timeout => 15 => 15
-memcache.session_prefix_host_key => 0 => 0
-memcache.session_prefix_host_key_remove_www => 1 => 1
-memcache.session_prefix_host_key_remove_subdomain => 0 => 0
+memcache.session_prefix_host_key => Off => Off
+memcache.session_prefix_host_key_remove_www => On => On
+memcache.session_prefix_host_key_remove_subdomain => Off => Off
memcache.session_prefix_static_key => no value => no value
memcache.session_save_path => no value => no value
-memcache.prefix_host_key => 0 => 0
-memcache.prefix_host_key_remove_www => 1 => 1
-memcache.prefix_host_key_remove_subdomain => 0 => 0
+memcache.prefix_host_key => Off => Off
+memcache.prefix_host_key_remove_www => On => On
+memcache.prefix_host_key_remove_subdomain => Off => Off
memcache.prefix_static_key => no value => no value
diff --git a/REFLECTION b/REFLECTION
index f6f1e6e..ffa0fc3 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #81 memcache version 4.0.5.2 ] {
+Extension [ <persistent> extension #72 memcache version 8.0 ] {
- INI {
Entry [ memcache.allow_failover <ALL> ]
@@ -74,59 +74,256 @@ Extension [ <persistent> extension #81 memcache version 4.0.5.2 ] {
- Functions {
Function [ <internal:memcache> function memcache_connect ] {
+
+ - Parameters [8] {
+ Parameter #0 [ <required> $host ]
+ Parameter #1 [ <optional> $port = <default> ]
+ Parameter #2 [ <optional> $timeout = <default> ]
+ Parameter #3 [ <optional> $unused4 = <default> ]
+ Parameter #4 [ <optional> $unused5 = <default> ]
+ Parameter #5 [ <optional> $unused6 = <default> ]
+ Parameter #6 [ <optional> $unused7 = <default> ]
+ Parameter #7 [ <optional> $unugsed8 = <default> ]
+ }
}
Function [ <internal:memcache> function memcache_pconnect ] {
+
+ - Parameters [8] {
+ Parameter #0 [ <required> $host ]
+ Parameter #1 [ <optional> $port = <default> ]
+ Parameter #2 [ <optional> $timeout = <default> ]
+ Parameter #3 [ <optional> $unused4 = <default> ]
+ Parameter #4 [ <optional> $unused5 = <default> ]
+ Parameter #5 [ <optional> $unused6 = <default> ]
+ Parameter #6 [ <optional> $unused7 = <default> ]
+ Parameter #7 [ <optional> $unugsed8 = <default> ]
+ }
}
Function [ <internal:memcache> function memcache_add_server ] {
+
+ - Parameters [10] {
+ Parameter #0 [ <required> MemcachePool $memcache ]
+ Parameter #1 [ <required> $host ]
+ Parameter #2 [ <optional> $port = <default> ]
+ Parameter #3 [ <optional> $tcp_port = <default> ]
+ Parameter #4 [ <optional> $persistent = <default> ]
+ Parameter #5 [ <optional> $weight = <default> ]
+ Parameter #6 [ <optional> $timeout = <default> ]
+ Parameter #7 [ <optional> $retry_interval = <default> ]
+ Parameter #8 [ <optional> $status = <default> ]
+ Parameter #9 [ <optional> $failure_callback = <default> ]
+ }
+ - Return [ bool ]
}
Function [ <internal:memcache> function memcache_set_server_params ] {
+
+ - Parameters [7] {
+ Parameter #0 [ <required> MemcachePool $memcache ]
+ Parameter #1 [ <required> string $host ]
+ Parameter #2 [ <optional> int $tcp_port = <default> ]
+ Parameter #3 [ <optional> float $timeout = <default> ]
+ Parameter #4 [ <optional> int $retry_interval = <default> ]
+ Parameter #5 [ <optional> bool $status = <default> ]
+ Parameter #6 [ <optional> $failure_callback = <default> ]
+ }
+ - Return [ bool ]
}
Function [ <internal:memcache> function memcache_set_failure_callback ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> MemcachePool $memcache ]
+ Parameter #1 [ <required> ?callable $failure_callback ]
+ }
+ - Return [ bool ]
}
Function [ <internal:memcache> function memcache_get_server_status ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> MemcachePool $memcache ]
+ Parameter #1 [ <required> string $host ]
+ Parameter #2 [ <optional> int $tcp_port = <default> ]
+ }
+ - Return [ int|bool ]
}
Function [ <internal:memcache> function memcache_get_version ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> MemcachePool $memcache ]
+ }
+ - Return [ string|bool ]
}
Function [ <internal:memcache> function memcache_add ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <required> MemcachePool $memcache ]
+ Parameter #1 [ <required> array|string $key ]
+ Parameter #2 [ <optional> mixed $value = <default> ]
+ Parameter #3 [ <optional> int $flags = <default> ]
+ Parameter #4 [ <optional> int $exptime = <default> ]
+ Parameter #5 [ <optional> int $cas = <default> ]
+ }
+ - Return [ bool ]
}
Function [ <internal:memcache> function memcache_set ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <required> MemcachePool $memcache ]
+ Parameter #1 [ <required> array|string $key ]
+ Parameter #2 [ <optional> mixed $value = <default> ]
+ Parameter #3 [ <optional> int $flags = <default> ]
+ Parameter #4 [ <optional> int $exptime = <default> ]
+ Parameter #5 [ <optional> int $cas = <default> ]
+ }
+ - Return [ bool ]
}
Function [ <internal:memcache> function memcache_replace ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <required> MemcachePool $memcache ]
+ Parameter #1 [ <required> array|string $key ]
+ Parameter #2 [ <optional> mixed $value = <default> ]
+ Parameter #3 [ <optional> int $flags = <default> ]
+ Parameter #4 [ <optional> int $exptime = <default> ]
+ Parameter #5 [ <optional> int $cas = <default> ]
+ }
+ - Return [ bool ]
}
Function [ <internal:memcache> function memcache_cas ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <required> MemcachePool $memcache ]
+ Parameter #1 [ <required> array|string $key ]
+ Parameter #2 [ <optional> mixed $value = <default> ]
+ Parameter #3 [ <optional> int $flags = <default> ]
+ Parameter #4 [ <optional> int $exptime = <default> ]
+ Parameter #5 [ <optional> int $cas = <default> ]
+ }
+ - Return [ bool ]
}
Function [ <internal:memcache> function memcache_append ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <required> MemcachePool $memcache ]
+ Parameter #1 [ <required> array|string $key ]
+ Parameter #2 [ <optional> mixed $value = <default> ]
+ Parameter #3 [ <optional> int $flags = <default> ]
+ Parameter #4 [ <optional> int $exptime = <default> ]
+ Parameter #5 [ <optional> int $cas = <default> ]
+ }
+ - Return [ bool ]
}
Function [ <internal:memcache> function memcache_prepend ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <required> MemcachePool $memcache ]
+ Parameter #1 [ <required> array|string $key ]
+ Parameter #2 [ <optional> mixed $value = <default> ]
+ Parameter #3 [ <optional> int $flags = <default> ]
+ Parameter #4 [ <optional> int $exptime = <default> ]
+ Parameter #5 [ <optional> int $cas = <default> ]
+ }
+ - Return [ bool ]
}
Function [ <internal:memcache> function memcache_get ] {
- Parameters [4] {
- Parameter #0 [ <required> $param0 ]
- Parameter #1 [ <required> $param1 ]
- Parameter #2 [ <required> &$param2 ]
- Parameter #3 [ <required> &$param3 ]
+ Parameter #0 [ <required> MemcachePool $memcache ]
+ Parameter #1 [ <required> $key ]
+ Parameter #2 [ <optional> &$flags = <default> ]
+ Parameter #3 [ <optional> &$cas = <default> ]
}
+ - Return [ mixed ]
}
Function [ <internal:memcache> function memcache_delete ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> MemcachePool $memcache ]
+ Parameter #1 [ <required> $key ]
+ Parameter #2 [ <optional> $exptime = <default> ]
+ }
+ - Return [ array|bool ]
}
Function [ <internal:memcache> function memcache_debug ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $on_off ]
+ }
+ - Return [ bool ]
}
Function [ <internal:memcache> function memcache_get_stats ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> MemcachePool $memcache ]
+ Parameter #1 [ <optional> string $type = <default> ]
+ Parameter #2 [ <optional> int $slabid = <default> ]
+ Parameter #3 [ <optional> int $limit = <default> ]
+ }
+ - Return [ array|bool ]
}
Function [ <internal:memcache> function memcache_get_extended_stats ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> MemcachePool $memcache ]
+ Parameter #1 [ <optional> string $type = <default> ]
+ Parameter #2 [ <optional> int $slabid = <default> ]
+ Parameter #3 [ <optional> int $limit = <default> ]
+ }
+ - Return [ array|bool ]
}
Function [ <internal:memcache> function memcache_set_compress_threshold ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> MemcachePool $memcache ]
+ Parameter #1 [ <required> int $threshold ]
+ Parameter #2 [ <optional> float $min_savings = <default> ]
+ }
+ - Return [ bool ]
}
Function [ <internal:memcache> function memcache_increment ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> MemcachePool $memcache ]
+ Parameter #1 [ <required> array|string $key ]
+ Parameter #2 [ <optional> int $value = <default> ]
+ Parameter #3 [ <optional> int $defval = <default> ]
+ Parameter #4 [ <optional> int $exptime = <default> ]
+ }
+ - Return [ array|int|bool ]
}
Function [ <internal:memcache> function memcache_decrement ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> MemcachePool $memcache ]
+ Parameter #1 [ <required> array|string $key ]
+ Parameter #2 [ <optional> int $value = <default> ]
+ Parameter #3 [ <optional> int $defval = <default> ]
+ Parameter #4 [ <optional> int $exptime = <default> ]
+ }
+ - Return [ array|int|bool ]
}
Function [ <internal:memcache> function memcache_close ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> MemcachePool $memcache ]
+ }
+ - Return [ bool ]
}
Function [ <internal:memcache> function memcache_flush ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> MemcachePool $memcache ]
+ Parameter #1 [ <optional> int $delay = <default> ]
+ }
+ - Return [ bool ]
}
Function [ <internal:memcache> function memcache_set_sasl_auth_data ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> MemcachePool $memcache ]
+ Parameter #1 [ <required> string $username ]
+ Parameter #2 [ <required> string $password ]
+ }
+ - Return [ bool ]
}
}
@@ -147,78 +344,242 @@ Extension [ <persistent> extension #81 memcache version 4.0.5.2 ] {
- Methods [23] {
Method [ <internal:memcache> public method connect ] {
+
+ - Parameters [7] {
+ Parameter #0 [ <required> $host ]
+ Parameter #1 [ <optional> $tcp_port = <default> ]
+ Parameter #2 [ <optional> $udp_port = <default> ]
+ Parameter #3 [ <optional> $persistent = <default> ]
+ Parameter #4 [ <optional> $weight = <default> ]
+ Parameter #5 [ <optional> $timeout = <default> ]
+ Parameter #6 [ <optional> $retry_interval = <default> ]
+ }
}
Method [ <internal:memcache> public method addserver ] {
+
+ - Parameters [8] {
+ Parameter #0 [ <required> $host ]
+ Parameter #1 [ <optional> $tcp_port = <default> ]
+ Parameter #2 [ <optional> $udp_port = <default> ]
+ Parameter #3 [ <optional> $persistent = <default> ]
+ Parameter #4 [ <optional> $weight = <default> ]
+ Parameter #5 [ <optional> $timeout = <default> ]
+ Parameter #6 [ <optional> $retry_interval = <default> ]
+ Parameter #7 [ <optional> $status = <default> ]
+ }
+ - Return [ bool ]
}
Method [ <internal:memcache> public method setserverparams ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <required> string $host ]
+ Parameter #1 [ <optional> int $tcp_port = <default> ]
+ Parameter #2 [ <optional> float $timeout = <default> ]
+ Parameter #3 [ <optional> int $retry_interval = <default> ]
+ Parameter #4 [ <optional> bool $status = <default> ]
+ Parameter #5 [ <optional> $failure_callback = <default> ]
+ }
+ - Return [ bool ]
}
Method [ <internal:memcache> public method setfailurecallback ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> ?callable $failure_callback ]
+ }
+ - Return [ bool ]
}
Method [ <internal:memcache> public method getserverstatus ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $host ]
+ Parameter #1 [ <optional> int $tcp_port = <default> ]
+ }
+ - Return [ int|bool ]
}
Method [ <internal:memcache> public method findserver ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $key ]
+ }
+ - Return [ string|bool ]
}
Method [ <internal:memcache> public method getversion ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string|bool ]
}
Method [ <internal:memcache> public method add ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> array|string $key ]
+ Parameter #1 [ <optional> mixed $value = <default> ]
+ Parameter #2 [ <optional> int $flags = <default> ]
+ Parameter #3 [ <optional> int $exptime = <default> ]
+ Parameter #4 [ <optional> int $cas = <default> ]
+ }
+ - Return [ bool ]
}
Method [ <internal:memcache> public method set ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> array|string $key ]
+ Parameter #1 [ <optional> mixed $value = <default> ]
+ Parameter #2 [ <optional> int $flags = <default> ]
+ Parameter #3 [ <optional> int $exptime = <default> ]
+ Parameter #4 [ <optional> int $cas = <default> ]
+ }
+ - Return [ bool ]
}
Method [ <internal:memcache> public method replace ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> array|string $key ]
+ Parameter #1 [ <optional> mixed $value = <default> ]
+ Parameter #2 [ <optional> int $flags = <default> ]
+ Parameter #3 [ <optional> int $exptime = <default> ]
+ Parameter #4 [ <optional> int $cas = <default> ]
+ }
+ - Return [ bool ]
}
Method [ <internal:memcache> public method cas ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> array|string $key ]
+ Parameter #1 [ <optional> mixed $value = <default> ]
+ Parameter #2 [ <optional> int $flags = <default> ]
+ Parameter #3 [ <optional> int $exptime = <default> ]
+ Parameter #4 [ <optional> int $cas = <default> ]
+ }
+ - Return [ bool ]
}
Method [ <internal:memcache> public method append ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> array|string $key ]
+ Parameter #1 [ <optional> mixed $value = <default> ]
+ Parameter #2 [ <optional> int $flags = <default> ]
+ Parameter #3 [ <optional> int $exptime = <default> ]
+ Parameter #4 [ <optional> int $cas = <default> ]
+ }
+ - Return [ bool ]
}
Method [ <internal:memcache> public method prepend ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> array|string $key ]
+ Parameter #1 [ <optional> mixed $value = <default> ]
+ Parameter #2 [ <optional> int $flags = <default> ]
+ Parameter #3 [ <optional> int $exptime = <default> ]
+ Parameter #4 [ <optional> int $cas = <default> ]
+ }
+ - Return [ bool ]
}
Method [ <internal:memcache> public method get ] {
- Parameters [3] {
- Parameter #0 [ <required> $param0 ]
- Parameter #1 [ <required> &$param1 ]
- Parameter #2 [ <required> &$param2 ]
+ Parameter #0 [ <required> array|string $key ]
+ Parameter #1 [ <optional> mixed &$flags = <default> ]
+ Parameter #2 [ <optional> mixed &$cas = <default> ]
}
+ - Return [ mixed ]
}
Method [ <internal:memcache> public method delete ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> array|string $key ]
+ Parameter #1 [ <optional> int $exptime = <default> ]
+ }
+ - Return [ array|bool ]
}
Method [ <internal:memcache> public method getstats ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> string $type = <default> ]
+ Parameter #1 [ <optional> int $slabid = <default> ]
+ Parameter #2 [ <optional> int $limit = <default> ]
+ }
+ - Return [ array|bool ]
}
Method [ <internal:memcache> public method getextendedstats ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> string $type = <default> ]
+ Parameter #1 [ <optional> int $slabid = <default> ]
+ Parameter #2 [ <optional> int $limit = <default> ]
+ }
+ - Return [ array|bool ]
}
Method [ <internal:memcache> public method setcompressthreshold ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $threshold ]
+ Parameter #1 [ <optional> float $min_savings = <default> ]
+ }
+ - Return [ bool ]
}
Method [ <internal:memcache> public method increment ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> array|string $key ]
+ Parameter #1 [ <optional> int $value = <default> ]
+ Parameter #2 [ <optional> int $defval = <default> ]
+ Parameter #3 [ <optional> int $exptime = <default> ]
+ }
+ - Return [ array|int|bool ]
}
Method [ <internal:memcache> public method decrement ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> array|string $key ]
+ Parameter #1 [ <optional> int $value = <default> ]
+ Parameter #2 [ <optional> int $defval = <default> ]
+ Parameter #3 [ <optional> int $exptime = <default> ]
+ }
+ - Return [ array|int|bool ]
}
Method [ <internal:memcache> public method close ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
}
Method [ <internal:memcache> public method flush ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> int $delay = <default> ]
+ }
+ - Return [ bool ]
}
Method [ <internal:memcache> public method setSaslAuthData ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $username ]
+ Parameter #1 [ <required> string $password ]
+ }
+ - Return [ bool ]
}
}
}
@@ -239,81 +600,257 @@ Extension [ <persistent> extension #81 memcache version 4.0.5.2 ] {
- Methods [24] {
Method [ <internal:memcache, overwrites MemcachePool, prototype MemcachePool> public method connect ] {
+
+ - Parameters [8] {
+ Parameter #0 [ <required> $host ]
+ Parameter #1 [ <optional> $port = <default> ]
+ Parameter #2 [ <optional> $timeout = <default> ]
+ Parameter #3 [ <optional> $unused4 = <default> ]
+ Parameter #4 [ <optional> $unused5 = <default> ]
+ Parameter #5 [ <optional> $unused6 = <default> ]
+ Parameter #6 [ <optional> $unused7 = <default> ]
+ Parameter #7 [ <optional> $unugsed8 = <default> ]
+ }
}
Method [ <internal:memcache> public method pconnect ] {
+
+ - Parameters [8] {
+ Parameter #0 [ <required> $host ]
+ Parameter #1 [ <optional> $port = <default> ]
+ Parameter #2 [ <optional> $timeout = <default> ]
+ Parameter #3 [ <optional> $unused4 = <default> ]
+ Parameter #4 [ <optional> $unused5 = <default> ]
+ Parameter #5 [ <optional> $unused6 = <default> ]
+ Parameter #6 [ <optional> $unused7 = <default> ]
+ Parameter #7 [ <optional> $unugsed8 = <default> ]
+ }
}
Method [ <internal:memcache, overwrites MemcachePool, prototype MemcachePool> public method addserver ] {
+
+ - Parameters [8] {
+ Parameter #0 [ <required> $host ]
+ Parameter #1 [ <optional> $tcp_port = <default> ]
+ Parameter #2 [ <optional> $persistent = <default> ]
+ Parameter #3 [ <optional> $weight = <default> ]
+ Parameter #4 [ <optional> $timeout = <default> ]
+ Parameter #5 [ <optional> $retry_interval = <default> ]
+ Parameter #6 [ <optional> $status = <default> ]
+ Parameter #7 [ <optional> $failure_callback = <default> ]
+ }
+ - Return [ bool ]
}
Method [ <internal:memcache, inherits MemcachePool> public method setserverparams ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <required> string $host ]
+ Parameter #1 [ <optional> int $tcp_port = <default> ]
+ Parameter #2 [ <optional> float $timeout = <default> ]
+ Parameter #3 [ <optional> int $retry_interval = <default> ]
+ Parameter #4 [ <optional> bool $status = <default> ]
+ Parameter #5 [ <optional> $failure_callback = <default> ]
+ }
+ - Return [ bool ]
}
Method [ <internal:memcache, inherits MemcachePool> public method setfailurecallback ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> ?callable $failure_callback ]
+ }
+ - Return [ bool ]
}
Method [ <internal:memcache, inherits MemcachePool> public method getserverstatus ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $host ]
+ Parameter #1 [ <optional> int $tcp_port = <default> ]
+ }
+ - Return [ int|bool ]
}
Method [ <internal:memcache, inherits MemcachePool> public method findserver ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $key ]
+ }
+ - Return [ string|bool ]
}
Method [ <internal:memcache, inherits MemcachePool> public method getversion ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string|bool ]
}
Method [ <internal:memcache, inherits MemcachePool> public method add ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> array|string $key ]
+ Parameter #1 [ <optional> mixed $value = <default> ]
+ Parameter #2 [ <optional> int $flags = <default> ]
+ Parameter #3 [ <optional> int $exptime = <default> ]
+ Parameter #4 [ <optional> int $cas = <default> ]
+ }
+ - Return [ bool ]
}
Method [ <internal:memcache, inherits MemcachePool> public method set ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> array|string $key ]
+ Parameter #1 [ <optional> mixed $value = <default> ]
+ Parameter #2 [ <optional> int $flags = <default> ]
+ Parameter #3 [ <optional> int $exptime = <default> ]
+ Parameter #4 [ <optional> int $cas = <default> ]
+ }
+ - Return [ bool ]
}
Method [ <internal:memcache, inherits MemcachePool> public method replace ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> array|string $key ]
+ Parameter #1 [ <optional> mixed $value = <default> ]
+ Parameter #2 [ <optional> int $flags = <default> ]
+ Parameter #3 [ <optional> int $exptime = <default> ]
+ Parameter #4 [ <optional> int $cas = <default> ]
+ }
+ - Return [ bool ]
}
Method [ <internal:memcache, inherits MemcachePool> public method cas ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> array|string $key ]
+ Parameter #1 [ <optional> mixed $value = <default> ]
+ Parameter #2 [ <optional> int $flags = <default> ]
+ Parameter #3 [ <optional> int $exptime = <default> ]
+ Parameter #4 [ <optional> int $cas = <default> ]
+ }
+ - Return [ bool ]
}
Method [ <internal:memcache, inherits MemcachePool> public method append ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> array|string $key ]
+ Parameter #1 [ <optional> mixed $value = <default> ]
+ Parameter #2 [ <optional> int $flags = <default> ]
+ Parameter #3 [ <optional> int $exptime = <default> ]
+ Parameter #4 [ <optional> int $cas = <default> ]
+ }
+ - Return [ bool ]
}
Method [ <internal:memcache, inherits MemcachePool> public method prepend ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> array|string $key ]
+ Parameter #1 [ <optional> mixed $value = <default> ]
+ Parameter #2 [ <optional> int $flags = <default> ]
+ Parameter #3 [ <optional> int $exptime = <default> ]
+ Parameter #4 [ <optional> int $cas = <default> ]
+ }
+ - Return [ bool ]
}
Method [ <internal:memcache, inherits MemcachePool> public method get ] {
- Parameters [3] {
- Parameter #0 [ <required> $param0 ]
- Parameter #1 [ <required> &$param1 ]
- Parameter #2 [ <required> &$param2 ]
+ Parameter #0 [ <required> array|string $key ]
+ Parameter #1 [ <optional> mixed &$flags = <default> ]
+ Parameter #2 [ <optional> mixed &$cas = <default> ]
}
+ - Return [ mixed ]
}
Method [ <internal:memcache, inherits MemcachePool> public method delete ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> array|string $key ]
+ Parameter #1 [ <optional> int $exptime = <default> ]
+ }
+ - Return [ array|bool ]
}
Method [ <internal:memcache, inherits MemcachePool> public method getstats ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> string $type = <default> ]
+ Parameter #1 [ <optional> int $slabid = <default> ]
+ Parameter #2 [ <optional> int $limit = <default> ]
+ }
+ - Return [ array|bool ]
}
Method [ <internal:memcache, inherits MemcachePool> public method getextendedstats ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> string $type = <default> ]
+ Parameter #1 [ <optional> int $slabid = <default> ]
+ Parameter #2 [ <optional> int $limit = <default> ]
+ }
+ - Return [ array|bool ]
}
Method [ <internal:memcache, inherits MemcachePool> public method setcompressthreshold ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $threshold ]
+ Parameter #1 [ <optional> float $min_savings = <default> ]
+ }
+ - Return [ bool ]
}
Method [ <internal:memcache, inherits MemcachePool> public method increment ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> array|string $key ]
+ Parameter #1 [ <optional> int $value = <default> ]
+ Parameter #2 [ <optional> int $defval = <default> ]
+ Parameter #3 [ <optional> int $exptime = <default> ]
+ }
+ - Return [ array|int|bool ]
}
Method [ <internal:memcache, inherits MemcachePool> public method decrement ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> array|string $key ]
+ Parameter #1 [ <optional> int $value = <default> ]
+ Parameter #2 [ <optional> int $defval = <default> ]
+ Parameter #3 [ <optional> int $exptime = <default> ]
+ }
+ - Return [ array|int|bool ]
}
Method [ <internal:memcache, inherits MemcachePool> public method close ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
}
Method [ <internal:memcache, inherits MemcachePool> public method flush ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> int $delay = <default> ]
+ }
+ - Return [ bool ]
}
Method [ <internal:memcache, inherits MemcachePool> public method setSaslAuthData ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $username ]
+ Parameter #1 [ <required> string $password ]
+ }
+ - Return [ bool ]
}
}
}
diff --git a/php-pecl-memcache.spec b/php-pecl-memcache.spec
index 754af65..7c38c19 100644
--- a/php-pecl-memcache.spec
+++ b/php-pecl-memcache.spec
@@ -11,25 +11,26 @@
%scl_package php-pecl-memcache
%endif
-%global pecl_name memcache
# Not ready, some failed UDP tests. Neded investigation.
-%global with_tests 0%{?_with_tests:1}
+%bcond_with tests
+
+%global pecl_name memcache
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
Summary: Extension to work with the Memcached caching daemon
Name: %{?scl_prefix}php-pecl-memcache
-Version: 4.0.5.2
+Version: 8.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
License: PHP
URL: https://pecl.php.net/package/%{pecl_name}
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel > 7
+BuildRequires: %{?scl_prefix}php-devel >= 8.0
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: zlib-devel
-%if %{with_tests}
+%if %{with tests}
BuildRequires: memcached
%endif
@@ -58,21 +59,17 @@ Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "7.1"
Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.3"
Obsoletes: php73-pecl-%{pecl_name} <= %{version}
Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "8.0"
+Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -100,9 +97,10 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
pushd NTS
+sed -e '/PHP_MEMCACHE_VERSION/s/4.0.5.2/%{version}/' -i src/php_memcache.h
+
# Check version as upstream often forget to update this
-dir=php7
-extver=$(sed -n '/#define PHP_MEMCACHE_VERSION/{s/.* "//;s/".*$//;p}' $dir/php_memcache.h)
+extver=$(sed -n '/#define PHP_MEMCACHE_VERSION/{s/.* "//;s/".*$//;p}' src/php_memcache.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
: Error: Upstream version is now ${extver}, expecting %{version}%{?prever:-%{prever}}
: Update the pdover macro and rebuild.
@@ -140,9 +138,9 @@ extension=%{pecl_name}.so
; Lock Timeout
;memcache.lock_timeout = 15
-;memcache.prefix_host_key = 0
-;memcache.prefix_host_key_remove_www = 1
-;memcache.prefix_host_key_remove_subdomain = 0
+;memcache.prefix_host_key = Off
+;memcache.prefix_host_key_remove_www = On
+;memcache.prefix_host_key_remove_subdomain = Off
;memcache.prefix_static_key = ''
; ----- Options to use the memcache session handler
@@ -156,9 +154,9 @@ extension=%{pecl_name}.so
; Defines a comma separated of server urls to use for session storage
; Only used when memcache.session_save_path is not set
;session.save_path="tcp://localhost:11211?persistent=1&weight=1&timeout=1&retry_interval=15"
-;memcache.session_prefix_host_key = 0
-;memcache.session_prefix_host_key_remove_www = 1
-;memcache.session_prefix_host_key_remove_subdomain = 0
+;memcache.session_prefix_host_key = Off
+;memcache.session_prefix_host_key_remove_www = On
+;memcache.session_prefix_host_key_remove_subdomain = On
;memcache.session_prefix_static_key = ''
;memcache.session_save_path = ''
EOF
@@ -218,7 +216,7 @@ done
-m | grep %{pecl_name}
%endif
-%if %{with_tests}
+%if %{with tests}
: Configuration for tests
cd NTS
sed -e "s:/var/run/memcached/memcached.sock:$PWD/memcached.sock:" \
@@ -281,6 +279,10 @@ fi
%changelog
+* Mon Dec 7 2020 Remi Collet <remi@remirepo.net> - 8.0-1
+- update to 8.0
+- raise dependency on PHP 8.0
+
* Fri Dec 20 2019 Remi Collet <remi@remirepo.net> - 4.0.5.2-1
- update to 4.0.5.2 (no change)