summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-04-10 18:55:14 +0200
committerRemi Collet <fedora@famillecollet.com>2014-04-10 18:55:14 +0200
commitf78688b235687a8ac1a3df94732320e1aa6f33f8 (patch)
treeeafa706bc31ec7411c47b1bf4ce3b849199a53bf
parent14c0842d1eec04ac29513bc7c12b866ad95a03fb (diff)
php-pecl: add numerical prefix to extension configuration file (5)
-rw-r--r--php-pecl-memcache.spec24
1 files changed, 16 insertions, 8 deletions
diff --git a/php-pecl-memcache.spec b/php-pecl-memcache.spec
index 7ef7275..e0a9b25 100644
--- a/php-pecl-memcache.spec
+++ b/php-pecl-memcache.spec
@@ -14,11 +14,16 @@
# Not ready, some failed UDP tests. Neded investigation.
%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
%global with_zts 0%{?__ztsphp:1}
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
Summary: Extension to work with the Memcached caching daemon
Name: php-pecl-memcache
Version: 3.0.8
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -46,18 +51,18 @@ Provides: php-pecl(%{pecl_name})%{?_isa} = %{version}
Provides: php-%{pecl_name} = %{version}
Provides: php-%{pecl_name}%{?_isa} = %{version}
+%if "%{?vendor}" == "Remi Collet"
# Other third party repo stuff
Obsoletes: php53-pecl-%{pecl_name}
Obsoletes: php53u-pecl-%{pecl_name}
-%if "%{php_version}" > "5.4"
Obsoletes: php54-pecl-%{pecl_name}
-%endif
%if "%{php_version}" > "5.5"
Obsoletes: php55u-pecl-%{pecl_name}
%endif
%if "%{php_version}" > "5.6"
Obsoletes: php56u-pecl-%{pecl_name}
%endif
+%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
# Filter shared private
@@ -92,7 +97,7 @@ if test "x${extver}" != "x%{version}"; then
fi
popd
-cat >%{pecl_name}.ini << 'EOF'
+cat >%{ini_name} << 'EOF'
; ----- Enable %{pecl_name} extension module
extension=%{pecl_name}.so
@@ -158,11 +163,11 @@ rm -rf %{buildroot}
make -C NTS install INSTALL_ROOT=%{buildroot}
# Drop in the bit of configuration
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_inidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
%if %{with_zts}
make -C ZTS install INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Install XML package description
@@ -238,15 +243,18 @@ fi
%doc %{pecl_docdir}/%{pecl_name}
%doc %{pecl_testdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
-%config(noreplace) %{php_inidir}/%{pecl_name}.ini
+%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
%{php_ztsextdir}/%{pecl_name}.so
%endif
%changelog
+* Thu Apr 10 2014 Remi Collet <remi@fedoraproject.org> - 3.0.8-3
+- add numerical prefix to extension configuration file
+
* Fri Mar 7 2014 Remi Collet <remi@fedoraproject.org> - 3.0.8-2
- cleanups
- install doc in pecl_docdir