summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-10-06 11:29:57 +0200
committerRemi Collet <remi@remirepo.net>2017-10-06 11:29:57 +0200
commitd43f1e8fe272487815100b016da44e9dfe6c3404 (patch)
tree91d077dbdaa56168eb210a31ddfc277d65286fcf
parent36052ea3278abe639088429859b59195af1ed873 (diff)
refresh to more recent snapshot
add patch from https://github.com/websupport-sk/pecl-memcache/issues/23
-rw-r--r--memcache-session.patch13
-rw-r--r--php-pecl-memcache.spec21
2 files changed, 26 insertions, 8 deletions
diff --git a/memcache-session.patch b/memcache-session.patch
new file mode 100644
index 0000000..eec0bd1
--- /dev/null
+++ b/memcache-session.patch
@@ -0,0 +1,13 @@
+diff --git a/php7/memcache_session.c b/php7/memcache_session.c
+index dd2434a..45ba97d 100644
+--- a/php7/memcache_session.c
++++ b/php7/memcache_session.c
+@@ -289,7 +289,7 @@ PS_READ_FUNC(memcache)
+ ZVAL_NULL(&addresult);
+
+ /* third request fetches the data, data is only valid if either of the lock requests succeeded */
+- ZVAL_NULL(&dataresult);
++ ZVAL_EMPTY_STRING(&dataresult);
+
+ /* create requests */
+ if (php_mmc_session_read_request(pool, &zkey, lockparam, &addresult, dataparam, &lockrequest, &addrequest, &datarequest) != MMC_OK) {
diff --git a/php-pecl-memcache.spec b/php-pecl-memcache.spec
index 002fa9d..82c21b2 100644
--- a/php-pecl-memcache.spec
+++ b/php-pecl-memcache.spec
@@ -12,11 +12,11 @@
%endif
# https://github.com/websupport-sk/pecl-memcache/commits/NON_BLOCKING_IO_php7
-%global gh_commit df7735e813d247ea141458e1774d163ad4e2d068
+%global gh_commit e702b5f91ec222e20d1d5cea0ffc6be012992d70
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner websupport-sk
%global gh_project pecl-memcache
-%global gh_date 20161124
+%global gh_date 20170802
%global pecl_name memcache
# Not ready, some failed UDP tests. Neded investigation.
%global with_tests 0%{?_with_tests:1}
@@ -31,19 +31,17 @@ Summary: Extension to work with the Memcached caching daemon
Name: %{?scl_prefix}php-pecl-memcache
Version: 3.0.9
%if 0%{?gh_date:1}
-Release: 0.8.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 0.9.%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
%endif
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
-%if 0%{?gh_date:1}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
-%else
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-%endif
+Patch0: %{pecl_name}-session.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel
@@ -135,6 +133,9 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
pushd NTS
+%if "%{php_version}" > "7.1"
+%patch0 -p1 -b .gh23
+%endif
# Chech version as upstream often forget to update this
dir=php$(%{__php} -r 'echo PHP_MAJOR_VERSION;')
@@ -312,6 +313,10 @@ fi
%changelog
+* Fri Oct 6 2017 Remi Collet <remi@remirepo.net> - 3.0.9-0.9.20170802.e702b5f
+- refresh to more recent snapshot
+- add patch from https://github.com/websupport-sk/pecl-memcache/issues/23
+
* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 3.0.9-0.8.20161124gitdf7735e
- rebuild for PHP 7.2.0beta1 new API