summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-12-19 10:05:06 +0100
committerRemi Collet <remi@remirepo.net>2019-12-19 10:05:06 +0100
commit909c5e81af578e4792613a967f8d110658154db5 (patch)
tree06c1b1fbfdcc32d88c9a6b11fca1808241a695f4
parent730fc2be6262d1365aff51535565624d16f4a2c7 (diff)
- update to 4.0.5
- switch back to sources from PECL
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION14
-rw-r--r--php-pecl-memcache.spec31
3 files changed, 18 insertions, 29 deletions
diff --git a/PHPINFO b/PHPINFO
index a36f627..5fe8b0b 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
memcache
memcache support => enabled
-Version => 4.0.4
+Version => 4.0.5
Revision => $Revision$
Directive => Local Value => Master Value
diff --git a/REFLECTION b/REFLECTION
index 3e5d15f..1eac796 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #119 memcache version 4.0.4 ] {
+Extension [ <persistent> extension #81 memcache version 4.0.5 ] {
- INI {
Entry [ memcache.allow_failover <ALL> ]
@@ -64,12 +64,12 @@ Extension [ <persistent> extension #119 memcache version 4.0.4 ] {
}
- Constants [6] {
- Constant [ integer MEMCACHE_COMPRESSED ] { 2 }
- Constant [ integer MEMCACHE_USER1 ] { 65536 }
- Constant [ integer MEMCACHE_USER2 ] { 131072 }
- Constant [ integer MEMCACHE_USER3 ] { 262144 }
- Constant [ integer MEMCACHE_USER4 ] { 524288 }
- Constant [ integer MEMCACHE_HAVE_SESSION ] { 1 }
+ Constant [ int MEMCACHE_COMPRESSED ] { 2 }
+ Constant [ int MEMCACHE_USER1 ] { 65536 }
+ Constant [ int MEMCACHE_USER2 ] { 131072 }
+ Constant [ int MEMCACHE_USER3 ] { 262144 }
+ Constant [ int MEMCACHE_USER4 ] { 524288 }
+ Constant [ int MEMCACHE_HAVE_SESSION ] { 1 }
}
- Functions {
diff --git a/php-pecl-memcache.spec b/php-pecl-memcache.spec
index 8fd3ec3..b817081 100644
--- a/php-pecl-memcache.spec
+++ b/php-pecl-memcache.spec
@@ -11,13 +11,6 @@
%scl_package php-pecl-memcache
%endif
-# https://github.com/websupport-sk/pecl-memcache/commits/NON_BLOCKING_IO_php7
-%global gh_commit 837d86f8e579ac6d73631841b3bd24f391de62ce
-%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner websupport-sk
-%global gh_project pecl-memcache
-%global gh_date 20190319
-#global prever dev
%global pecl_name memcache
# Not ready, some failed UDP tests. Neded investigation.
%global with_tests 0%{?_with_tests:1}
@@ -26,13 +19,9 @@
Summary: Extension to work with the Memcached caching daemon
Name: %{?scl_prefix}php-pecl-memcache
-Version: 4.0.4
-%if 0%{?prever:1}
-Release: 4%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-%else
-Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-%endif
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
+Version: 4.0.5
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
License: PHP
URL: http://pecl.php.net/package/%{pecl_name}
@@ -78,11 +67,11 @@ Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
+Obsoletes: php73-pecl-%{pecl_name} <= %{version}
Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-%{pecl_name} <= %{version}
+Obsoletes: php74-pecl-%{pecl_name} <= %{version}
Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -109,12 +98,7 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -c -q
-%if 1
-mv %{gh_project}-%{gh_commit} NTS
-mv NTS/package.xml .
-%else
mv %{pecl_name}-%{version} NTS
-%endif
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
@@ -123,6 +107,7 @@ sed -e 's/role="test"/role="src"/' \
pushd NTS
# Chech version as upstream often forget to update this
+sed -e '/PHP_MEMCACHE_VERSION/s/4.0.4/4.0.5/' -i */php_memcache.h
dir=php7
extver=$(sed -n '/#define PHP_MEMCACHE_VERSION/{s/.* "//;s/".*$//;p}' $dir/php_memcache.h)
@@ -304,6 +289,10 @@ fi
%changelog
+* Thu Dec 19 2019 Remi Collet <remi@remirepo.net> - 4.0.5-1
+- update to 4.0.5
+- switch back to sources from PECL
+
* Tue Sep 03 2019 Remi Collet <remi@remirepo.net> - 4.0.4-4
- rebuild for 7.4.0RC1