summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-12-02 08:43:37 +0100
committerRemi Collet <remi@php.net>2024-12-02 08:43:37 +0100
commit10f80b5084772ca502050a76fbd60bc1eac6d2c7 (patch)
treed5c87444bc836c8a8a48609f71e80645ddb43400
initial package, version 1.0.0dev
open https://github.com/eklausme/php-md4c/issues/12 version inconsistency open https://github.com/eklausme/php-md4c/issues/13 PHP version compatibility
-rw-r--r--.gitignore9
-rw-r--r--Makefile4
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION18
-rw-r--r--php-pecl-md4c.spec123
5 files changed, 160 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..8babbf0
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,6 @@
+
+md4c
+
+MD4C => enabled
+PHP-MD4C version => 1.1
+MD4C version => 0.5.2
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..979121b
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,18 @@
+Extension [ <persistent> extension #87 md4c version 1.0 ] {
+
+ - Constants [2] {
+ Constant [ int MD4C_DIALECT_GITHUB ] { 3852 }
+ Constant [ int MD4C_FLAG_NOINDENTEDCODEBLOCKS ] { 16 }
+ }
+
+ - Functions {
+ Function [ <internal:md4c> function md4c_toHtml ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $str ]
+ Parameter #1 [ <required> $flag ]
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-md4c.spec b/php-pecl-md4c.spec
new file mode 100644
index 0000000..d19ed5e
--- /dev/null
+++ b/php-pecl-md4c.spec
@@ -0,0 +1,123 @@
+# remirepo spec file for php-pecl-md4c
+#
+# Copyright (c) 2024 Remi Collet
+# License: CC-BY-SA-4.0
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+
+%{?scl:%scl_package php-pecl-md4c}
+
+%global pecl_name md4c
+%global ini_name 40-%{pecl_name}.ini
+%global upstream_version 1.0.0
+%global upstream_prever dev
+%global upstream_rpmrel DEV
+%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
+
+Summary: Convert Markdown to HTML
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
+Version: %{upstream_version}%{?upstream_prever:~%{upstream_rpmrel}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+# Copy/paste library http://github.com/mity/md4c is MIT
+# Extension is MIT
+License: MIT
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
+
+BuildRequires: make
+BuildRequires: %{?dtsprefix}gcc
+# See https://github.com/eklausme/php-md4c/issues/13
+BuildRequires: %{?scl_prefix}php-devel >= 8.0
+BuildRequires: %{?scl_prefix}php-pear
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+
+Provides: bundled(md4c) = 0.5.2
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+
+
+%description
+This extension provides one simple PHP function md4c_toHtml() to convert
+Markdown or CommonMark to HTML.
+
+This function uses the MD4C library written in C and is currently the fastest
+conversion routine,
+see https://talk.commonmark.org/t/why-is-md4c-so-fast-c/2520/12
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl})}.
+
+
+%prep
+%setup -q -c
+# Don't install/register tests
+sed -e 's/role="test"/role="src"/' \
+ -e '/LICENSE/s/role="doc"/role="src"/' \
+ -i package.xml
+
+# Drop in the bit of configuration
+cat > %{ini_name} << 'EOF'
+; Enable %{pecl_name} extension module
+extension = %{pecl_name}.so
+EOF
+
+
+%build
+%{?dtsenable}
+
+cd %{sources}
+%{__phpize}
+[ -f Makefile.global ] && GLOBAL=Makefile.global || GLOBAL=build/Makefile.global
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i $GLOBAL
+
+%configure \
+ --enable-md4c \
+ --with-php-config=%{__phpconfig}
+
+%make_build
+
+
+%install
+%{?dtsenable}
+cd %{sources}
+
+: Install the extension
+%make_install
+
+: Install the configuration file
+install -D -m 644 ../%{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+: Install the package XML file
+install -D -m 644 ../package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+: Install Documentation
+for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%check
+: Minimal load test for NTS extension
+%{__php} --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+
+
+%files
+%license %{sources}/LICENSE*
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+
+%changelog
+* Mon Dec 2 2024 Remi Collet <remi@remirepo.net> - 1.0.0~DEV-1
+- initial package, version 1.0.0dev
+- open https://github.com/eklausme/php-md4c/issues/12 version inconsistency
+- open https://github.com/eklausme/php-md4c/issues/13 PHP version compatibility