summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-05-23 12:47:59 +0200
committerRemi Collet <remi@php.net>2022-05-23 12:47:59 +0200
commit121e3737094d8a3bdeaeb3b3d53fed5827cfda2b (patch)
tree796f68fc20498f374eba4f37a7430d2c4880d169
parentb3296e1eecbdbb37e3493e5aa0729a90a26d3b79 (diff)
update to 1.0.5
-rw-r--r--0001-add-extension-version-in-phpinfo.patch26
-rw-r--r--0002-drop-null-value-deprecated-in-8.1.patch100
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION26
-rw-r--r--php-pecl-mcrypt.spec15
5 files changed, 20 insertions, 149 deletions
diff --git a/0001-add-extension-version-in-phpinfo.patch b/0001-add-extension-version-in-phpinfo.patch
deleted file mode 100644
index 44af7f2..0000000
--- a/0001-add-extension-version-in-phpinfo.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 6cf8c800f2926b65867b10dfe582bbb4596d1b7e Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@php.net>
-Date: Wed, 2 Dec 2020 11:37:43 +0100
-Subject: [PATCH 1/2] add extension version in phpinfo
-
----
- mcrypt.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/mcrypt.c b/mcrypt.c
-index 20f6aae..b834ffe 100644
---- a/mcrypt.c
-+++ b/mcrypt.c
-@@ -480,7 +480,8 @@ PHP_MINFO_FUNCTION(mcrypt) /* {{{ */
- php_info_print_table_start();
- php_info_print_table_header(2, "mcrypt support", "enabled");
- php_info_print_table_header(2, "mcrypt_filter support", "enabled");
-- php_info_print_table_row(2, "Version", LIBMCRYPT_VERSION);
-+ php_info_print_table_row(2, "Extension version", PHP_MCRYPT_VERSION);
-+ php_info_print_table_row(2, "Library version", LIBMCRYPT_VERSION);
- php_info_print_table_row(2, "Api No", mcrypt_api_no);
- php_info_print_table_row(2, "Supported ciphers", ZSTR_VAL(tmp1.s));
- php_info_print_table_row(2, "Supported modes", ZSTR_VAL(tmp2.s));
---
-2.31.1
-
diff --git a/0002-drop-null-value-deprecated-in-8.1.patch b/0002-drop-null-value-deprecated-in-8.1.patch
deleted file mode 100644
index 3554ff3..0000000
--- a/0002-drop-null-value-deprecated-in-8.1.patch
+++ /dev/null
@@ -1,100 +0,0 @@
-From 5b16bf1c97c1bbab400fc877285bf0919ae73256 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@php.net>
-Date: Wed, 9 Jun 2021 10:49:51 +0200
-Subject: [PATCH 2/2] drop null value, deprecated in 8.1
-
----
- tests/mcrypt_rijndael128_128BitKey.phpt | 30 ++++++-------------------
- 1 file changed, 7 insertions(+), 23 deletions(-)
-
-diff --git a/tests/mcrypt_rijndael128_128BitKey.phpt b/tests/mcrypt_rijndael128_128BitKey.phpt
-index ffc5e39..84abac8 100644
---- a/tests/mcrypt_rijndael128_128BitKey.phpt
-+++ b/tests/mcrypt_rijndael128_128BitKey.phpt
-@@ -32,14 +32,12 @@ $data = 'This is the secret message which must be encrypted';
-
- // keys up to 128 bits (16 bytes)
- $keys = array(
-- null,
- '',
- '12345678',
- '1234567890123456'
- );
- // rijndael128 is a block cipher of 128 bits (16 bytes)
- $ivs = array(
-- null,
- '',
- '12345678',
- '1234567890123456',
-@@ -72,61 +70,47 @@ foreach ($ivs as $iv) {
-
- key length=0
-
--Deprecated: Function mcrypt_encrypt() is deprecated in %s%emcrypt_rijndael128_128BitKey.php on line 45
--
--Warning: mcrypt_encrypt(): Key of size 0 not supported by this algorithm. Only keys of sizes 16, 24 or 32 supported in %s on line %d
--string(0) ""
--
--key length=0
--
--Deprecated: Function mcrypt_encrypt() is deprecated in %s%emcrypt_rijndael128_128BitKey.php on line 45
-+Deprecated: Function mcrypt_encrypt() is deprecated in %s%emcrypt_rijndael128_128BitKey.php on line %d
-
- Warning: mcrypt_encrypt(): Key of size 0 not supported by this algorithm. Only keys of sizes 16, 24 or 32 supported in %s on line %d
- string(0) ""
-
- key length=8
-
--Deprecated: Function mcrypt_encrypt() is deprecated in %s%emcrypt_rijndael128_128BitKey.php on line 45
-+Deprecated: Function mcrypt_encrypt() is deprecated in %s%emcrypt_rijndael128_128BitKey.php on line %d
-
- Warning: mcrypt_encrypt(): Key of size 8 not supported by this algorithm. Only keys of sizes 16, 24 or 32 supported in %s on line %d
- string(0) ""
-
- key length=16
-
--Deprecated: Function mcrypt_encrypt() is deprecated in %s%emcrypt_rijndael128_128BitKey.php on line 45
-+Deprecated: Function mcrypt_encrypt() is deprecated in %s%emcrypt_rijndael128_128BitKey.php on line %d
- string(128) "dc8f957ec530acf10cd95ba7da7b6405380fe19a2941e9a8de54680512f18491bc374e5464885ae6c2ae2aa7a6cdd2fbe12a06bbc4bd59dbbfaa15f09044f101"
-
- --- testing different iv lengths
-
- iv length=0
-
--Deprecated: Function mcrypt_decrypt() is deprecated in %s%emcrypt_rijndael128_128BitKey.php on line 53
--
--Warning: mcrypt_decrypt(): Received initialization vector of size 0, but size 16 is required for this encryption mode in %s on line %d
--string(0) ""
--
--iv length=0
--
--Deprecated: Function mcrypt_decrypt() is deprecated in %s%emcrypt_rijndael128_128BitKey.php on line 53
-+Deprecated: Function mcrypt_decrypt() is deprecated in %s%emcrypt_rijndael128_128BitKey.php on line %d
-
- Warning: mcrypt_decrypt(): Received initialization vector of size 0, but size 16 is required for this encryption mode in %s on line %d
- string(0) ""
-
- iv length=8
-
--Deprecated: Function mcrypt_decrypt() is deprecated in %s%emcrypt_rijndael128_128BitKey.php on line 53
-+Deprecated: Function mcrypt_decrypt() is deprecated in %s%emcrypt_rijndael128_128BitKey.php on line %d
-
- Warning: mcrypt_decrypt(): Received initialization vector of size 8, but size 16 is required for this encryption mode in %s on line %d
- string(0) ""
-
- iv length=16
-
--Deprecated: Function mcrypt_decrypt() is deprecated in %s%emcrypt_rijndael128_128BitKey.php on line 53
-+Deprecated: Function mcrypt_decrypt() is deprecated in %s%emcrypt_rijndael128_128BitKey.php on line %d
- string(32) "42adc8c0db19473f2c684ff2d6e828a5"
-
- iv length=17
-
--Deprecated: Function mcrypt_decrypt() is deprecated in %s%emcrypt_rijndael128_128BitKey.php on line 53
-+Deprecated: Function mcrypt_decrypt() is deprecated in %s%emcrypt_rijndael128_128BitKey.php on line %d
-
- Warning: mcrypt_decrypt(): Received initialization vector of size 17, but size 16 is required for this encryption mode in %s on line %d
- string(0) ""
---
-2.31.1
-
diff --git a/PHPINFO b/PHPINFO
index b11e4d6..0187842 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,7 +3,7 @@ mcrypt
mcrypt support => enabled
mcrypt_filter support => enabled
-Extension version => 1.0.4
+Extension version => 1.0.5
Library version => 2.5.8
Api No => 20021217
Supported ciphers => cast-128 gost rijndael-128 twofish arcfour cast-256 loki97 rijndael-192 saferplus wake blowfish-compat des rijndael-256 serpent xtea blowfish enigma rc2 tripledes
diff --git a/REFLECTION b/REFLECTION
index 7d48f0b..ac13705 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #119 mcrypt version 1.0.4 ] {
+Extension [ <persistent> extension #56 mcrypt version 1.0.5 ] {
- INI {
Entry [ mcrypt.algorithms_dir <ALL> ]
@@ -78,19 +78,19 @@ Extension [ <persistent> extension #119 mcrypt version 1.0.4 ] {
- Parameters [2] {
Parameter #0 [ <required> $size ]
- Parameter #1 [ <optional> $source ]
+ Parameter #1 [ <optional> $source = <default> ]
}
}
Function [ <internal, deprecated:mcrypt> function mcrypt_list_algorithms ] {
- Parameters [1] {
- Parameter #0 [ <optional> $lib_dir ]
+ Parameter #0 [ <optional> $lib_dir = <default> ]
}
}
Function [ <internal, deprecated:mcrypt> function mcrypt_list_modes ] {
- Parameters [1] {
- Parameter #0 [ <optional> $lib_dir ]
+ Parameter #0 [ <optional> $lib_dir = <default> ]
}
}
Function [ <internal, deprecated:mcrypt> function mcrypt_get_iv_size ] {
@@ -107,7 +107,7 @@ Extension [ <persistent> extension #119 mcrypt version 1.0.4 ] {
Parameter #1 [ <required> $key ]
Parameter #2 [ <required> $data ]
Parameter #3 [ <required> $mode ]
- Parameter #4 [ <optional> $iv ]
+ Parameter #4 [ <optional> $iv = <default> ]
}
}
Function [ <internal, deprecated:mcrypt> function mcrypt_decrypt ] {
@@ -117,7 +117,7 @@ Extension [ <persistent> extension #119 mcrypt version 1.0.4 ] {
Parameter #1 [ <required> $key ]
Parameter #2 [ <required> $data ]
Parameter #3 [ <required> $mode ]
- Parameter #4 [ <optional> $iv ]
+ Parameter #4 [ <optional> $iv = <default> ]
}
}
Function [ <internal, deprecated:mcrypt> function mcrypt_module_open ] {
@@ -221,49 +221,49 @@ Extension [ <persistent> extension #119 mcrypt version 1.0.4 ] {
- Parameters [2] {
Parameter #0 [ <required> $algorithm ]
- Parameter #1 [ <optional> $lib_dir ]
+ Parameter #1 [ <optional> $lib_dir = <default> ]
}
}
Function [ <internal, deprecated:mcrypt> function mcrypt_module_is_block_algorithm_mode ] {
- Parameters [2] {
Parameter #0 [ <required> $mode ]
- Parameter #1 [ <optional> $lib_dir ]
+ Parameter #1 [ <optional> $lib_dir = <default> ]
}
}
Function [ <internal, deprecated:mcrypt> function mcrypt_module_is_block_algorithm ] {
- Parameters [2] {
Parameter #0 [ <required> $algorithm ]
- Parameter #1 [ <optional> $lib_dir ]
+ Parameter #1 [ <optional> $lib_dir = <default> ]
}
}
Function [ <internal, deprecated:mcrypt> function mcrypt_module_is_block_mode ] {
- Parameters [2] {
Parameter #0 [ <required> $mode ]
- Parameter #1 [ <optional> $lib_dir ]
+ Parameter #1 [ <optional> $lib_dir = <default> ]
}
}
Function [ <internal, deprecated:mcrypt> function mcrypt_module_get_algo_block_size ] {
- Parameters [2] {
Parameter #0 [ <required> $algorithm ]
- Parameter #1 [ <optional> $lib_dir ]
+ Parameter #1 [ <optional> $lib_dir = <default> ]
}
}
Function [ <internal, deprecated:mcrypt> function mcrypt_module_get_algo_key_size ] {
- Parameters [2] {
Parameter #0 [ <required> $algorithm ]
- Parameter #1 [ <optional> $lib_dir ]
+ Parameter #1 [ <optional> $lib_dir = <default> ]
}
}
Function [ <internal, deprecated:mcrypt> function mcrypt_module_get_supported_key_sizes ] {
- Parameters [2] {
Parameter #0 [ <required> $algorithm ]
- Parameter #1 [ <optional> $lib_dir ]
+ Parameter #1 [ <optional> $lib_dir = <default> ]
}
}
Function [ <internal, deprecated:mcrypt> function mcrypt_module_close ] {
diff --git a/php-pecl-mcrypt.spec b/php-pecl-mcrypt.spec
index f1c126f..304291d 100644
--- a/php-pecl-mcrypt.spec
+++ b/php-pecl-mcrypt.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-mcrypt
#
-# Copyright (c) 2017-2021 Remi Collet
+# Copyright (c) 2017-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -18,16 +18,13 @@
Summary: Bindings for the libmcrypt library
Name: %{?scl_prefix}php-pecl-mcrypt
-Version: 1.0.4
-Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.0.5
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: https://pecl.php.net/package/mcrypt
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
-Patch0: 0001-add-extension-version-in-phpinfo.patch
-Patch1: 0002-drop-null-value-deprecated-in-8.1.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.2
@@ -91,9 +88,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1
-%patch1 -p1
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_MCRYPT_VERSION/{s/.* "//;s/".*$//;p}' php_mcrypt.h)
if test "x${extver}" != "x%{version}%{?prever}"; then
@@ -229,6 +223,9 @@ fi
%changelog
+* Mon May 23 2022 Remi Collet <remi@remirepo.net> - 1.0.5-1
+- update to 1.0.5
+
* Wed Sep 01 2021 Remi Collet <remi@remirepo.net> - 1.0.4-5
- rebuild for 8.1.0RC1