summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION5
-rw-r--r--php-pecl-mailparse.spec108
3 files changed, 58 insertions, 57 deletions
diff --git a/PHPINFO b/PHPINFO
index 36079f7..0f1d80c 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
mailparse
mailparse support => enabled
-Extension Version => 3.1.3
+Extension Version => 3.1.6
Directive => Local Value => Master Value
mailparse.def_charset => us-ascii => us-ascii
diff --git a/REFLECTION b/REFLECTION
index f19f96a..a3a7e67 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #83 mailparse version 3.1.3 ] {
+Extension [ <persistent> extension #84 mailparse version 3.1.6 ] {
- Dependencies {
Dependency [ mbstring (Required) ]
@@ -130,7 +130,8 @@ Extension [ <persistent> extension #83 mailparse version 3.1.3 ] {
- Static methods [0] {
}
- - Properties [0] {
+ - Properties [1] {
+ Property [ public $data = NULL ]
}
- Methods [10] {
diff --git a/php-pecl-mailparse.spec b/php-pecl-mailparse.spec
index 471feb1..d6f0602 100644
--- a/php-pecl-mailparse.spec
+++ b/php-pecl-mailparse.spec
@@ -3,7 +3,7 @@
#
# Fedora spec file for php-pecl-mailparse
#
-# Copyright (c) 2008-2022 Remi Collet
+# Copyright (c) 2008-2023 Remi Collet
# Copyright (c) 2004-2007 Matthias Saou
#
# License: MIT
@@ -12,29 +12,27 @@
# Please, preserve the changelog entries
#
-# we don't want -z defs linker flag
-%undefine _strict_symbol_defs_build
+%{?scl:%scl_package php-pecl-mailparse}
-%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
-%scl_package php-pecl-mailparse
-%endif
+%bcond_without tests
-%global pecl_name mailparse
-%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global ini_name 40-%{pecl_name}.ini
+%global pecl_name mailparse
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global ini_name 40-%{pecl_name}.ini
+%global sources %{pecl_name}-%{version}
+%global _configure ../%{sources}/configure
Summary: PHP PECL package for parsing and working with email messages
-Name: %{?sub_prefix}php-pecl-mailparse
-Version: 3.1.3
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-License: PHP
+Name: %{?scl_prefix}php-pecl-mailparse
+Version: 3.1.6
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+License: PHP-3.01
URL: https://pecl.php.net/package/mailparse
-Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Source0: https://pecl.php.net/get/%{sources}.tgz
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel >= 7.0
+BuildRequires: %{?scl_prefix}php-devel >= 7.3
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-mbstring
# Required by phpize
@@ -46,32 +44,11 @@ BuildRequires: autoconf, automake, libtool
Requires: %{?scl_prefix}php-mbstring%{?_isa}
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
-
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "8.0"
-Obsoletes: php80-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "8.1"
-Obsoletes: php81-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
%description
@@ -84,14 +61,12 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -q -c
-mv %{pecl_name}-%{version} NTS
-
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
%{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
-i package.xml
-cd NTS
+cd %{sources}
extver=$(sed -n '/#define PHP_MAILPARSE_VERSION/{s/.* "//;s/".*$//;p}' php_mailparse.h)
if test "x${extver}" != "x%{version}"; then
: Error: Upstream version is ${extver}, expecting %{version}.
@@ -107,23 +82,25 @@ extension = mailparse.so
;mailparse.def_charset = us-ascii
EOF
+mkdir NTS
%if %{with_zts}
-cp -pr NTS ZTS
+mkdir ZTS
%endif
%build
%{?dtsenable}
-cd NTS
-%{_bindir}/phpize
-%configure --with-php-config=%{_bindir}/php-config
+cd %{sources}
+%{__phpize}
+
+cd ../NTS
+%configure --with-php-config=%{__phpconfig}
make %{?_smp_mflags}
%if %{with_zts}
cd ../ZTS
-%{_bindir}/zts-phpize
-%configure --with-php-config=%{_bindir}/zts-php-config
+%configure --with-php-config=%{__ztsphpconfig}
make %{?_smp_mflags}
%endif
@@ -146,24 +123,27 @@ install -Dpm 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
# Documentation
for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+do install -Dpm 644 %{sources}/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
%check
+cd %{sources}
+
: Minimal load test for NTS extension
%{__php} --no-php-ini \
--define extension=mbstring.so \
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
--modules | grep '^%{pecl_name}$'
+%if %{with tests}
: Upstream test suite for NTS extension
-cd NTS
TEST_PHP_EXECUTABLE=%{__php} \
-%{__php} run-tests.php -n -q \
+%{__php} -n run-tests.php -n -q \
-d extension=mbstring.so \
- -d extension=$PWD/modules/%{pecl_name}.so \
+ -d extension=$PWD/../NTS/modules/%{pecl_name}.so \
--show-diff
+%endif
%if %{with_zts}
: Minimal load test for ZTS extension
@@ -172,14 +152,15 @@ TEST_PHP_EXECUTABLE=%{__php} \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
--modules | grep '^%{pecl_name}$'
+%if %{with tests}
: Upstream test suite for ZTS extension
-cd ../ZTS
TEST_PHP_EXECUTABLE=%{__ztsphp} \
-php run-tests.php -n -q \
+%{__ztsphp} -n run-tests.php -n -q \
-d extension=mbstring.so \
- -d extension=$PWD/modules/%{pecl_name}.so \
+ -d extension=$PWD/../ZTS/modules/%{pecl_name}.so \
--show-diff
%endif
+%endif
%if 0%{?fedora} < 24 && 0%{?rhel} < 8
@@ -203,7 +184,7 @@ fi
%files
-%{?_licensedir:%license NTS/LICENSE}
+%{?_licensedir:%license %{sources}/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -217,6 +198,25 @@ fi
%changelog
+* Wed Aug 30 2023 Remi Collet <remi@remirepo.net> - 3.1.6-2
+- rebuild for PHP 8.3.0RC1
+
+* Tue Aug 22 2023 Remi Collet <remi@remirepo.net> - 3.1.6-1
+- update to 3.1.6
+
+* Thu Jul 27 2023 Remi Collet <remi@remirepo.net> - 3.1.5-1
+- update to 3.1.5
+- build out of sources tree
+
+* Tue Jun 6 2023 Remi Collet <remi@remirepo.net> - 3.1.4-2
+- add upstream patches for PHP 8.3
+
+* Thu Sep 15 2022 Remi Collet <remi@remirepo.net> - 3.1.4-1
+- update to 3.1.4
+
+* Tue May 24 2022 Remi Collet <remi@remirepo.net> - 3.1.3-2
+- add upstream patch for PHP 8.2
+
* Mon Feb 21 2022 Remi Collet <remi@remirepo.net> - 3.1.3-1
- update to 3.1.3